PHP Opcode Caching

  • Wähle ich als PHP die Version 7.2.15 aus, dann ist PHP Opcode Caching aktiviert. Wenn ich hingegen PHP 7.3 (aktuell PHP 7.3.2) wähle, dann ist kein Opcode Caching vorhanden, wie auch ein Blick auf phpinfo zeigt.


    Gibt es einen Grund, warum bei PHP 7.3.x kein PHP Opcode Caching aktiviert ist? Oder wurde es beim Erstellen der PHP-Version vergessen?


    Tschüss

    Uwe

  • Gerade noch mal nachgeschaut: Beim PHP 7.2.15 (FPM/Fast-CGI) vom Feb 8 2019 11:52:09 ist das Opcode-Caching definitiv aktiviert. Aber beim PHP 7.3.2 (CGI/FastCGI) vom Feb 12 2019 15:13:08 ist es nicht mit eincompiliert.

    Gerade noch mal nachgeforscht, es liegt wohlt an den eingestellten Parametern. Wenn einer davon unterhalb der minimal empfohlenen Werte liegt, dann meckert Nextcloud, dass der Opcode-Cache nicht aktiviert sei. Tolle Wurst. APCu scheint es allerdings wirklich nicht zu geben.