URL's richtig einrichten wenn Wordpress in Subdirectory installiert ist

  • Hi,


    ich bin vor kurzem von einem anderen Webhoster zu Netcup umgezogen und habe noch ein kleines Problem.


    Ich habe z.B. die Domain ranayoga.com, die ich im CCP registriert habe. Ich habe dann im WCP im Menü links auf Wordpress geklickt und dann auf Install.


    Als Installationspfad habe ich https://ranayoga.com/ranayoga angegeben, da ich noch andere Websites habe und ich nicht will, dass alle Websites im gleichen Ordner liegen.


    Die Website wurde also unter httpdocs/ranayoga installiert. Ich habe dann meine alte Website mit der gleichen URL ranayoga.com über das Plugin Duplicator migriert.


    Ich habe dann im Ordner httpdocs eine .htaccess Datei erstellt mit diesem Inhalt, damit ich, wenn ich auf ranayoga.com gehe, ich auf meine Website weitergeleitet werde, ansonsten müsste ich ranayoga.com/ranayoga eingeben, um auf die Website zu kommen:

    Code
    1. <IfModule mod_rewrite.c>
    2. RewriteEngine on
    3. RewriteCond %{HTTP_HOST} ^(www.)?ranayoga.com$
    4. RewriteCond %{REQUEST_URI} !^/ranayoga/
    5. RewriteCond %{REQUEST_FILENAME} !-f
    6. RewriteCond %{REQUEST_FILENAME} !-d
    7. RewriteRule ^(.*)$ /ranayoga/$1
    8. RewriteCond %{HTTP_HOST} ^(www.)?ranayoga.com$
    9. RewriteRule ^(/)?$ ranayoga/index.php [L]
    10. </IfModule>


    Wenn ich nun aber auf ranayoga.com gehe, werde ich zu ranayoga.com/ranayoga/ weitergeleitet.


    Dieses zweite ranayoga nach dem Slash will ich nicht in der URL, die Leute sollen auf ranayoga.com bleiben.


    Ich bin dann hingegangen und habe im Wordpress Dashboard unter Settings / General die Site Address (URL) von https://ranayoga.com/ranayoga auf https://ranayoga.com/ geändert. Die WordPress Address (URL) habe ich bei https://ranayoga.com/ranayoga belassen.


    Das führt dann zwar dazu, dass wenn man auf ranayoga.com geht, man nicht mehr auf ranayoga.com/ranayoga weitergeleitet wird, aber wenn ich z.B. auf die Page "Kontakt" klicke, kommt dann diese Fehlermeldung:

    1.jpg


    Wisst ihr was ich tun könnte, damit ich weiterhin meine Website in einem Unterordner von httpdocs installiert lassen kann und meine home URL ranayoga.com und meine Page URL's z.B. "ranayoga.com/contact" sein können und nicht "ranayoga.com/ranayoga/contact" ?


    Schon mal Danke für eure Hilfe! :)

  • und ich nicht will, dass alle Websites im gleichen Ordner liegen.

    Das ist schon mal der richtige Ansatz, aber deine Umsetzung ist meiner Meinung nach fehleranfällig.


    Ich würde hierfür folgende Umsetzung wählen:

    - eigene Ordnerstruktur für Domains anlegen

    - fürs DocumentRoot keine Unterordner einer anderen Domain für neue Domains wählen

    Beispiel:

    /mywebsites/www-domain1-de/

    /mywebsites/sub-domain1-de/

    /mywebsites/www-domain2-de/

    /mywebsites/sub-domain2-de/

    usw.


    (ich habe es, da ich es übersichtlicher finde, für mich sogar noch weiter gesplittet: /mywebsites/domain.de/www/, usw.).


    Vorteil: übersichtlicher und etwaige .htaccess-Dateien oder Unterordner beeinträchtigen keine anderen Webseiten die in tieferen Ordnern liegen.

  • Ich versteh das leider noch nicht, vielleicht könntest du mir nochmal konkreter sagen, wie du es empfehlen würdest.


    Wenn ich eine neue Website installiere, klicke ich im WCP Menü links auf Wordpress, dann Install, wähle dann als Installation Path die Domain aus, deren Website ich installieren will und gib dann zusätzlich noch in das dritte Feld hinter dem / den Unterordner an, also z.B. ranayoga.

    2.jpg

    So würdest du es nicht vorschlagen?


    Obwohl ich als Installationspfad die Domain auswähle, landen dann ja trotzdem alle Dateien unter hostingXXXX.XXXX.netcup.net / httpdocs / domain1,2,3,...


    Das hat mich auch verwundert, aber ich befasse mich jetzt auch zum ersten Mal mit dem Dateisystem.

  • Leider funktionieren die Links zu den Pages noch immer nicht.


    Ich habe nun im CCP unter Produkte meine Domain ranayoga.com ausgewählt und dann den Dokumentenstamm wie folgt geändert:

    1.jpg


    Daraufhin habe ich im WCP im Menüpunkt Wordpress eine neue Website installiert und zwar mit diesem Installationspfad:

    2.jpg


    Die Website wurde wie erwartet im File Manager hier installiert:

    1.jpg


    Ich habe dann meine alte Website von meinem vorherigen Webhoster, welche ich mit Duplicator exportiert habe, ins Dateisystem hochgeladen und installiert.


    Im Wordpress Dashboard unter Settings / General steht nun folgendes:

    pasted-from-clipboard.png


    Die Home Seite ist so wie es sein soll über ranayoga.com erreichbar. Die Links funktionieren aber nicht, z.B. die Seite Kontakt ist nicht über https://ranayoga.com/kontakt/ erreichbar, es kommt folgende Fehlermeldung:

    pasted-from-clipboard.png


    Ich habe im Wordpress Dashboard versucht eine neue Page zu erstellen, um zu sehen, ob diese erreichbar ist und vielleicht nur die Seiten meiner alten Website nicht erreichbar sind, welche ich über Duplicator migriert habe. Beim Versuch die Page zu erstellen kam diese Fehlermeldung, vielleicht lag es daran, dass ich den Website Builder Divi verwende:

    pasted-from-clipboard.png


    Ich habe den Fehler gegoogled, es wurde empfohlen das Plugin "Classic Editor" zu installieren und zu aktivieren. Dadurch konnte ich wieder Pages erstellen, die Page test1 ist aber auch nicht erreichbar.


    Ich bin wie gesagt noch Anfänger und check leider nicht ganz durch, vielleicht wisst ihr ja, wo mein Fehler liegt und was ich tun muss, damit ich z.B. die Kontakt Page über https://ranayoga.com/kontakt/ erreichen kann.


    Danke! 🙂

  • wo mein Fehler liegt und was ich tun muss, damit ich z.B. die Kontakt Page über https://ranayoga.com/kontakt/ erreichen kann.

    Was steht denn in den Errorlogs? 500er müssten dort auftauchen. Ggf gibt es dort ja mehr Details.

    Siehe dazu:

    https://www.netcup-wiki.de/wik…nel_Webhosting#Protokolle

    Oder direkt auf Dateiebene unter /logs/<domain>/*


    Könnte mir vorstellen, dass die .htaccess-Datei nicht ganz valide ist.

  • Danke für deine Hilfe DerRené!


    Zum 500er Error steht dort folgendes

    pasted-from-clipboard.png


    Ansonsten tauchen noch diese drei Errors auf

    pasted-from-clipboard.png

    pasted-from-clipboard.png

    pasted-from-clipboard.png


    Quote

    Könnte mir vorstellen, dass die .htaccess-Datei nicht ganz valide ist.

    Die .htaccess Datei habe ich wieder gelöscht, ich dachte die wird nicht mehr benötigt, da ich jetzt den Dokumentenstamm geändert habe.

  • Die .htaccess Datei habe ich wieder gelöscht

    Ich bin nun kein Wordpress-Profi, aber ich meine viele (alle?) Wordinstallationen benötigen eben diese. Vor allem wenn es um solche schicken Urls wie "domain.de/kontakt/" geht. Schließlich geht das ja gar nicht ohne Redirect - der Ordner existiert ja gar nicht auf dem Dateisystemm. Und auch die Fehlermeldung bzgl zu vieler redirects deutet in dieselbe Richtung. Ich gehe davon aus, dass im Verzeichnis noch eine .htaccess existiert, sonst käme es gar nicht zu der Fehlermeldung.

    Wie die Datei nun aber genau auszusehen hat, kann dir entweder ein anderer Forenteilnehmer genauer sagen oder ggf. die Suchmaschine deines Vertrauens - ich bin da leider bei Wordpress raus und wollte nur einen Denkanstoß geben. :)

  • Ich gehe davon aus, dass im Verzeichnis noch eine .htaccess existiert, sonst käme es gar nicht zu der Fehlermeldung.

    Du hast Recht, im Dateisystem im Ordner "www", also da wo die Website installiert wurde, ist eine .htaccess Datei.


    Dort steht:


    Und hier sind noch viele weitere .htaccess Dateien:

    pasted-from-clipboard.png


    Ich habe mal noch im Wordpress Forum nachgefragt, vielleicht weiß da jemand was los ist, alleine komm ich nämlich glaub nicht mehr weiter 😑

  • Es läuft jetzt 😁🥰


    Im Wordpress Forum hat einer geschrieben, dass die Internal server errors (error 500) häufig durch Plugins veursacht werden und daran lags.


    Leider weiß ich nicht an welchem, weil ich die unnötigen gelöscht habe, bevor ich sie wieder einzeln aktiviert hab. Aber nun tut alles, nochmal vielen lieben Dank für deine Hilfe DerRené!!! 😊😁