Cronjobs werden 60 mal ausgeführt wobei diese ja nur 1x gestartet werden

  • Hallo Forum Mitglieder,


    ich habe folgendes Problem das in einem EXPERT Tarif der Angelegte Cronjob der ja einmal nur ausgeführt werden soll bis zu 60 mal ausgeführt wird.


    ich lasse folgendes Script durchlaufen:

    Code
    1. # DATENBANK DUMP GZIP
    2. mysqldump -h10.xx.xx.178 -ukxxxxx_xxxxx -pxxxxx kxxxxx_xxxxx | gzip > /backup/xxxxxx/db/xxxxx_xxxxxx.`date +\%y\%m\%d\_%T`.sql.gz
    3. # ARCHIV TAR GZIP
    4. tar -czPf /backup/xxxxx/site/xxxxx.`date +\%y\%m\%d\_%T`.tar.gz /httpdocs/xxxxx_xxxxx/
    5. # DATENBANK DUMP GZIP nach 30 Tage loeschen
    6. find /backup/xxxxx/db/ -type f -name 'xxxxx_xxxxx.*' -mtime +30 -delete
    7. # ARCHIV TAR GZIP nach 30 tage loeschen
    8. find /backup/xxxxx/site/ -type f -name 'xxxxx.*' -mtime +30 -delete

    Liegt es eventuell an der "FIND" Funktion das er keine 30 älteren DUMPS findet und dadurch einen Fehler setzt?


    gruß,

    talkuvit

  • Hay,


    ich glaube nicht, dass es an Deinem Script liegt - da ist keine Iteration enthalten.


    Mach mal

    Code
    1. crontab -l

    und gib das Ergebnis der Zeile, welche den Cronjob ausführen soll. Bei "bis zu 60 mal" ist schon stark zu vermuten, dass da ein Parameter bei den Zeitangaben vorher verrutscht ist :) bzw. ganz vorne ein * steht.


    Code
    1. * * * * * auszuführender Befehl
    2. ┬ ┬ ┬ ┬ ┬
    3. │ │ │ │ │
    4. │ │ │ │ └──── Wochentag (0-7, Sonntag ist 0 oder 7)
    5. │ │ │ └────── Monat (1-12)
    6. │ │ └──────── Tag (1-31)
    7. │ └────────── Stunde (0-23)
    8. └──────────── Minute (0-59)


    Sagen wir mal, der Cronjob soll einmal am Tag ausgeführt werden, dann legt man die Zeit fest (sinnigerweise irgendwann in der low-traffic-zeit und das ein bisserl variiert):


    Code
    1. 12 4 * * * /root/bin/mycronjob.sh


    Heisst, der Job wird täglich (* bei Tag) um 04:12 nachts (Serverzeit) ausgeführt.


    Code
    1. * 4 * * * /root/bin/mycronjob.sh


    Heisst, der Job wird täglich (* bei Tag) um 4 Uhr jede Minute einmal (* bei Minuten) ausgeführt.


    Tipp am Rande: Man sollte aufgrund nicht konsistenter Einstellungen keinen Cron-Job zwischen 02:00 und 03:00 Uhr Nachts ausführen, das gibt unvermutete Ergbnisse an den Tagen der Sommerzeit/Winterzeit-Umstellung.


    CU, Peter

  • Hallo alle Zusammen,


    danke Ihr Seid spitze hier im Forum.


    Es war wirklich der kleine simple Fehler wie Ihn CmdrXay vermutet hat.

    (in Parameter bei den Zeitangaben vorher verrutscht ist :) bzw. ganz vorne ein * stand)


    Danke für die Hinweise und Ideen von euch.


    gruß,

    talkuvit