Owncloud 8.1.1 Webhosting Expert M

  • Hey,
    ich habe gerade frisch auf einem Webhosting Expert M Tarif eine Owncloudinstallation (Version 8.1.1) durchgeführt.


    Nun bekomme ich im Admin-Bereich folgende Warnungen angezeigt:


    Quote

    Sicherheits- & Einrichtungswarnungen

    • Dieser Server hat keine funktionierende Internetverbindung. Dies bedeutet, dass einige Funktionen wie das Einhängen externen Speicherplatzes, Update-Benachrichtigungen oder die Installation von Drittanbieter-Apps nicht funktionieren werden. Der Fernzugriff auf Dateien und der Versand von E-Mail-Benachrichtigungen kann ebenfalls nicht funktionieren. Es wird empfohlen, die Internetverbindung dieses Servers zu aktivieren, wenn Sie alle Funktionen nutzen möchten.
    • Es wurde kein PHP Memory Cache konfiguriert. Konfiguriere zur Erhöhung der Leistungsfähigkeit, soweit verfügbar, einen Memory Cache. Weitere Informationen finden Sie in unsererDokumentation.
    • /dev/urandom ist von PHP nicht lesbar, wovon aus Sicherheitsgründen dringend abgeraten wird. Weitere Informationen hierzu finden Sie in unserer Dokumentation.
    • cURL is using an outdated NSS version (NSS/3.16.2.3 Basic ECC). Please update your operating system or features such as installing and updating apps via the app store or Federated Cloud Sharing will not work reliably.
    • Der „X-Frame-Options“-HTTP-Header ist nicht so konfiguriert, dass er „SAMEORIGIN“ entspricht. Dies ist ein potentielles Sicherheitsrisiko und es wird empfohlen, diese Einstellung zu ändern.
    • Der „Strict-Transport-Security“-HTTP-Header ist nicht auf mindestens „15768000“ Sekunden eingestellt. Für umfassende Sicherheit wird das Aktivieren von HSTS empfohlen, wie es in unseren Sicherheitshinweisen erläutert ist.


    Ich habe hier im Forum noch keine Hilfestellung diesbezüglich gefunden.
    Da ich hier jedoch schon von vielen hier gelesen habe, die in einem Webhostingpacket owncloud eingebunden haben muss es ja Lösungen für obige Meldungen geben.


    Ich hoffe ihr könnt mir weiterhelfen.


    Grüße Tino

  • Um die Sache noch etwas konkreter zu gestallten füge ich mal noch einige Fragen mit an.


    • Die fehlende Internetverbindung trifft nur in Teilen zu. Installiere ich z.B. eine veraltete Version (8.1.0) kann ich diese problemlos Über das Admin-Panel upgraden. Was jedoch nicht geht ist z.B. die Einbindung von externen WebDav-Speichern (läuft auf einer anderen Instanz [auf vServer] problemlos).

      Quote

      Exception: {"Exception":"OCP\\Files\\StorageNotAvailableException","Message":"Sabre\\HTTP\\ClientException: couldn't connect to host","Code":0,"Trace":"#0 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/lib\/private\/files\/storage\/dav.php(575): OC\\Files\\Storage\\DAV->convertException(Object(Sabre\\HTTP\\ClientException), '')\n#1 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/lib\/private\/files\/storage\/common.php(408): OC\\Files\\Storage\\DAV->stat('')\n#2 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/apps\/files_external\/lib\/config.php(497): OC\\Files\\Storage\\Common->test(false)\n#3 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/apps\/files_external\/controller\/storagescontroller.php(123): OC_Mount_Config::getBackendStatus('\\\\OC\\\\Files\\\\Stora...', Array, false)\n#4 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/apps\/files_external\/controller\/globalstoragescontroller.php(157): OCA\\Files_External\\Controller\\StoragesController->updateStorageStatus(Object(OCA\\Files_external\\Lib\\StorageConfig))\n#5 [internal function]: OCA\\Files_External\\Controller\\GlobalStoragesController->update(1, 'test', '\\\\OC\\\\Files\\\\Stora...', Array, NULL, Array, Array, 100)\n#6 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/lib\/private\/appframework\/http\/dispatcher.php(159): call_user_func_array(Array, Array)\n#7 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/lib\/private\/appframework\/http\/dispatcher.php(89): OC\\AppFramework\\Http\\Dispatcher->executeController(Object(OCA\\Files_External\\Controller\\GlobalStoragesController), 'update')\n#8 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/lib\/private\/appframework\/app.php(108): OC\\AppFramework\\Http\\Dispatcher->dispatch(Object(OCA\\Files_External\\Controller\\GlobalStoragesController), 'update')\n#9 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/lib\/private\/appframework\/routing\/routeactionhandler.php(45): OC\\AppFramework\\App::main('GlobalStoragesC...', 'update', Object(OC\\AppFramework\\DependencyInjection\\DIContainer), Array)\n#10 [internal function]: OC\\AppFramework\\routing\\RouteActionHandler->__invoke(Array)\n#11 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/lib\/private\/route\/router.php(274): call_user_func(Object(OC\\AppFramework\\routing\\RouteActionHandler), Array)\n#12 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/lib\/base.php(873): OC\\Route\\Router->match('\/apps\/files_ext...')\n#13 \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/index.php(40): OC::handleRequest()\n#14 {main}","File":"\/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/httpdocs\/tld.de\/oc\/lib\/private\/files\/storage\/dav.php","Line":814}


    • Ich finde keine Möglichkeit den Cache im WCP zu aktivieren oder ähnliches, heißt das, dass ich auf diese "Optimierung" verzichten muss?
    • auch open_basedir lässt sich im WCP nur auf {DOCROOT}, {WEBSPACEROOT} und {TMP} stellen. Gibt es eine Möglichkeit owncloud /dev/urandom vorzugaukeln?
    • bei dem Rest bin ich derzeit noch komplett ratlos



    Ich hoffe jemand kann mir helfen.


    Vorab vielen Dank


    Grüße Tino


  • Ganz genau, wie bei mir! Wäre schön, wenn wir das lösen könnten!


    S.

  • Also ich habe diesbezüglich bereits den Support kontaktiert.


    „Strict-Transport-Security“-HTTP-Header kann ja noch via htaccess gesetzt werden aber „X-Frame-Options“-HTTP-Header oder auch SSLCipherSuite jedoch nicht.



    Bezüglich der fehlenden Internetverbindung wurde mir vom Support bisher angeboten entsprechende IP-Adressen in der Firewall freizugeben. Aber das wäre ja auch nicht zielführend, aber eine Notlösung.


    Bei /dev/urandom wird es wohl darauf hinauslaufen, dass der Pfad in den PHP-Dateien von Owncloud relativ angegeben werden muss, damit das /dev Verzeichniss im Hostingpacket genutzt wird.



    Grüße Tino

  • Quote

    Dieser Server hat keine funktionierende Internetverbindung


    Diesen Fehler habe ich auf meinem vServer auch (obwohl ich 'has_internet_connection' auf true gesetzt habe in config.php).


    Scheint ein cURL/NSS problem mit PHP zu sein, siehe Error: server is not connected to the internet message - but I am, or so I think ... · Issue #16255 · owncloud/core · GitHub.


    Kann im Prinzip ignoriert werden, wenn OwnCloud soweit funktioniert. :)

    CentOS 7 / nginx / php-fpm / postfix / rspamd / clamav / dovecot / nextcloud running on RS 1000 SSDx4 G8 / VPS 500 G8 / VPS 2000 G8 Plus

    The post was edited 1 time, last by sdellenb ().

  • Vielen Dank für den Beitrag, habe das an den Support weitergeleitet.


    Interesannter Weise funktioniert ein Upgrade von 8.1.0 auf 8.1.1 online über das Admin-Interface problemlos, aber ich kann keine externen Speicher einbinden (Google, etc.).


    Grüße Tino

  • Als die Version 8.1.1 raus kam, hatte ich mal auf einem Testserver das Upgrade probiert und dabei kam auch der cURL Fehler, ein paar Tage später lief das Upgrade dann problemlos durch. Es scheint 3 Versionen von OC 8.1.1 zu geben, die neueste 8.1.1.3 hat einige Probleme behoben. Eventuell wird ja bei der Installation übers Webhostingpanel die erste Version 8.1.1.1 installiert, während bei einem Upgrade von 8.1.0 automatisch auf 8.1.1.3 aktualisiert wird. Am einfachsten findet man das raus indem man im Owncloudverzeichnis in die Datei version.php schaut. Da steht genau drin, welche Version gerade installiert ist...

  • Habe derzeit auch ein Problem mit dem Cron-Job

    Quote

    php -f /***/cron.php


    liefert einen Fehler zurück

    Quote

    PHP Parse error: syntax error, unexpected '[' in /***/lib/base.php on line 141


    Konnte dem bisher aber noch nicht weiter auf den Grund gehen.


  • Der gezeigte Fehler wird vermutlich durch eine verkürzte Array-Definition ([] ansttat array()) verursacht, die erst in neueren PHP-Versionen unterstützt wird. Versuche einmal den Befehl mit einer explizit neueren PHP-Version aufzurufen, siehe: /usr/bin/ erweitert



    MfG Christian


    Vielen Dank, dass war wieder zu einfach, aber du hast vollkommen recht!


    Jetzt gibt es zwar weitere Fehler, aber ein Schritt nach dem anderen ;)


    Quote

    Data directory (/var/www/vhosts/hosting1234.ab56c.netcup.net/***/data) is invalid
    Please check that the data directory contains a file ".ocdata" in its root.


    Cannot create "data" directory (/var/www/vhosts/hosting1234.ab56c.netcup.net/***/data)
    This can usually be fixed by <a href="https://doc.owncloud.org/serve…?to=admin-dir_permissions" target="_blank">giving the webserver write access to the root directory</a>.


    {"reqId":"ocOD8Ow21\/yNO3JgwZ+m","remoteAddr":"","app":"PHP","message":"touch(): Unable to create file \/var\/www\/vhosts\/hosting1234.ab56c.netcup.net\/***\/data\/owncloud.log because No such file or directory at \/***\/lib\/private\/log\/owncloud.php#53","level":3,"time":"2015-08-18T10:21:02+00:00","method":"--","url":"--"}

  • Beim Rest kann ich mangels Webhosting-Account und mangels ownCloud Installation nur raten.


    Überprüfe einfach einmal die Rechte des genannten Ordners und passe sie mittels FTP-Client notfalls an, zum Test wäre 775 oder 777 zu empfehlen. Falls die CLI-Scripte unter einem anderen Benutzer als der Webserver ausgeführt werden, wäre das ein üblicher Fehler. Dazu können andere Nutzer aber sicher mehr sagen, die selbst ein Webhosting Paket verwenden.



    MfG Christian

  • Guten Morgen,



    eines der Tickets habe ich gestern bearbeitet.


    Folgendes ist aktuell nicht änderbar:


    • cURL is using an outdated NSS version (NSS/3.16.2.3 Basic ECC).
      Please update your operating system or features such as installing and
      updating apps via the app store or Federated Cloud Sharing will not work
      reliably.

    Hier setzen wir auf die Version von CentOS 6. Diese ist entsprechend der Distribution aktuell. Wenn eine andere Version genutzt werden soll, muss ein Root-Server verwendet werden.


    • Es wurde kein PHP Memory Cache konfiguriert. Konfiguriere zur Erhöhung
      der Leistungsfähigkeit, soweit verfügbar, einen Memory Cache. Weitere
      Informationen finden Sie in unsererDokumentation.

    Dafür sollte auch auf ein eigenes System ausgewichen werden. Bei einem shared Webhosting können wir individuelle Caches nicht anbieten.
    Der „X-Frame-Options“-HTTP-Header kann per .htaccess gesetzt werden.


    • Dieser Server hat keine funktionierende Internetverbindung. Dies
      bedeutet, dass einige Funktionen wie das Einhängen externen
      Speicherplatzes, Update-Benachrichtigungen oder die Installation von
      Drittanbieter-Apps nicht funktionieren werden. Der Fernzugriff auf
      Dateien und der Versand von E-Mail-Benachrichtigungen kann ebenfalls
      nicht funktionieren. Es wird empfohlen, die Internetverbindung dieses
      Servers zu aktivieren, wenn Sie alle Funktionen nutzen möchten.

    Wenn hier auf externe Ports zugegriffen werden muss die nicht 80 oder 443 sind, schaltet die unser Support auf Anfrage frei. Bitte dafür auch die entsprechenden IP-Adressen nennen.



    Gibt es sonst noch Probleme?


    Mit freundlichen Grüßen


    Felix Preuß

  • Gibt es sonst noch Probleme?


    Mit freundlichen Grüßen


    Felix Preuß

    Lieber Herr Preuß,


    haben sie herzlichen Dank für Ihrer erklärenden Informationen.
    Ich habe verstanden, dass es im Moment leider nicht möglich ist eine owncloud Installation fehlerfrei auf einem Webhosting Paket zu installieren. Das finde ich enttäuschend, da m.E. owncloud keine besonders aussergewöhnliche Anwendung darstellt, sondern doch eher "Standard" (etwa wie auch Wordpress) ist.
    Da insbsondere die Installation vor dem owncloud-Update auf die Version 8.1 fehlerfrei auch auf Webhosting Paketen lief, bitte ich Sie ggf. nochmals zu prüfen, auch Kunden mit "kleineren" Paketen eine fehlerfeie Installation solcher Standard Applikation zu ermöglichen.


    Viele Grüße


    Stefan

  • Hallo Stefan,


    gibt es irgendwo noch Fehlermeldungen oder nur Warnungen in Ihrer Installation? Alle Warnungen werden auf einem shared Webhosting nicht beseitigt werden können, da ein shared Webhosting nicht die Funktionen eines eigenen Servers bietet, für das Owncloud durchaus gedacht ist.


    Ich selber habe privat ein Owncloud auf einem shared Webhosting am laufen. Die Warnungen (siehe letzten Post von mir) sind mir bekannt. Fehler gibt es jedoch keine.


    Ich wünsche einen angenehmen Sonntag!


    Mit freundlichen Grüßen


    Felix Preuß

  • Ich aktiviere das Thema hier nochmal.


    "open_basedir
    Die Liste der Verzeichnisse, die verwendet werden, um die Dateien, die von PHP geöffnet werden können, zu begrenzen.
    Wenn die Datei nicht in den angegebenen Verzeichnissen liegt, werden PHP-Skripte sie nicht öffnen.
    Zum Trennen von Verzeichnissen verwenden Sie bei Linux einen Doppelpunkt (:) und bei Windows ein Semikolon (;). Ein Beispiel für Linux: /dir/upload:/usr/tmp"



    Wäre wirklich praktisch, wenn dort /dev/urandom ist für PHP lesbar gemacht werden könnte.
    Von mir aus auch als erweitertes Auswahlfeld im Dropdown, wobei der Infotext eher das Fehlen eines Eingabefeldes deutet.



    Der fehlende "PHP Memory Cache" ist zu verschmerzen, da ich bisher keine Performance Probleme feststellen konnte.

  • Vielen Dank für die schnelle Antwort.


    Im WCP finde ich bei den PHP-Einstellungen zwar die Einstellmöglichkeiten für open_basedir,
    jedoch nur nur ein Dropdown Feld mit drei Einstellmöglichkeiten.
    Ein Feld "Eigenen Wert eingeben", wie bei anderen Einstellmöglichkeiten gibt es jedoch nicht.


    Siehe Screenshot im Anhang.
    Die blau unterlegte Einstellung war vorbelegt.

    open_base_dir.jpg