Wordpress Webhosting - keine Sitemap - keine Google Indexierung

  • Hallo liebes Forum,

    ich bin immer versucht alle Probleme ohne eigenen Beitrag zu lösen, hier komme ich allerdings seit Stunden nicht weiter, daher hoffe ich ihr könnt mir vielleicht Tipps geben.


    Lage:

    Ich habe den kleinen Webhosting-Tarif bei Netcup und dort eine Wordpress-Seite mit dem Theme Getqwid laufen: einfachmachen.ug


    Problem:

    Ich habe versucht die Seite von Google indexieren zu lassen über die Search Console. Automatisch funktioniert dies anscheinend nicht. Also habe ich die Indexierung vor 2 Tagen manuell beantragt. Bisher hat sich nichts getan. Also habe ich versucht eine Sitemap hochzuladen. Das Problem ist, dass Wordpress mir keine Sitemap erstellt (/wp-sitemap.xml bringt 404). Also habe ich ein externes SEO-Plugin (Yoast) für WP ausprobiert, aber auch das kann mir keine Sitemap.xml (ebenfalls Error 404) erstellen. Ich bin alle Troubleshooting-Optionen des Plugins durchgegangen, unter anderem habe ich eine Ausnahme für das Plugin in meine .htaccess im Ordner .composer eingefügt:


    pasted-from-clipboard.png


    Apache Configuration
    # Yoast SEO - XML Sitemap Rewrite Fix
    RewriteEngine On
    RewriteBase /
    RewriteRule ^sitemap_index.xml$ /index.php?sitemap=1 [L]
    RewriteRule ^locations.kml$ /index.php?sitemap=wpseo_local_kml [L]
    RewriteRule ^geo_sitemap.xml$ /index.php?sitemap=geo [L]
    RewriteRule ^([^/]+?)-sitemap([0-9]+)?.xml$ /index.php?sitemap=$1&sitemap_n=$2 [L]
    RewriteRule ^([a-z]+)?-?sitemap.xsl$ /index.php?yoast-sitemap-xsl=$1 [L]
    # END Yoast SEO - XML Sitemap Rewrite Fix

    Das hat leider nicht geholfen. Ich habe außerdem versucht die Option "Suchmaschinenindexierung" im CCP unter "Wordpress" auszuschalten.

    pasted-from-clipboard.png

    Leider hat auch dies nichts geholfen. In der Hilfe der Google Search Console steht, dass ich nichts unternehmen muss zur Indexierung, wenn ich einen Webhoster habe. Allerdings steht dort seit 2 Tagen:

    pasted-from-clipboard.png


    Ziel:

    Am liebsten würde ich die Sitemap von dem Yoast-Plugin in Wordpress erstellen lassen und die bei Google einreichen. Mache ich etwas mit der .htaccess falsch? Müsste die Datei in einem anderen Ordner liegen? Oder habt ihr sonst eine Idee, was genau das Problem sein könnte?


    Ich danke euch schon einmal im Voraus.

  • Moin,

    das aktuelle WP sollte automatisch die Datei; wp-sitemap.xml erstellt haben.

    Magst du bitte schauen ob die im Ordner liegt. Falls ja müsstest du deine .htaccess Einträge ändern / löschen.

    Vg.

  • Hallo Homwer,

    nein leider befindet sich die wp-sitemap.xml nicht im Ordner

    pasted-from-clipboard.png

    ist auch nicht über den Browser erreichbar: https://einfachmachen.ug/wp-sitemap.xml


    Das Problem besteht weiterhin, die Seite wurde weiterhin nicht indexiert. Ich habe über einen Online-Drittanbieter eine Sitemap.xml meiner Homepage erstellen lassen und gestern in der Google Search Console hochgeladen. Weiterhin keine Indexierung vorhanden. Ich schnall einfach nicht woran das liegen kann.

  • Hallo TBT,

    die von dir beschriebene Funktion war in WP deaktiviert. Ich habe zum Testen die Funktion mal aktiviert und wieder deaktiviert. Keine Veränderung. Es bleibt dabei:

    1. Weder WP noch Plugins erstellen eine sitemap.xml

    2. Google indexiert meine Seite nicht

  • Ich habe nun die Lösung gefunden, allerdings weiß ich nicht welcher dieser Schritte am Ende die Lösung gebracht hat. Für die Nachwelt:

    1. Ich habe diese Option im CCP in den Hosting-Einstellungen bei netcup aktiviert:

    pasted-from-clipboard.png

    2. Dann habe ich die .htaccess-Datei mit dem oben beschriebenen Inhalt in den Ordner "httpdocs" verschoben.


    Ich denke es war der zweite Schritt, der entscheidend war. Die htaccess-Datei im composer-Ordner zu haben war offensichtlich falsch.