Konfiguration von basic PHP auth

  • Einen schönen guten Abend,


    ich bin derzeit dabei von einem anderen Anbieter zu Linevast zu wechseln.

    Ich habe das Webhosting 4000 SE Paket gebucht.


    Unter einer meiner Domains läuft die Fotogalerie X3.

    Bei dieser bekomme ich leider das Problem, dass ich beim Einloggen (Seite global geschützt) in eine Dauerschleife bei der Anmeldung komme.

    Benutzername und Passwort stimmen. Es ist ein bekanntes, gelegentlich auftretendes, Problem mit PHP auth.


    Persönlich kenne ich mich auf der technischen Seite nicht wirklich gut aus um die Antwort genauer interpretieren bzw. damit weiterarbeiten zu können.

    Evtll. kann mir jemand dabei helfen, festzustellen ob ich die benötigten Voraussetzungen bei meinem Webhosting Paket habe und falls ja, wo ich da etwas konfigurieren muss, um das Problem zu lösen.


    Vielen lieben Dank!


    Hier die Antwort vom Hersteller, mit der ich eben aufgrund mangelnder Kenntnis nur beschränkt weiter komme:


    ---


    This issue was covered for several users since years ago, as some servers have different implementations of PHP auth. We already covered all possibilities in X3 by looking for optional server variables in the .htaccess file and /app/auth.inc.php. We look for the following vars:

    Code Select all

    Code
    1. PHP_AUTH_USER, REDIRECT_HTTP_AUTHORIZATION, HTTP_AUTHORIZATION, REDIRECT_REMOTE_USER, REMOTE_USER

    Until now, all servers that support PHP auth will forward at least one of these. In addition in .htaccess:Code Select all

    Code
    1. # Allow basic authentication in X3 for servers running PHP as FastCGI RewriteCond %{HTTP:Authorization} !^$

    2.   RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},E=PHP_AUTH_USER:%{HTTP:Authorization},E=REMOTE_USER:%{HTTP:Authorization},L]

    Basically what is happening, is that after filling the username/password, these are empty when X3 checks them, and therefore you will end up in a loop prompting to login. You will need to ask if your host supports basic PHP auth, which in this case, it seems not.

  • Ich habe bislang keine spezielle .htaccess eingerichtet - ich wüsste ehrlich gesagt auch nicht, wo ich sie genau ablegen müsste. Im Root der Installation/der Domain?


    Bei den Apache/nginx-Einstellung habe ich beim Proxymodus nur eine Checkbox zum aktivieren. Diese ist auch aktiv. Andere Optionen zur Auswahl bestehen keine.


    Danke schon einmal.