Webhosting Content Security Policy-Error

  • Hallo Forum,


    ich habe mir eine Anwendung geschrieben (html/css/js/sql), die mir im Browser CSP-Fehler entgegenwirft:

    Code
    1. Refused to load the script 'URL zum .js' because it violates the following Content Security Policy directive: "script-src 'none'". Note that 'script-src-elem' was not explicitly set, so 'script-src' is used as a fallback.

    Wenn ich einen Header in die Datei direkt reinnehme:


    Code
    1. <meta http-equiv="Content-Security-Policy" content="script-src 'self'"; />

    Gleicher Fehler.


    Da ich das Ding selber geschrieben habe, weiß ich, dass ich irgendwo einen CSP-Header gesetzt habe. Kann ich da im WCP was verstellt haben? Andere Seiten auf dem gleichen Webspace (anderer webroot) z. B. ein Wordpress laufen ganz normal. Die Domain ist neu registriert, funktioniert aber. Ich weiß nicht mehr weiter.


    Wenn ich das auf einem nicht NC Webspace starten will, klappt es :/. Das ist ein Webhosting 2000 ix.

  • Schon mal mit den Entwicklertools des Browsers geschaut, welche HTTP-Header vom Server gesendet werden?


    CSP ist meistens ein HTTP-Header, also würde ich mal in Plesk die Felder für eigene Header kontrollieren: https://www.netcup-wiki.de/wik…g#Einstellungen_Webserver


    Ein Blick in alle .htaccess-Dateien schadet auch nicht, falls Apache verwendet wird.

  • Danke für die Anregungen. Im Endeffekt war es selber verschuldet. Das trat nur im Chrome auf, nicht im Edge oder Firefox. Ich habe das Projekt von der Testumgebung auf die eigentliche Domain umgezogen und vergessen im Chrome eine Regel für ScriptSafe hinzuzufügen. :|