Hilfe beim Installieren von Nextcloud

  • Hallo,


    ich habe leider auch ein Problem Nextcloud auf meinem Webspace zu installieren. Bin nach dem installieren auf einen blauen Bildschirm weitergeleitet wurden und nach dem aktualisieren sah es bei mir so aus (siehe Screenshot). Das Problem: Ich kann nichts anklicken. Ich hoffe, hier hatte jemand dasselbe Problem und kann mir helfen es zu beheben. Vielen Dank.

    Bildschirmfoto 2020-06-17 um 09.49.28.png

  • Das Problem: Ich kann nichts anklicken. Ich hoffe, hier hatte jemand dasselbe Problem und kann mir helfen es zu beheben. Vielen Dank.

    Hier wären die Access/Error log's vom Vorteil. Diese liegen im Ordner /logs/<domainname>/ dort einmal schauen ob Auffälligkeiten vorliegen oder falls möglich die Log hier einfach Posten (im Code-Tag).

  • Hab die IP/Domain etc mal zensiert, dass sollte ja aber eigentlich kein Problem sein.

    Code
    1. [Wed Jun 17 09:35:54.227010 2020] [fcgid:warn] [pid 21295] [client 188.***.***.124:***22] mod_fcgid: stderr: PHP Warning: fileperms(): stat failed for /var/www/vhosts/hosting1****3.a***6.netcup.net/office.*****.de/data/nextcloud.log in /var/www/vhosts/hosting1****3.a***6.netcup.net/office.*****.de/lib/private/Log/File.php on line 85
    2. [Wed Jun 17 09:35:54.227077 2020] [fcgid:warn] [pid 21295] [client 188.***.***.124:***22] mod_fcgid: stderr: {"reqId":"pxjME8McUsgWlUIufLb7","level":3,"time":"2020-06-17T07:35:54+00:00","remoteAddr":"188.***.***.124","user":"--","app":"PHP","method":"GET","url":"/","message":"session_start(): A session had already been started - ignoring at /var/www/vhosts/hosting1****3.a***6.netcup.net/office.*****.de/lib/private/Session/Internal.php#209","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.97 Safari/537.36","version":""}
  • Es tut mir leid dass ich das so sage, aber Nextcloud auf einem Webhosting ist einfach kein Vergnügen.

    Evt. reicht die php runtime nicht bei einem kleinen oder angebots webspace, aber nicht mal auf einem regulär gekauftem Webspace 8000 macht die Nextcloud Spaß.

    Dafür muss dann ein vServer her.

  • Alternativ gibt es günstige Angebote bei denne mal das komplette hosting mit ordentlich Speicher zu einem fairen Preis bekommt.
    Ich will dich nicht Hetzen, überlege dir in Ruhe was für dich die beste Lösung ist.

  • Es tut mir leid dass ich das so sage, aber Nextcloud auf einem Webhosting ist einfach kein Vergnügen.

    Evt. reicht die php runtime nicht bei einem kleinen oder angebots webspace, aber nicht mal auf einem regulär gekauftem Webspace 8000 macht die Nextcloud Spaß.

    Dafür muss dann ein vServer her.

    Bei kleinen Angebots-Tarifen mag das stimmen. Aber beim WH8k kann ich das definitiv nicht unterschreiben. Dort läuft meine Nextcloud einwandfrei. Klar, ein paar Features könnte ich nur am eigenen Server realisieren, aber die brauche ich nicht unbedingt.


    Shasa Der Fehler deutet auf ein Berechtigungsproblem hin. Hast Du an den Ordner-/Dateirechten irgendwo etwas geändert? Im Zweifelsfall nochmals alles in einen neuen Ordner hochladen, der innerhalb von /httpdocs liegt und die Domain darauf zeigen lassen.

  • Bei kleinen Angebots-Tarifen mag das stimmen. Aber beim WH8k kann ich das definitiv nicht unterschreiben. Dort läuft meine Nextcloud einwandfrei. Klar, ein paar Features könnte ich nur am eigenen Server realisieren, aber die brauche ich nicht unbedingt.


    Shasa Der Fehler deutet auf ein Berechtigungsproblem hin. Hast Du an den Ordner-/Dateirechten irgendwo etwas geändert?

    Sehr komisch.
    Die Cloud läuft bei mir, ist aber schon mit wenigen 100 MB extrem langsam. Das laden der Seiten dauert ewig. Down- Up- Load ist ok.

    Aber über das Webinterface macht das echt kein Spaß.

  • Bei kleinen Angebots-Tarifen mag das stimmen. Aber beim WH8k kann ich das definitiv nicht unterschreiben. Dort läuft meine Nextcloud einwandfrei. Klar, ein paar Features könnte ich nur am eigenen Server realisieren, aber die brauche ich nicht unbedingt.


    Shasa Der Fehler deutet auf ein Berechtigungsproblem hin. Hast Du an den Ordner-/Dateirechten irgendwo etwas geändert? Im Zweifelsfall nochmals alles in einen neuen Ordner hochladen, der innerhalb von /httpdocs liegt und die Domain darauf zeigen lassen.

    Habs probiert, funktioniert leider auch nicht. Ich werds wohl über einen vServer machen müssen. Danke euch trotzdem.

  • Ich werds wohl über einen vServer machen müssen.

    Das ist aber sicher nur eine Kleinigkeit ;-)


    Nextcloud läuft normalerweise definitiv, das lässt sich irgendwie lösen. Welche Version ist das eigentlich, die Du da versuchst zu installieren? Dann versuche ich das mal bei mir zu reproduzieren.

  • Ich ziehe gerade meine nextcloud (3 GB files, 16 MB mysql dump) in ein Webhosting 2000 SE de a1 um, dauert aber noch. Bin gespannt, ob das eine schlechte Entscheidung wie Homwer meint. Da ich in der alten Installation bzgl. Dateirechten noch hardened habe und dort aber die Laufzeitumgebung eine andere war, musste ich erst mal schauen, wie es grundsätzlich nun bei netcup ist und wie ich es konvertieren muss. Lange Rede, kurzer Sinn, habe mir ein zweites Webhosting 1000 besorgt und dort mal über das Web Installer Skript eine frische nextcloud installiert. Ich habe dabei

    • mysql statt sqllite konfiguriert: dazu musste ich eine Datenbank erstellen/vorbereiten
    • das data Verzeichnis außerhalb des Stammverzeichnisses gelegt: dazu musst man in den PHP settings das open_basedir angepasst werden

    Alles erfolgreich geschafft, sie läuft. Kann also nicht unbedingt das Fehlverhalten nachvollziehen. Hast Du error_log und nextcloud.log geprüft. Bei mir waren dort hilfreiche Infos.

  • Habe das Problem gelöst. Danke euch allen :)


    Und zwar habe ich Nextcloud auf eine Domain verschoben, die nicht bei Cloudflare ist. Jetzt geht alles wunderbar. Gab wohl Probleme mit dem Cache.

  • Wollte gerade noch was hinzufügen, evlt. hilft es anderen: hatte auch noch ein Problem mit


    Temporary directory /var/www/vhosts/hosting***.***.netcup.net/***.***.de/tmp is not present or writable


    Der Installer hatte irgendwie kein /tmp Unterverzeichnis angelegt, obwohl das sein Default wäre. Ich habe es dann durch das Umkonfigurieren (Hinzufügen) in config/config.php

    'tempdirectory' => '/tmp',


    selbst geregelt.