Nextcloud: Downloadgrenze bei 1.08GB durch proxy_max_temp_file_size?

  • Hallo,

    ich komme leider trotz einiger Recherche nicht weiter:


    In meinem Webhosting-Paket habe ich eine Nextcloud-Installation (16.0.2) in Betrieb. Downloads über das Web-Frontend scheitern bei 1.08GB.


    Ein naheliegender Grund wäre, dass der nginx-Proxy proxy_max_temp_file_size auf den Default-Wert, also 1GB, gesetzt hat. Allerdings ist im WCP in den Einstellungen für Apache & nginx für die Subdomain nginx-Caching deaktiviert. Also bin ich da vermutlich auf dem Holzweg?!?


    Könnte doch die PHP-Konfiguration das Problem sein? Ich bin auf PHP 7.3. In der .htaccess im Nextcloud-Verzeichnis finde ich keine

    In den Server Logs erscheinen folgende Warnungen:

    (70007)The timeout specified has expired: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function

    (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function


    Über einen hilfreichen Tipp dazu würde ich mich sehr freuen und bedanke mich schon im Vorraus.

  • Danke schon mal für die Hinweise. Ich dachte, das ein Update auf die aktuellste 16er Nextcloud Version (16.0.9) sinnvoll ist, um einen Bug auszuschließen. Leider hänge ich da aktuell: Da der Updater einen Timeout beim Backup wirft, habe ich, wie in der Nextcloud-Doc beschrieben, ein manuelles Update durchgeführt:

    • neue Nextlcoud-Version auf den Server laden und als "nc_new" entpacken
    • Maintenance Mode auf true
    • config.php und data Verzeichnis hinein kopieren
    • altes NC-Verzeichnis in"nc_old" umbenennen, neues Verzeichnis in "nc"
    • Maintenance Mode auf false
    • NC-Seite aufrufen. Updater ausführen

    Leider auch wieder ein Timeout. Upgrade per SSH ist nicht möglich, da logischerweise keine Rechte für Befehlsudo -u www-data php occ upgrade

    Wenn ich das gelöst habe (jemand einen Tipp?), gehe ich wieder an das Size-Limit Problem :/




    Passiert das wirklich immer exakt an der geichen Stelle? Unabhängig von der verwendeten Internetverbindung?


    Hast Du zufällig mal einen öffentlichen Testlink für eine Datei, mit dem man das nachvollziehen kann?

    ja, passiert immer bei 1.08 GB, habe es von mehreren Rechnern mit verschiedenen Dateien versucht. Ergebnis siehe Anhang.

    Einen Testlink generiere ich gerne, wenn ich das Update durch habe (s.o.)


    Genau das Problem hatte ich auch: https://forum.netcup.de/anwend…cloud-download-bricht-ab/


    Meine Lösung war auf FPM served by nginx umzustellen.

    Das scheint bei PHP 7.3 nicht mehr möglich zu sein. Dort kann man nur noch auswählen "FastCGI von Apache bedient". Evtl. müsste ich dann zurück auf PHP 7.2

  • Bei mir hat das Updaten immer ganz gut über den webbasierten Updater funktioniert. Ist zwar auch regelmäßig in einen Time Out gelaufen. Aber ich hab dann einfach öfter auf den "Retry"-Button geklickt und irgendwann hat es funktioniert. Kann auch sein, dass der nächste Run vom Cron-Job das ganze gelöst hat.


    Das scheint bei PHP 7.3 nicht mehr möglich zu sein. Dort kann man nur noch auswählen "FastCGI von Apache bedient". Evtl. müsste ich dann zurück auf PHP 7.2

    Jap. Das ist dann leider so. Aber du kannst es ja mal testen. Es kann nur sein, dass du dich dann nicht mehr einloggen kannst. Meine Vermutung ist, dass PHP 7.3 einen neueren Hashing-Algorythmus verwendet. Mit "Passwort vergessen?" kannst du das aber wieder lösen. Zumindest fürs Testen.

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • Wieso „sudo -u www-data ...“? Du bist doch bereits als der Hosting-User angemeldet.

    ist der Hosting-User also auch der User, unter dem der Webserver läuft? Da war ich mir nicht sicher. Ich habe nun malphp occ upgrade versucht, laufe da aber auch in einen Fehler

    Code
    1. The current PHP memory limit is below the recommended value of 512MB.
    2. Nextcloud or one of the apps require upgrade - only a limited number of commands are available
    3. You may use your browser or the occ upgrade command to do the upgrade
    4. Cannot create "data" directory
    5. This can usually be fixed by giving the webserver write access to the root directory. See https://docs.nextcloud.com/server/16/go.php?to=admin-dir_permissions


    Die Frage ist nun, warum er beim Upgrade versucht das data-Verzeichnis zu erstellen, da das ja bereits vorhanden ist. Der Link bringt mich leider nicht weiter.

    Die Rechte sind, so wie ich das verstehe, aber korrekt, wenn der hosting-user den Webserver ausführt:


    Code
    1. bash-4.3$ ls -l
    2. total 148
    3. [....]
    4. drwxr-xr-x 54 hostingXXXXX psacln 4096 Apr 6 21:50 apps
    5. drwxr-xr-x 2 hostingXXXXX psacln 4096 Apr 6 23:11 config
    6. -rw-r--r-- 1 hostingXXXXX psacln 4986 Sep 1 2019 cron.php
    7. drwxrwx--- 24 hostingXXXXX psacln 4096 Feb 6 09:32 data
    8. -rw-r--r-- 1 hostingXXXXX psacln 283 Sep 1 2019 occ
    9. drwxr-xr-x 2 hostingXXXXX psacln 4096 Sep 1 2019 updater

    Die Fehlermeldung zum Memorylimit ist aus meiner sicht auch seltsam, weil das laut WCP auf 1024M steht und damit ja über 512M sein sollte.

  • Ja, der hostingXXX-Nutzer ist der, unter dem auch der Webhosting-Prozess läuft.


    Probier mal dem PHP-Befehl auf der Kommandozeile den MemoryLimit-Parameter direkt mitzugeben: php -d memory_limit=1024M ...

    ChestSort: Automatische Kistensortierung in Minecraft - www.chestsort.de


    binichblau: Online-Promillerechner - www.binichblau.de

  • Probier mal dem PHP-Befehl auf der Kommandozeile den MemoryLimit-Parameter direkt mitzugeben: php -d memory_limit=1024M ...

    danke, das elimiert schon mal die Fehlermeldung bzgl. des Limits! cannot create data directory besteht aber weiterhin.

    Muss ich da ggf. rekursiv die Rechte für die Unterordner anpassen?

    Die Zeile

    drwxrwx--- 24 hostingXXXXX psacln 4096 Feb 6 09:32 data

    heißt doch eigentlich, dass der Zugriff auf das Verzeichnis für das occ upgrade Script kein Problem sein sollte, oder?

  • Hey,

    also. Ein Umstellen der php-Settings von

    FastCGI-Anwendung von apache bedient

    auf

    FPM-Anwendung von ngnix bedient


    hat das Update-Problem gelöst!

    Nach dem Umstellen ging das Update plötzlich ohne Probleme im Browser (per OCC habe ich dann natürlich nicht mehr versuchen können). Warum, ist mir leider ein Rätsel.


    broda : ja, die config.php war bereits auf den Webhosting Pfad angepasst.


    Auch der eigentliche Thread-Topic, also Download-Abbruch bei ~1GB, wurde dadurch, wie von Virinum beschrieben, gelöst (Danke!!)


    Leider ergibt sich durch die Umstellung eine Warning im Nextcloud Admin Panel

    PHP scheint zur Abfrage von Systemumgebungsvariablen nicht richtig eingerichtet zu sein. Der Test mit getenv("PATH") liefert nur eine leere Antwort zurück. Bitte die Installationsdokumentation ↗ auf Hinweise zur PHP-Konfiguration durchlesen sowie die PHP-Konfiguration Deines Servers überprüfen, insbesondere dann, wenn PHP-FPM eingesetzt wird.


    Die Meldung hat bisher keine Auswirkung, die ich sehe. Wenn jemand weiß, wo man die Umgebungsvariablen korrekt konfigurieren kann, freue ich mich über einen Tipp :)