Backup&Restore => Wordpress Seite nur für 10 Minuten OK, danach kaputt :-(

  • Wir betreiben seit ca. 1,5 Jahren die Webseite unseres Rudervereins bei netcup und bisher hat auch alles hervorragend

    funktioniert. Am gestrigen Sonntag wollte ich einige Veränderungen vornehmen und habe daher vorher ein Backup erstellt.

    Mit den Änderungen war ich nicht 100% zufrieden und habe daher das Backup des Gesamtsystems (alle Objekte und Konfiguration) wieder eingespielt.


    Das hat das System auch zurückgesetzt und es funktioniert dann (reproduzierbar) für ca. 10 Minuten einwandfrei. Nach den ca. 10 Minuten ist dann das gesammte

    Layout zerschlagen und ich sehe von meiner Webseite nur noch eine "Notversion" mit Texten und Strichpunkten von https://orvo.de

    Die Seite ist dann komplett ohne Grafiken und nicht nutzbar.

    Wenn ich versuche die kaputten Grafiken zu öffnen, dann versucht er sie von

    https://ol-rv.de/wp-content/up…odfrey_ol_kit-780x420.jpg statt von

    https://orvo.de/wp-content/upl…odfrey_ol_kit-780x420.jpg zu laden.


    Könnte es das DNS-System sein?

    Leider habe ich keine Idee mehr wie ich das reaprieren kann :-(


    P.S.:

    Unmittelbar wenn die Seiten nach ca. 10 Minuten die Seiten kaputt gehen, bekomme ich eine Mail, dass mein MyCMS Passwort geändert wurde, die ich mir ebenfalls nicht erklären kann:

  • Ja, habe ich. Und auch von verschiedennen Rechnern getestet.

    Ich glaube inzwischen, dass mit dem komplett Restore irgenetwas aus dem dem "Wordpress Toolkit" hochgespült wird, was auf eine falsche Domain zeigt.

    Das System haben wir damals durch eine externe Firma aufsetzen lassen und es lief zunächst als Testssystem unter "ol-rv.de". Erst als es fertig war, erfolgte der Umzug nach "orvo.de"...

  • Lösung:

    ich weiß immern noch nicht was bei dem Backup&Restore von netcup (alle Objekte und Konfiguration) geschieht, aber ein weiß ich:

    Das ist nicht 100% konsitent - ich werde das nicht mehr nutzen :-(


    Im Ergebnis tauchten nach dem komplett Backup&Restore a(alle Objekte&Konfiguraionen) alte Einträge in der Wordpress-Datenbank auf.

    An mehreren Stellen wurde auf die alte Domain "ol-rv.de" verwiesen wo inzwischen "orvo.de" stand.


    Die (dreckige) Lösung bei mir: Mit dem Plugin "Serach & Replace" alles "ol-rv.de" gegen "orvo.de" ersetzen. Jetzt läuft es wieder.


    Aber: Vorsicht mit dem Plesk "Backup&Restore!"

    ich glaube ja, dass der irgendwelchen alten Einträge aus dem Wordpress-Toolkit wiederfindet und einbaut. Oder sont was tut, das ich nicht begreife.

    ich werde in Zukunft mit der Hand sichern...

  • Was ich in deiner Situation immer gerne mache und hätte bisher noch nie ein Problem damit:


    1. WordPress Toolkit -> Seite klonen

    2. Alle Änderungen auf der neu erstellten Staging Seite vornehmen.

    3.1. Wenn mit Ergebniss nicht zufrieden alles verwerfen.

    3.2. Wenn mit Ergebniss zufrieden WordPress Toolkit benutzen um die Änderungen auf die Produktion Seite zu bekommen.


    4. Wenn die alte Version weiter vorgehalten werden soll. Dann einfach vor 3.2 nochmal 1. Durchführen ohne Änderungen zu machen. (natürlich in eine neue Datenbank und neuen Ordner)


    Was bei dir schief gelaufen ist, kann ich natürlich nicht sagen. Dagegen hilft aber zum Beispiel Updraft mit Sicherung auf Google Drive (kostenlos und man hat Backups auf einem externen Speicher)

  • Ich kann nur immer wieder betonen, das Akeeba Backup in Zusammenarbeit mit Akeeba Kickstart, welches auch für WordPress verfügbar ist, unter Joomla einen hervorragenden Dienst leistet. Damit ist ein Backup&Restore, z.B. für einen Umzug, ein Kinderspiel.

    9 von 10 Stimmen in meinem Kopf sagen ich bin nicht verrückt, die letzte summt ständig die Melodie von Tetris.