PHP-Einstellungen: PHP-Version

  • Hallo,


    ich bin Webhosting-Kunde und benutze mein Webhosting-Paket für 3 Dinge:


    - eMail (inkl. Roundcube als Webmailer)

    - Meine Homepage, die ich mit dem "Presence Builder" (gehört zum Webhosting-Paket) erzeuge.

    - Webspace.


    Von den vielfältigen Möglichkeiten des WCP lasse ich die Finger (Lass die Finger von Maschinen die du selbst nicht kannst bedienen).


    Unter PHP-Version stand bisher "5.6.40". Jetzt steht in roter Schrift "(überholt)" dahinter. Kann ich den Eintrag einfach auf 7.3.10 ändern?


    Gruß


    akapuma

  • Moin,

    Kann ich den Eintrag einfach auf 7.3.10 ändern?

    Nutzt deine Homepage denn überhaupt PHP (zu sehen z.b. an der Dateiendung .php)? Falls nicht würde ich PHP komplett deaktivieren. Ansonsten musst du schauen ob deine Homepage mit PHP7.3 umgehen kann. Falls du nicht gerade eine produktive Seite mit mehreren hundert Aufrufen/Stunde hast, kannst du es einfach im WCP auf 7.3 stellen und einmal deine Homepage auf eventuelle Fehler überprüfen. Falls keine Fehler auftreten kann du PHP dann bedenkenlos auf 7.3 gesetzt lassen.

  • Hallo Bensen,


    in der Tat finde ich eine Menge php-Dateien. Die meisten sind ganz neu (von gestern) und finden sich unter httpdocs/incudes/Zend, ein paar sind auch unter httpdocs/data und httpdocs/data/snapshots. Dann noch 2 bei den Kontaktformularen.


    Quote

    Falls du nicht gerade eine produktive Seite mit mehreren hundert Aufrufen/Stunde hast, kannst du es einfach im WCP auf 7.3 stellen und einmal deine Homepage auf eventuelle Fehler überprüfen. Falls keine Fehler auftreten kann du PHP dann bedenkenlos auf 7.3 gesetzt lassen.


    So werde ich wohl vorgehen.


    Danke.


    Gruß


    akapuma

  • Hallo,


    mein Post zuvor stimmt nicht:



    - Wenn mein Webhosting-Paket "PHP 5.6.40 (überholt)" verwendet funktioniert mein Kontaktformular.

    - Wenn mein Webhosting-Paket "PHP 7.4" verwendet funktioniert mein Kontaktformular nicht mehr!


    Das Kontaktformular wird vom "Web Presence Builder 17.8.12" erzeugt. Dieser Web Presence Builder ist Bestandteil meines Webhosting-Pakets "Expert M int 2018".


    Ist es schlimm, PHP 5.6.40 zu verwenden? Im WCP wird das "(überholt)" in roter Schrift angezeigt.


    Gruß


    akapuma

  • Ist es schlimm, PHP 5.6.40 zu verwenden?

    Es gibt seit diesem Jahr keinerlei Updates mehr, wenn es also eine Sicherheitslücke gibt, dann wird es die für immer geben.

    Man könnte es fast mit Windows XP (oder anderen alten Betriebssystemen) vergleichen. Benutzen kann man es schon noch, aber es kann halt gefährlich werden