VServer als Netzwerkfestplate nutzen Hamachi vpn samba ?

  • Guten Abend


    Ich bin seit einigen Tagen auf der Suche nach eienr einfachen (und vorallen Funktionstüchtigen) möglichkeit Eine Netzwerkfestplatte auf meinem vServer einzurichten von der mann von überall zugriff hat. (so wie Hi-Drive von Strato)
    Einen Netzwerkordner habe ihc zwar ist aber für den gebrauch nicht wirklich geeignet da ich die Daten nicht im Ordner öffnen kann sondern erst runterladen muss ändern speicher (lokal) und dan hochladen....
    Da ich mich freigegebenden Dateien arbeiten möchte (damit mehrere gleichzeitig eine z.b word oder exeldatei bearbeiten können) ist das mit den Ornder bescheiden.


    Was für eine möglichkeit gibt es? bzw welche ist empfehlenswert?


    Samba?
    openvpn?
    hamachi?


    vServer läuft mit debian


    Hamachi habe ich instaliert kann es aber nicht Starten.
    LSB ist instaliert... oder fehlt da noch etwas anderes?



    Ich würde mich freuen wen mir da jemand helfen könnte.

  • WebDAV über HTTPS - Damit hast du einen Netzwerkordner den du in jedem aktuellem Betriebssytem als Laufwerk ohne extra Software einbinden kannst. Selbst Locking funktioniert, d.h. wenn Person A gerade ein Word-Dokument bearbeitet, dann bekommt das Person B mit und man überschreibt sich nicht ausversehen gegenseitig die Änderungen.

  • Danke für deine Antwort :)


    webdave läuft aber ihrgendwie fujst das nur lokal...


    root@ufoserver:~# cadaver http://localhost/webdav/
    Authentication required for webdav on server `localhost':
    Username: *********
    Password:
    dav:/webdav/> quit
    Connection to `localhost' closed.
    root@ufoserver:~# cadaver http://46.38.232.135/webdav/
    Could not access /webdav/ (not WebDAV-enabled?):
    405 Method Not Allowed
    Connection to `46.38.232.135' closed.
    dav:!>



    EDIT:


    Ich war zu blöd... habe bei der default datei für apatsch die ip adresser vergessen einzutragen

  • Was nebenbei sehr wichtig ist das windows vista und 7 Probleme bei der Anmeldung machen.... daher muss mann:
    * Klicke auf Start --> regedit in dem Feld Suche starten oder Ausführen eingeben
    * im Registry-Editor zu folgendem Pfad gehen:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters und klicke doppelt auf den Eintrag "BasicAuthLevel" und ändee den Wert auf "2" und bestätige mit "OK".
    * Sollte der Eintrag nicht vorhanden sein, klicke Sie mit der rechten Maus im rechten Fensterbereich und wähle "Neu" und klicke dann auf "DWORD (32-bit)".
    * Nenne ihn "BasicAuthLevel" und drücke dann die Eingabetaste.
    * Klicke in dem Menü Bearbeiten auf Ändern.
    * Gebe in dem Feld Wert "2" ein, und klicke dann auf "OK".
    * Starte den PC neu


    (Quelle: WebDAV unter Vista und Windows 7 | hack3r.de)




    Das War auch mein Problem... aber jetzt läuft es. Zwar langsam aber es läuft :) THX!

  • DasUFO, der Hack ist überflüssig und der Blogeintrag enthält viel Quatsch. Man kann sehr wohl mit Boardmitteln eine WebDAV-Freigabe als Laufwerksbuchstabe einbinden. Einfach "Netzlaufwerk verbinden" aufrufen und die Adresse eintragen. Der Authack ist wohl für Webserver gedacht, wo der Admin das nicht richtig einrichten kann.

  • hmm ich komme aber erst seitdem ich den eintrag in der reg geändert haben auf das laufwerk drauf.

  • weil windows 7 kein http-basic-auth mehr zulässt (zumindest bei webdav-geschichten), sondern nur mehr http-digest-auth.


    du hättest am webserver auch einfach von basic auf digest wechseln können, dann wäre, wie schon von vmk angemerkt, der "hack" nicht notwendig gewesen.

  • in welche config datei den? die von apacht oder von debian?


    EDIT;
    hej do
    wen ich die confic von authType Basic auf Digest umstelle kann ich mich überhauptnichtmehr einloggen.. weder über Firefox noch über Windows 7 :(
    Nur mit Basic und den umstellen der regestrierung geht das bei mir. Aber warum ist das am PC soooo langsam?
    wen ihc per winscp auf den server zugreife läd der viel schneller die verzeichnisse. selbst wen ich mit meinem Apfelhandy mich einlogge (mit webdav app) geht das echt schnell nur am pc hat mann das gefühl wie mit nen 14 k modem...... gibts da abhilfe?


    lg Das UFO


    Lösung


    vvvvvvvvvvvv


    loool
    Folgende Schritte sollten das Problem beheben:

    • Internet Explorer starten.
    • Menü „Extras | Internetoptionen“ wählen.
    • Auf der Registerkarte „Verbindungen“ die Schaltfläche „LAN-Einstellungen“ klicken.
    • Die Option „Automatische Suche der Einstellungen“ deaktivieren.

    Die apocalypse der Deutschen Rechtschreibung ;)
    GIDF.DE Google ist dein Freund! :D

    The post was edited 2 times, last by DasUFO ().