API Response time verdammt hoch

  • Nachdem ich heute mal meine LetsEncrypt Zertifikate um Wildcards erweitern wollte, bin ich stän­dig in timeouts reingelaufen.


    Code
    1. #Exectued on a netcup server, ping and down-/upload speeds are normal
    2. time curl -H "Content-Type: application/json" --data "@test" "https://ccp.netcup.net/run/webservice/servers/endpoint.php?JSON"
    3. {"serverrequestid":"222DM2jojzy2VJIQn39U2RllGJM","clientrequestid":"","action":"login","status":"success","statuscode":2000,"shortmessage":"Login successful","longmessage":"Session has been created successful.","responsedata":{"apisessionid":"***************************"}}
    4. real 0m27.281s
    5. user 0m0.020s
    6. sys 0m0.004s


    Gehört das so? Gefühlt sind 27s für ein Login sehr hoch. Von meinem Rechner zuhause bekomm ich ähnliche Ergebnisse.

  • Hab heut nochmal getestet, selbes Ergebnis. Ein Freund von mir erzielt um die 16s.


    Der request hat die Form wie vom Wiki vorgeschlagen

    Code
    1. {
    2. "action":"login",
    3. "param":{
    4. "apikey":"xxxxxxxxxxxx",
    5. "apipassword":"xxxx",
    6. "customernumber":"123456"
    7. }
    8. }
  • Die Zeiten sind bei mir wesentlich besser geworden! Vielen Dank :)


    Das Klonen einer Zone auf zwei andere Domains dauerte vorher ca. 9 Minuten, jetzt waren es nur noch 23 Sekunden!

    RS 2000 Plus SAS G8 | VPS 2000 G8 Plus | VPS Ibiza/16 Years | 3x VPS 200 G8 | EiWoMiSau

    www.jeff24.de - www.serioese-alternative.de - www.jeff-media.de