Webseiten nicht mehr erreichbar

  • Hallo zusammen,


    bin aktuell etwas negativ irritiert was den Netcup-Support angeht. :rolleyes:

    Folgendes Problem: ich bin vor kurzem zu Netcup gewechselt und habe zu meinem Webhosting Paket eine externe Domain aufgeschalten. Das hatte soweit auch alles einwandfrei geklappt. Nachdem die Aufschaltung durchgeführt worden ist, waren jedoch plötzlich meine zwei anderen, im Webhosting-Paket enthaltenen, Webseiten nicht mehr erreichbar. Der komplette Inhalt beider Wordpress-Instanzen, sowie auch beide Datenbanken hierfür sind völlig aus dem CCP verschwunden - die entsprechenden Webseiten zeigen jetzt eine Netcup-Standardseite mit Forbidden.

    Ich habe daraufhin den Netcup-Support angeschrieben und als Rückmeldung erhalten, dass soetwas bei der Aufschaltung einer externen Domain nicht passieren kann. Ich bin mir zu 100% sicher, dass sich auch nicht die entsprechenden Verzeichnisse und dazugehörigen Datenbanken gelöscht habe. Da müsste man sich schon ganz oft mal "aus versehen" verklicken. Natürlich habe ich noch KEIN Backup eingerichtet, weil ich erst frisch gewechselt habe. Als Antwort bekomme ich nun, dass ich zwei Mal 20€ für die Datenwiederherstellung bezahlen soll, soweit ich das möchte.

    Das ich kein Backup habe, daran bin ich selbst Schuld. Dass jedoch in keinster Weise darauf eingegangen wird, wie das Problem überhaupt verursacht worden ist, warum so etwas passiert, ob so etwas erneut passiert, finde ich jedoch hingegen eine Unverschämtheit. Finde so etwas alles andere als kundenfreundlich! Ich habe gefühlt jetzt schon den Wechsel bereut.


    Grüße

    citydweller

  • Ja, der Support bleibt bei sowas in der Regel sehr unpersönlich bei seinen Standardreaktionen. Allerdings wüsste ich in diesem Fall auch nicht, was ein Supportmitarbeiter tun sollte. Dafür, dass eine automatisierte Domainaufschaltung Dateien und Datenbanken löschen könnte (damit das passiert müsste man das ganze Abonnement löschen oder deaktivieren, oder?), gibt es wohl keine logische Erklärung und ich schätze nicht, dass auf Systemebene die Änderungen genau protokolliert werden.

    Ich finde das Ganze, einen Fehler Deinerseits komplett ausgeschlossen, allerdings auch etwas beunruhigend.

  • Guten Tag citydweller,



    es ist bedauerlich, dass Ihre Daten verschwunden sind. Sie können sich allerdings sicher sein, dass wir viel tun, damit nicht Daten einfach gelöscht werden. Unter anderem warnen wir Kunden sehr deutlich vor einen Datenverlust, wenn dieser durch eine Aktion entstehen kann.


    Ich habe dennoch für Sie einmal Logdateien gewälzt:


    Sie haben die aktuell genutzte externe Domain bereits in der Vergangenheit Ihrem Account zugewiesen gehabt. Wenn ich das richtig sehen, haben Sie in den Bereich der Domain auch Datenbanken installiert. Die Zuweisung der externen Domain haben Sie zwischenzeitlich aufgehoben und anschließend neu zugewiesen. Dabei sind vermutlich die Daten verloren gegangen, die Sie vermissen.


    Wenn wir an einer Stelle noch deutlichere Warnungen einbringen können, lassen Sie uns dieses bitte wissen.



    Vielen Dank und mit freudlichen Grüßen


    Felix Preuß

  • Hallo Felix,


    vielen Dank für die ausführliche Rückinfo. Das von dir beschriebene Vorgehen von mir ist korrekt. Allerdings sind Daten/Datenbanken von Domains verloren gegangen, die überhaupt nichts mit der externen Domain zu tun haben bzw. auch nicht annäherend in einem Bereich liegen die damit zu tun haben. Eine dritte vorhandene Datenbank ist nicht gelöscht worden, auch nicht nicht ein anderes Verzeichnis einer internen Domain. Irgendwas passt hier doch nicht, oder?


    Grüße

    citydweller

  • Guten Tag,



    wenn Sie eine Datenbank erstellen / Anwendung installieren, können Sie dieser einer Domain zuweisen. Sie haben diese wie es aussieht der externen Domain zugewiesen, die Sie zwischenzeitlich entfernt haben. Dabei gehen auch die zugewiesenen Datenbanken und Anwendungen verloren.



    Mit freundlichen Grüßen


    Felix Preuß

  • Hallo Felix,


    danke für deine schnelle Rückmeldung. Ich habe jedoch definitiv keine Datenbank/Anwendung dieser neuen Domain in solch einer kurzen Zeit zugewiesen. Dies würde auch überhaupt keinen Sinn machen. Auf dieser externen Domain liegen nun eine Bild und eine HTML-Datei.

    Bitte verstehe mich nicht falsch, aber da muss ein Fehler im System vorliegen.


    Grüße

    citydweller


    Update: Kann es vielleicht an Ticket NC#2018033110001795 liegen?

  • Quote

    Update: Kann es vielleicht an Ticket NC#2018033110001795 liegen?

    Vermutlich. Wenn die Hauptseite deaktiviert ist, können Sie die Datenbank ja nur anderen Domains zuweisen.


    Die Datenbanken waren der externen Domain zugewiesen. Das geht so auch aus den Logdateien hervor.



    Mit freundlichen Grüßen


    Felix Preuß

  • Vielen Dank für die Recherche. Macht für mich jedoch trotzdem keinen Sinn, da ich hier definitiv nichts an die externe Domain zugewiesen habe. Warum gibt es in den Verzeichnissen noch einige übrige Dateien/Verzeichnisse obwohl doch alles gelöscht wird/werden sollte.

    Sorry, bin seit über 20 Jahren in der IT und sowas hab ich noch nie erlebt...

  • Also jetzt werde ich langsam echt sauer. Habe gerade folgende Antwort erhalten:

    Die Datenbank-Daten wurden soeben wiederhergestellt, diese finden Sie in Ihrem Hauptverzeichnis. Bezüglich den Wordpress-Daten muss ich Ihnen mitteilen, das auch ein Backup vom 19.03.2018 auch diese Daten nicht beinhaltet.
    Wir vermuten daher, dass seit dem 18/19.03.2018 schon die Daten nicht mehr vorhanden wahren, denn die Log-Dateien enden am 18.03.2018 um 2 Uhr.


    Ich habe meine Webseite gestern Abend noch aufrufen können, da ich einen Uptime-Bot laufen habe. Sorry, aber hier gibt es scheinbar ganz andere technische Probleme! Wie komme ich nun zu einer zufriedenstellenden Lösung. Eine Bezahlung für die reine Datenbankwiederherstellung lehne ich hiermit ausdrücklich ab.

  • Natürlich ist sowas ärgerlich, gerade wenn kein Backup seitens netcup vorhanden ist, was deine verlorenen Daten beinhaltet, warum sei mal dahingestellt.


    Wenn die Datenbank wirklich wichtig war/ist und regelmäßig erweitert wurde/wird, wieso hast du dann keine eigenen Backups? Ein Backup von netcup ist schön und gut, kostet dich aber Geld und im schlimmsten Fall sind nicht alle verlorenen Daten enthalten bzw. die Löschung der Daten liegt zulange zurück...

    Wenn du 100%ige Sicherheit haben willst, musst du die Backups selber anfertigen, dann kann es an nichts und niemandem - außer dir - scheitern.


    Hier wurde das ganze mal grob beschrieben, musst du nurnoch anpassen. Einfach auf deinem Server als cronjob einrichten, falls vorhanden, andernfalls unter HyperV 'ne Autostart VM erstellen und das dort regeln. Braucht nichtmal viele Ressourcen und den Start könntest du verzögern und mit dem Cronjob die VM auch wieder runterfahren. Vielleicht siehst du das anders, aber wenn du kein aktuelles Backup hast oder dir das hier beschriebene die Zeit nicht wert ist, kann die Datenbank dir kaum sehr wichtig sein.

    ...und du würdest in jedem Fall dein Geld behalten


    EDIT: Und viel Arbeit ist's einrichten auch nicht, da die VM sowieso nicht direkt im Internet hängt und bestenfalls wie schon erwähnt fürs Backup hoch- und danach direkt wieder runterfährt

  • Hallo 03simon10,


    du musst die Angelegenheit etwas dezidierter betrachten. Es sind Backups vorhanden, jedoch nur ein Teil, da scheinbar die anderen Daten nie vorhanden waren - diese Aussage ist vom Netcup-Support schlichtweg falsch.


    Ein Backup habe ich eingerichtet, allerdings jetzt erst, da ich erst vor kurzem zu netcup gewechselt bin.


    Ich verwende keine VM, sondern ein einfaches Webhosting-Paket.


    Grüße

    citydweller



    Auf was prüft der Uptime-Bot genau? Meistens prüfen die nur auf den Status-Code 200 und das war es, dann würde auch die "leere Website" bzw. Platzhalter-Website keinen Fehler auslösen

    Hallo julian-w,


    es ist aktuell vollkommen unerheblich auf was der Uptime-Robot prüft, da ich die Webseite gestern noch aufrufen konnte. Sollte man hier meiner Aussage nicht vertrauen, haben wir ein ganz anderes Problem.


    Grüße

    citydweller

  • es ist aktuell vollkommen unerheblich auf was der Uptime-Robot prüft, da ich die Webseite gestern noch aufrufen konnte. Sollte man hier meiner Aussage nicht vertrauen, haben wir ein ganz anderes Problem.

    Ganz unerheblich ist es nicht, ob nur ein Uptime-Robot auf Status-Code 200 prüft oder ob sie persönlich die Website aufgerufen und auf Funktionalität getestet haben. Haben sie nur die Startseite geladen oder auch auf der Seite "gesurft". Nicht das der Cache ihnen einen Streich gespielt hat und eine funktionierende Seite vorgekauelt hat.


    Scheinbar besitzen sie auch mehrere Webhosting Pakete zwischen denen sie die Domain hin- und hergeschaltet haben, eventuell wurde da was vertauscht.

    Wenn die Hauptseite deaktiviert ist, können Sie die Datenbank ja nur anderen Domains zuweisen.

    Die Haupdomain (also die generische xxx.netcup.net Domain) sollte man generell nie deaktivieren, da dann etliche Dinge nicht mehr korrekt funktionieren, wie z.B. Cronjobs, Mailempfang (?) etc. Leider ist diese Funktion trotzdem verfügbar. Ich fände einen deutlichen Warnhinweis angebracht, die Hauptdomain (xxx.netcup.net) nicht zu deaktivieren, am besten wäre es wenn man die Möglichkeit diese zu deaktivieren ganz ausbauen würde, sodass man gar nicht erst in Versuchung kommen kann. Aktuell gibt es den Warnhinweis in dieser Form sowieso nur in Forenbeiträge, zumindest hab ich Ihn sonst noch nie gesehen :/

    Ein Backup habe ich eingerichtet, allerdings jetzt erst, da ich erst vor kurzem zu netcup gewechselt bin.

    Du bist aber doch schon ein paar Wochen bei netcup laut den Aussagen oben... und gerade das Datenbanken und die Verzeichnisse immer Domains zugeordnet sind hat auch bei mir schon einmal für eine böse Überraschung gesorgt weil ich auch etwas unvorsichtig war :rolleyes: Glücklicherweise war ein Backup vorhanden. Aber dein Umzug ist wohl schon ein paar Wochen her, daher ist die Chance zwar gering, aber vlt. sind auf deinem PC noch Dateien vorhanden. Viele FTP(S)-Programme kopieren erst alles lokal in einen temporären Ordner und laden es erst dann auf den neuen Server hoch wenn man Dateien umzieht, vielleicht hast du ja viel Glück und findest dort die gelöschten Dateien wieder.

  • Hallo zusammen,


    nach mehrmaliger Nachfrage ist doch ein Backup bei NetCup aufgetaucht und es wurde mir freundlicherweise die Restorekosten nicht in Rechnung gestellt.

    Warum das Ganze passiert ist, ist mir trotzdem nach wie vor unklar. Ein Backup wurde von meiner Seite nun eingerichtet und ich hoffe das soetwas nicht mehr passieren wird.


    Vielen Dank für euer Feedback und Grüße

    citydweller