Drupal CMS / 500 internal Error

  • Hallo!


    Ich bin noch relativ neu im Umgang mit Webhosting und wollte hier um Rat fragen. Das Problem was ich nämlich habe, ist, dass ich Versuche Drupal auf den Webserver zu bekommen, jedoch immer einen Fehler bekomme, wenn ich die Seite aufrufe, auf welcher der Server läuft. Dies ist eben ein 500 internal Server Error. Ich habe Drupal so genau wie möglich nach Anleitung installiert, wie z.b. die Index.php zu erstellen mit den dazugehörigen Rechten. Auch habe ich mitbekommen, dass irgendetwas mit der Datei .htaccess nicht stimme. Naja, habe mehrmals Versucht, das über FTP hochzuladen in den html ordner, auch mit .htaccess und ohne. Das Problem was hier ebenfalls war, war, dass die Datei in beiden Fällen nichteinmal angezeigt wurde (mit den Rechten stimmte am Ende auch etwas nicht, sowie existiert nun ein Ordner im html Ordner, welcher sich nicht löschen lässt). Ich verstehe es einfach nicht ganz, habe mich aber mit Drupal selber schon auseinandergesetzt und kann damit eine Website zu erstellen, eben alles nach der installation. Das Paket ist ein Business 1G Paket, also die Mindestanforderungen sind soweit ich weis gegeben. Ebenfalls habe ich versucht Drupal über das Software-Center in Confixx zu installieren. Hier trat allerdings derselbe Fehler wieder auf!
    Ich habe auch schon mehrere Post hier durchgelesen, die mir allerdings nicht wirklich weiterhelfen.


    Ich danke schonmal im vorraus!

  • Quote

    Fehler 500 - Internal Server Error / Interner Server Fehler. Es ist ein Script Fehler aufgetreten. Dies hat bei netcup zumeist folgende Ursachen.
    Es wurde einem Ordner und/oder einer Datei chmod 777 gegeben was nicht zulässig ist. Es ist maximal chmod 755 nötig und möglich.
    Sie verwenden eine .htaccess Datei mit ungültigen Optionen
    Sie verwenden mod_rewrite Features ohne mod_rewrite in Confixx aktiviert zu haben, siehe auch httpd_Spezial - mod_rewrite.
    Ihr verwendetes Script verursacht ein internen Server Fehler, aktivieren Sie sich ggf. die Error Log Ausgabe, siehe auch httpd_Spezial - Error Log oder wenden Sie sich ggf. an den Support.


    Welchen FTP Clienten benutzt du?

  • Hallo,


    lade doch bitte mal die beiden Dateien hoch und schau ob Du sie öffnen kannst.
    Eine evtl. vorhandene php.ini und .htaccess bitte vorher löschen oder umbennen.


    test.html
    <html><p>Hallo</p></html>


    phpinfo.php
    <?php phpinfo(); ?>


    Dann wissen wir ob html und php überhaupt funktionieren.


    Stefan

  • Entschuldigt mich, ich war gestern etwas unter Zeitdruck und konnte nicht mehr antworten.
    Ich bedanke mich aber erteinmal bei euch für die schnelle Antwort und werde jetzt gleich eure vorschläge umsetzen!
    Ich glaube, dass ich mit Stefankittel's vorschlag anfange, da überhaupt ersteinmal sichergestellt werden muss, dass php funktioniert.
    Ich werde mich melden! Und nochmals danke! :thumbsup:


    EDIT: Habe vergessen zu erwähnen, dass ich FIlezilla nutze!
    EDIT2: Ich habe jetzt die beiden Dateien hochgeladen. Wenn ich domain/test.html mache kommt eben das Hallo!, wenn ich aber die phpinfo starte (domain/phpinfo.php) kommt wieder der internal server error... Habe ich die Datei falsch geöffnet, oder ist dass dann der fehler? Ich denke mal, dass das ein Indiz ist!

  • der html ordner (der ordner in der die phpinfo steckt) hatte einen chmod von 777, habe es natürlich sofrt auf 755 zurückgestellt. Die phpinfo hat einen chmod von 644. Es funktioniert allerdings noch nicht. Eine.htaccess Datei ist nicht vorhanden bzw. sie wird nicht angezeigt. ich habe nämlihch gestern eine Drupal Konfiguration auf den Server geladen, die .htaccess Datei war jedoch nicht übertragen worden, Filezilla hat jedoch keinen Fehler angezeigt!

  • Filezilla zeigt von Haus aus versteckte Dateien nicht an, dies müssen Sie in den Einstellungen von Filezilla zunächst aktivieren. Im Moment liegt dort eine .htaccess Datei ;) Diese ist auch die Quelle der Fehlermeldung.


    Aktivieren Sie in Confixx mod_rewrite unter Einstellungen / Tools -> httpd_Spezial oder löschen Sie die .htaccess Datei.

  • Darauf muss man natürlich erstmal kommen :) Habe mich auch schon gewundert, warum die.htaccess nie übertragen wurde. Dennoch wird die phpinfo nicht gestartet, sondern ist immernoch ein 500er error vorhanden! Welche Einstellungen muss man in httpd spezial vornehmen? hat dies auswirkungen auf php dateien (es steht dort jedenfalls recht viel geschrieben über php).


    EDIT: Habe ihren 2. Teil nicht gelesen, aber mod_rewirte hatte ich schon länger aktiv.
    EDIT: Außerdem kann ich immer noch nicht diesen Ordner löschen!
    EDIT: Zur Phpinfo: Ich bin nur ien trottel gewesen, da ich noch die ausführberechtigung bei allen zeilein weghatte -.- es geht jetzt! ich bedanke mich vielmals! Aber bitte diesen thread noch nicht schließen, da ich noch nicht weis, ob es mit drupal funktionieren wird :) Außerdem ist da immernoch das problem mit dem ordner. aber vielmals Danke! ICh wäre sonst noch ewig im dunkeln getappt!

  • Ich habe vorhin noch extra nachgeschaut mit der anzeige versteckter dateien nachgeschaut! Da war nix! Ich schau nochmal: lauter dateien mit nem punkt davor o.O! Was ist das nur? :) Jetzt sind sie gelöscht, nochmals danke dafür!


    EDIT: Es Funktioniert jetzt alles perfekt! Danke nochmals an alle :) Der Thread kann damit geschlossen werden/ich schließe ihn!