Wordpress Seite nicht in Google gelistet

  • Hallo,


    ich hoffe jemand hier hat Rat für mich, da ich mit meinen Ideen nun am Ende bin.


    Da meine wordpress-Seite seit Monaten nicht per google auffindbar ist, habe ich nun aktiv geschaut, was ich tun kann.


    Unter Einstellungen -> Lesen habe ich natürlich den entsprechenden Haken nicht gesetzt:

    pasted-from-clipboard.png


    Zusätzlich habe ich mir nun Yoast SEO als plugin in wordpress installiert und mir eine sidemap.xml und eine robots.txt zu erstellen.


    Die robots.txt sieht so aus:

    Code
    1. Sitemap: https://meineURL/sitemap_index.xml
    2. User-agent: *
    3. Disallow: /wp-admin/
    4. Allow: /wp-admin/admin-ajax.php


    "meineURL" ist natürlich mit der echten ersetzt.

    Ich kann auf die sidemap auch zugreifen und sie sieht korrekt aus.


    Nun habe ich meine Seite per google search eintragen lassen und mich als Besitzer verifiziert

    pasted-from-clipboard.png


    Dort habe ich meine sidemap URL eingegeben, aber sie "Konnte nicht abgerufen werden":

    pasted-from-clipboard.png


    Warum das so ist weiß ich nicht.

    Ich bekomme einen nichts aussagenden "allgemeiner HTTP-Fehler"

    pasted-from-clipboard.png


    In den Richtlinien finde ich auch nichts hilfreiches.


    Da man nicht unbedingt zwingend eine sidemap.xml braucht, wollte ich es dann anschließend "direkt" über die URL-Prüfung probieren.

    Hier bekomme ich den Hinweis:

    ============

    URL ist nicht auf Google
    Diese Seite ist nicht im Index, aber nicht aufgrund eines Fehlers. Informationen dazu, warum sie nicht indexiert wurde, findest du unten. Weitere Informationen

    ============


    Unten auf der "URL-Prüftool"-Seite befindet sich ein Abschnitt "Problem mit fehlenden Seiten beheben"


    Nachdem ich auf "Indexierung Beantragen" gegangen bin, bekomme ich diesen Fehler:

    pasted-from-clipboard.png



    Dort soll man unter Punkt 2 folgendes machen:

    Wenn der URL-Status „URL ist nicht für Google verfügbar“ lautet, maximieren Sie den Abschnitt Verfügbarkeit.

    1. Der Header für den Abschnitt „Verfügbarkeit“ sollte ein Label mit einer kurzen Beschreibung enthalten, warum die URL nicht indexiert werden konnte. Sehen Sie sich die Liste der Werte und möglichen Problembehebungen an. Wenn das Label URL ist Google nicht bekannt lautet, hat Google diese URL noch nicht gesehen. Sie sollten daher eine Indexierung der Seite beantragen. Die Indexierung dauert in der Regel einige Tage.

    Im abschnitt Verfügbarkeit steht nun das hier:

    pasted-from-clipboard.png


    Das hilft mir aber auch kein Stück weiter.

    Unter "Weitere Informationen" komme ich dann wieder auf die "URL-Prüftool"-Seite.

    Der link bestimmte Bedingungen führt leider für mich auch zu nichts brauchbarem.


    Hat irgendjemand noch einen Tipp für mich?

    Der telefonische Support konnte mir leider gar nicht helfen und ich bin mittlerweile wirklich ideenlos.


    Vielen lieben Dank an alle, die sich die Zeit nehmen mir zu helfen!

  • Mach mal Testweise in der Robots.txt die Zeile mit allow weg.

    Ich denke das gibt nur explizit die url dann frei...

    • allow: [Mindestens ein disallow- oder allow-Eintrag pro Regel]: ein Verzeichnis oder eine Seite unter der Stammdomain, die möglicherweise vom zuvor genannten User-Agent gecrawlt wird. Hierdurch wird eine disallow-Anweisung überschrieben, um so das Crawling eines Unterverzeichnisses oder einer Seite in einem ausgeschlossenen Verzeichnis zu erlauben. Gib für eine einzelne Seite den vollständigen Seitennamen an, wie er im Browser angezeigt wird. Bei einem Verzeichnis schließt du die Regel mit dem Zeichen / ab.
  • nitram :
    Das kann gut sein, weil ich gestern öfter mal hin und her getestet habe.


    Aktuell ist es korrekt, es steht nur folgendes drinne:

    Code
    1. User-agent: *
    2. Disallow: /wp-admin/
    3. Sitemap: https://asd.de/sitemap.xml.


    Das von dir genannte google-tool zeigt mir das hier an:

    pasted-from-clipboard.png

    Ich gehe daher davon aus, das soweit alles korrekt ist?


    m_ueberall :

    Das wäre tatsächlich sehr wünschenswert, allerdings steht da für mich nichts hilfreiches.

    Das Ergebnis der URL-Prüfung ist lediglich das hier:

    pasted-from-clipboard.png



    Wenn ich auf "INDEXIERUNG BEANTRAGEN" klicke kommt dieser, für mich nicht hilfreiche Fehler:

    pasted-from-clipboard.png


    Mit klick auf "LIVE-TEST ANZEIGEN" sehe ich nur das hier:

    pasted-from-clipboard.png




    Bei der sidemap-Seite ist ebenfalls ein sehr generischer und nicht hilfreicher "Allgemeiner HTTP-Fehler"

    pasted-from-clipboard.png


    Diese ganzen "Hilfe-Seiten" ("bestimmte Bedingungen" etc.) von google sind leider wenig aufschlussreich.

    Ich im Detail auch schon im ersten Beitrag beschrieben, warum es mir nicht weiterhilft - vielleicht siehst du da ja einen Fehler von mir oder hast eine weitere Idee?


    Ich danke euch beiden jedenfalls schonmal, dass ihr dabei seid mir zu helfen :)

  • Neben "Indexierung zulässig?" auf dem vorletzten Screenshot ist ein "(I)" – da müsste doch der Grund stehen?

    Wenn die Sitemap nicht gefunden wird (aber vorliegt/erstellt werden kann), kann man sie manuell "pushen" via "Ping-Tool", siehe hier. Mit etwas Glück bekommt man dort eine abweichende/detailliertere Fehlermeldung zurück.

  • Das dachte ich zuerst auch m_ueberall , allerdings ist das kein "echtes (i)" :(


    Ich kann dort nicht drauf klicken und es erscheint auch kein popup o.ä.. Es ist einfach nur ein grauer Kreis mit einem i-Zeichen.

    Damit ihr euch auch davon überzeugen könnt, habe ich mal ein Video davon gemacht:


    Wie Sie sehen, sehen Sie nix :D


    Zur Sicherheit habe ich es mit aktuellem Chrome, Edge und FireFox-Browsern getestet. Keiner zeigt dort einen Hinweis an.


    Die sidemap ist übrigens eine von wordpress dynamisch erzeugte (also keine echte auf dem Server abgelegte sidemap.xml) - nur falls das irgendwie relevant ist.

    Ich habe die URL/sidemap mal manuell gepusht und bekomme dabei diese Rückmeldung angezeigt:

    Code
    1. Sitemap-Benachrichtigung erhalten
    2. Ihre Sitemap wurde unserer Liste von Sitemaps, die gecrawlt werden sollen, hinzugefügt. Falls Sie Google diese Sitemap zum ersten Mal melden, fügen Sie sie über http://www.google.com/webmasters/tools/ hinzu, damit Sie den Status verfolgen können. Beachten Sie, dass wir nicht alle eingereichten URLs unserem Index hinzufügen und wir können nicht vorhersagen oder garantieren, wann oder sie angezeigt werden

    Ich denke auch, dass die sidemap nur ein "Randproblem" ist, weil man ja eigentlich nicht zwingend eine für google benötigt (besonders, weil die Seite gerade mal als 9 Unterseiten besteht).

    Das richtige Problem ist, dass google sich ohne konkrete Fehlermeldung weigert, die Seite zu indexieren :(


    Danke für eure Tipps! Ich hoffe wir nähern uns der Ursache an :)

  • "Da meine wordpress-Seite seit Monaten nicht per google auffindbar ist..."


    Gar nicht auffindbar oder nur nicht auf den ersten Seiten?

    Was ergibt die google Suche über site:deinedomain.tld ?


    Wenn eine eine Seite als nicht indexiert geführt wird sollte man auch beachten: Google sieht jede domain zur gleichen Seite und auch jedes Protokoll (http/https) als unterschiedliche Seite an und indexiert diese separat.


    "Die sidemap ist übrigens eine von wordpress dynamisch erzeugte (also keine echte auf dem Server abgelegte sidemap.xml) - nur falls das irgendwie relevant ist."

    Die sitemap liegt aber auf dem Server? Google muss ja darauf beständig zugreifen können.


    Lass die robots.txt doch erstmal einfach mal ganz weg. badbots ignorieren die ja sowieso.


    Die Google Search Console ist außerdem recht träge (und auch recht eigenwillig) Es kann schon eine ganze Weile dauern, bis google anfängt eine sitemap zu crawlen.


    Ich habe mehrere Seiten darüber indexieren lassen und kann sagen: SEO-Tuning meinerseits hat eher wenig gebracht. (Nicht nichts, aber wenig) Keywords werden weitgehend ignoriert, eigene descriptions durchaus auch mal von google selbsterstellte ersetzt.

    Aber Content rulez. :) Keine Ahnung wie Google das mittlerweile so effektiv hinbekommt, aber je originär die Seiten waren, desto schneller wurden sie indexiert und desto weiter oben sind sie in der SERP gelandet.


    Sitemaps können die Erstindexierung durchaus anstoßen, aber mehr auch nicht. Google macht das auch ohne sitemap. Eine "Landingpage" reicht im Prinzip aus. Aber erst mit der Zeit wird die Seite dann nach oben gespült. (Und natürlich kann niemand, der eine Seite über Ubuntu erstellt erwarten, dass seine Seite beim Suchbegriff "Ubuntu" gleich von Anfang an auf den ersten 100 SERPs erscheint)


    Ich habe mehrere Bücher über SEO durchgeackert und auch versucht die Ratschläge umzusetzen.

    Mein Fazit:

    Wenn der Inhalt der Seite öde ist oder nur abgekupfert und sich eh kein Schwein dafür interessiert, dann hilft kein Tuning der Welt um das Ranking zu verbessern.

    Ist der Inhalt originär und interessant, dann wird sich die Seite mit der Zeit von ganz alleine nach oben schieben.

  • Ja, Googles Algorithmen sind teilweise recht intelligent geworden. Man sieht auch deutlich, dass z.B. Bing m.E. wesentlich weniger intelligent auswertet. Da ist immer noch viel mit Suchbegriffen in der URL zu machen, was Google nach meinen letzten Erfahrungen kaum noch beeindruckt. Gesehen habe ich das an einer relativ neuen Plattform für Rechtsanwälte. Da werden weitgehend identische Websites erstellt, die praktisch nur aus einer Reihe von Textbausteinen bestehe, bei denen an mehr oder weniger passenden Stellen Ort und Rechtsgebiet eingesetzt werden, die beide auch in der URL vorkommen. Bei Bing und somit auch DuckDuckGo ranken diese Seiten ziemlich gut, bei Google so gut wie gar nicht. Da ranken die eigenen Seiten der Anwälte meist viel besser. Da erkennt Google offenbar die Textbausteine bzw die große Ähnlichkeit der Webseiten und "bestraft" diese Strategie dann ziemlich stark. Dass die dann aber mittels Google-Ads zumindest teilweise als "Anzeige" angezeigt werden, bis halt das Budget aufgebraucht ist, da hat Google freilich nichts dagegen. ;)

  • Hallo an euch beide :)


    "Da meine wordpress-Seite seit Monaten nicht per google auffindbar ist..."

    Gar nicht auffindbar oder nur nicht auf den ersten Seiten?

    Was ergibt die google Suche über site:deinedomain.tld ?

    aRaphael : Es wird tatsächlich gar nicht in google gelistet!

    Es wird nur ein "Ergebnis" gelistet:

    Code
    1. In Google Search Console überprüfen
    2. www.google.com/webmasters/
    3. Gehört dir abc.de? Rufe Indexierungs- und Rankingdaten von Google ab.
    4. Es wurden keine mit deiner Suchanfrage - site:abc.de - übereinstimmenden Dokumente gefunden.

    Die Seite wird komplett auf https umgeleitet, http gibt es nicht, bzw. ist nicht erlaubt.


    Es ist eine wordpress-Seite deren Inhalt komplett mit dem plugin "Envato" erstellt/designed wurde.


    Quote

    "Die sidemap ist übrigens eine von wordpress dynamisch erzeugte (also keine echte auf dem Server abgelegte sidemap.xml) - nur falls das irgendwie relevant ist."

    Die sitemap liegt aber auf dem Server? Google muss ja darauf beständig zugreifen können.

    Nein die Datei liegt nicht auf dem Server.

    Das hat mich auch gewundert. Ich bin Wordpress-Neuling und als ich mich eingelesen habe, habe ich irgendwo entdeckt (Link gerade nicht auffindbar), dass die sidemap.xml nicht "wirklich" auf dem Server gespeichert wird, sondern durch die Funktionen in wordpress/wp-includes/sitemaps/ "dynamisch erstellt" wird.

    Das heißt, wenn jemand die URL eingibt, wird mit diesen Funktionen eine sidemap.xml ausgegeben, auch wenn diese nicht wirklich als Datei auf dem Server liegt.


    Aktuell nutze ich das Plugin "XML Sidemap Generator" und sehe dort zumindest auch, dass diese erfolgreich an google und an bing gegeben wurde:

    pasted-from-clipboard.png


    Mit klick auf den Link "your main sidemap and all sub-sidemaps" bekomme ich auch eine Erfolgsmeldung angezeigt:


    pasted-from-clipboard.png



    Aber die sidemap oder auch robots.txt ist nur eine Kleinigkeit.

    Problematisch ist, dass die Seite wirklich überhaupt nicht bei google gelistet ist.


    Quote

    Es kann schon eine ganze Weile dauern, bis google anfängt eine sitemap zu crawlen

    Ja, aber nach nun ~3 Monaten sollte sie eigentlich da sein.

    Bei google "verifiziert" und über die "Google Search Console" versucht irgendetwas zu erreichen habe ich allerdings erst vorgestern.

    Dennoch sollten die Suchmaschinen eine Seite ja auch listen, wenn man sie nicht aktiv versucht zu pushen.

    Zumindest ist das nach meinem Verständnis die Kernidee hinter einer Suchmaschine :D


    SEO und auch das ranking sind erstmal zweitrangig. Überhaupt gefunden zu werden ist das oberste Ziel :)


    Über das Wordpress Toolkit im WCP, gibt es einen Punkt "Sicherheit". Kann es sein, das hier etwas den Zugriff sperrt?

    So sieht es aktuell aus:

    pasted-from-clipboard.png




    Hallo auch and dich tab

    Ich hätte auch nichts dagegen im ranking "bestraft" zu werden, wenn es denn zumindest überhaupt gelistet würde.

    Gleiches gilt übrigens auch für bing und duckduckgo. Auch dort wird die Seite gar nicht gefunden.


    Inhaltlich ist nicht ein einziger Satz per Textbaustein - also daran kann es nicht liegen.


    Ich habejetzt auch mal über https://search.google.com/test/mobile-friendly getestet, ob meine Seite mobil aufrufbar ist.

    Dort bekomme ich diesen Fehler:

    pasted-from-clipboard.png


    Aha! Also gibt es nicht "keine Fehler" sondern anscheinend blockiert was tatsächlich die Suchmaschinen.

    Jetzt ist nur die Frage, wo ich am besten suchen sollte.


    Ich vermute, dass es nicht an der robots.txt, der .htaccess oder der sidemap liegt.

    Zur Sicherheit aber hier auch nochmal meine .htaccess:



    Über das Wordpress-Toolkit sind folgende Einstellungen gesetzt:

    pasted-from-clipboard.png


    Lieben Gruß und danke an alle, die sich daran beteiligen :)


    EDIT:

    Bei dem "(?)" hinter dem "Suchmaschinenindexierung" ist folgendes zu finden:

    pasted-from-clipboard.png


    Anscheinend wird auch die robots.txt dynamisch/virtuell erzeugt.

    Wo man diese bearbeiten kann weiß ich nicht und auch netcup konnte mir da am Freitag (Hotline) nicht helfen.

    Über meinerURL/sidemap.xml kann ich darauf zugreifen.


    Wenn ich meine robots.txt auf dem Server lösche, sehe ich dort

    Code
    1. User-agent: *
    2. Disallow: /wp-admin/
    3. Allow: /wp-admin/admin-ajax.php
    4. Sitemap: https://asd.de/wp-sitemap.xml
    5. Sitemap: https://asd.de/sitemap.xml



    Wenn ich über das Toolkit die "Suchmaschinenindexierung" aussschalte, erhalte ich das hier:

    Code
    1. User-agent: *
    2. Disallow: /wp-admin/
    3. Allow: /wp-admin/admin-ajax.php
    4. Sitemap: https://asd.de/sitemap.xml


    Die "wp-sitemap.xml" ist übrigens leer und führt auf eine 404-Seite

  • nitram


    Zuerst zu deinem PS: Also ich hatte das Bild hochgeladen und mich danach entschieden die URL zu zensieren. Leider kann ich danach meinen Beitrag nicht mehr editieren. Weißt du wie ich das Bild entsprechend gelöscht bekomme?


    Zum Fehler:
    Ich hab in den sauren Apfel gebissen und eine weitere Seite parallel von Hand mit wordpress aufgesetzt (von Hand = neues worpress per FTP hochgeladen und eine frische Datenbank angelegt).

    Danach habe ich Schritt für Schritt alles identisch eingerichtet, d.h. alls Plugins, Inhalte und .htaccess angeglichen.

    Die neue Seite war ohne Probleme auffindbar.


    Dann habe ich die Hauptseite über Plesk/Wordpress-Toolkit komplett gelöscht und die Seite ebenfalls nochmal koplett händisch installiert.

    Ergebnis: Seite nicht auffindbar.

    Danach habe ich beim Support angerufen, ob da irgendwelche Cache Dateien oder ähnliches zwischengespeichert werden und alle X min erneuert werden oder so.

    Antwort war nein und dass das Problem von mir kommen muss.

    Da die Seite aber 100%ig neu war konnte das eigentlich nicht sein.


    Zur Sicherheit habe ich nochmal die Hauptseite komplett neu aufgesetzt. Schritt für Schritt, weil ich vom Aufsetzen der Testseite ein Video gemacht hatte.

    Ergebnis: Weiterhin nicht per google auffindbar/zugreifbar.


    Ich habe dann im WCP und CCP jede Einstellung gründlich verglichen.

    Es gab genau einen Unterschied:

    Im CCP auf Produkte -> Übersicht, dort die Domain auswählen -> unter den Plesk-Panel-Links auf Hosting-Einstellungen -> unter Sicherheit

    hatte ich die Dauerhafte, für SEO geeignete 301-Weiterleitung von HTTP zu HTTPS aktiviert.

    Da ich sie nicht selber deaktivieren kann, habe ich eine mail an netcup mit Bitte der Deaktivierung geschickt.


    Unmittelbar nach der Bestätigung durch netcup konnte die Seite gefunden werden.

    Vorher wurde mir am Telefon gesagt, dass es daran sicher nicht liegen könne.


    Jetzt sieht es im CCP bei mir an dieser Stelle so aus und es funktioniert ohne Probleme:

    pasted-from-clipboard.png


    Ich wüsste eigentlich gerne, wo diese Weiterleitung abgefangen wird, weil sie ja sicher nicht in der .htaccess landet.

    Sie ist für mich jedenfalls sicher der Grund für das Problem gewesen.


    Danach habe ich die manuell installierte Haupt-Seite wieder gelöscht und per Wordpress-Toolkit installiert.

    Jetzt geht jedenfalls alles und es liegt/lag sicher nicht am WP-Toolkit oder Plesk.

    Könnte für jemandem mit einem ähnlichen Problem in Zukunft eine wichtige Info sein ;)


    Vielen Dank an alle Helfer

    nitram , m_ueberall , aRaphael , tab


    auch wenn es letztendlich an was anderem gelegen hat :)

  • […] Also ich hatte das Bild hochgeladen und mich danach entschieden die URL zu zensieren. Leider kann ich danach meinen Beitrag nicht mehr editieren. Weißt du wie ich das Bild entsprechend gelöscht bekomme?

    Die Forenbetreuerinnen (CC [netcup] Claudia M. , [netcup] Christina R. , [netcup] Lucia S. ) können hier bestimmt weiterhelfen und das Bild entweder vollständig anonymisieren oder ganz entfernen.