managed vServer (mit Plesk) + extra Mail-Server

  • Hallo zusammen,


    ich habe einen managed Server (zum Webhosting) und einen Root-Server als Mail-Server.


    Nun ist es so, dass wenn über eine Shopwareinstallation eine Mail verschickt wird und der Empfänger eine Mail-Adresse einer Domain hat, welche u.a. auf dem managed Server zum Webhosting aufgeschalten ist, die Mail nicht ankommt (am Root-Server).


    Mails zu dritten gehen problemlos raus - und kommen auch von diesen an.


    Letztendlich muss man doch einfach sicher den "Mail-Support" in Plesk deaktivieren - oder? Und wenn ja, wie ist das möglich?

  • Moin,

    ich finde es etwas verwirrend wie du die Begriffe nutzt.

    Also es gibt ein Webhosting-Server und einen Mail-Server.

    Bestellungen vom Webhosting-Server kommen am Mailserver nicht an:


    Das liegt daran, dass die Domain, shop.xy an den Webserver verweist und dort eingetragen ist.
    Wenn shop.xy nun eine mail versenden soll an info@shop.xy dann schaut er erst lokal, entdeckt - das bin ja ich - und versucht die Mail lokal zu zu stellen. Er versucht also keine externe Zustellung.

    Eine Möglichkeit wäre es den Mailserver auf dem Webhosting zu deaktivieren.
    "Besser" oder sauberer wäre es wenn der Shop seine Mails via. SMTP über den Mailserver versenden würde.

  • Ich gehe mal davon aus dass auch bei deaktiviertem Mailservice der Server trotzdem denkt dass die Domain ja lokal gehostet wird - und keine Mails annimmt.

    Daher würde ich dir raten den Mailversand auf SMTP umzustellen und über den Mailserver laufen zu lassen.

    Sollte in den Einstellungen deines Shopsystems zu finden sein.

  • Dann denk ich stimmt was anderes nicht. Sobald der Mailservice einer Domain deaktiviert ist, reagiert der Server auch nicht. SMTP ist aber grundsätzlich immer eine gute Idee. Die deaktivierte Maildomain ist aber nicht zufällig auch die Abonnement Domain oder? Denn dann kann das wirklich zu Problemen führen.

  • Danke für Eure Antworten.


    Ich nutze nun in der Zwischenzeit SMTP zum Mailversand (und als Mail-Server (Shopware nennt das hier HOST) ist natürlich auch der Mail-Server eingetragen), leider kommen Mails nur bei Kunden an, die Beispielsweise eine gmail Mail-Adresse nutzen.



    Die Kopie an mich kommt nicht an.


    Die URL des Shops ist natürlich auch die, welche für die Mailadresse verwendet wird.

    Dann denk ich stimmt was anderes nicht. Sobald der Mailservice einer Domain deaktiviert ist, reagiert der Server auch nicht. SMTP ist aber grundsätzlich immer eine gute Idee. Die deaktivierte Maildomain ist aber nicht zufällig auch die Abonnement Domain oder? Denn dann kann das wirklich zu Problemen führen.

    In wie fern kann das zu Problemen führen?

  • Sendmail oder PHPmil nutzt in Plesk die "Hauptdomain" (Abonnementdomain) und den Systembenutzer im Hintergrund. Unteranderem aus diesem Grund wird bei den meisten Hostern als Hauptdomain eine technische Adresse verwendet. Wenn du nun über Sendmail eine Mail verschickst, verwendet Plesk im Hintergrund hauptbenutzer@abonnementdomain verwendest. Deshalb kann es zu Problemen führen.

  • Sendmail oder PHPmil nutzt in Plesk die "Hauptdomain" (Abonnementdomain) und den Systembenutzer im Hintergrund. Unteranderem aus diesem Grund wird bei den meisten Hostern als Hauptdomain eine technische Adresse verwendet. Wenn du nun über Sendmail eine Mail verschickst, verwendet Plesk im Hintergrund hauptbenutzer@abonnementdomain verwendest. Deshalb kann es zu Problemen führen.

    Gibt's eine Möglichkeit, dass das umgangen wird?