Debian 6 Image und manuele installation von ISPCP

  • Guten Morgen Netcup Community,


    Ich stehe vor einem Problem das ich nicht gelöst bekomme.
    Ich habe ispcp 1.0.7 installiert, und das auf Debian 6.
    Nun kann ich keine Dateien mehr hochladen, bei einer bestimmten Größe fängt er von vorne an, oder gibt mir einen Error aus Wordpress (IO Error)
    zuerst bin ich von einem Problem bei Wordpress ausgegangen, als ich merkte das es bei allen Scripts Upload probleme gab dachte ich an die Server Software.


    Ich habe in folgenden Ordnern aus (Verzweifelung) schon die php.ini überarbeitet
    /etc/php5/
    /var/www/fcgi/master/


    /var/www/fcgi/WEBSEITEN/



    Leider ohne erfolg, hätte jemand eine Idee womit das sonst zusammen hängen könnte?
    Vielen Dank! LG.L

  • [code]echo "MaxRequestLen 15728640" >> /etc/apache2/mods-available/fcgid.conf[/code] Den Wert ggf. anpassen, hier sind es 15MB (15*1024*1024). Das ist ein explizites "Problem" von fcgid. Der Wert sollte mindestens dem upload_max_filesize bzw. post_max_size Wert der php.ini entsprechen.
  • Danke für die schnelle Antwort, ich habe direkt mal mit phpinfo(); geprüft.
    Ich habe eine Datei über ISPCP auf eine der Virtuellen Webseite hochgeladen, des Resultat ist ein weißes Screen.
    als zweites habe ich die"phpinfo" Datei in folgendes Verzeichnis gelegt: "/var/www/ispcp/gui/"
    Der Webbrowser zeigt mir auch nur ein weißes Bild.


    Ich habe dementsprechend auch meine Webseiten in der php.ini abgeändert

    fcgid


    .

  • hier...was nicht aktiv ist: disable_functions = show_source, system, shell_exec, passthru, exec, phpinfo, shell, symlink


    ispcp ist eh am einschlafen. der fork von i-MSCP – internet Multi Server Control Panel - i-MSCP – internet Multi Server Control Panel
    laeuft sehr gut und hat auch die mögl. die php.ini zu bearbeiten auf user basis im cp

    Logic will take you from A to B. Imagination will take you everywhere.(A.Einstein)
    Nur wer sein Ziel kennt findet auch den Weg!

  • Alles klar, hatte nicht bemerkt das phpinfo() disable war.
    Nachdem editieren habe ich erneut phpinfo() aufgerufen.


    [Blocked Image: http://images.devs-on.net/Thumb/lBOo9MGD5Fgz2sd-Bereich.png]



    Scheint mir so als würde er die richtige aufrufen.
    Jetzt glaube ich aber gibt es ein anderes Problem, im Verzeichnis des ISPCP´s wird phpinfo nicht aufgerufen. (Weißes Bild)
    Also habe ich mir die "/etc/php5/cgi/php.ini" erneut angesehen, dort ist mit aufgefallen das keine Funktionen deaktiviert ist.


    PS: Gestern habe ich ebenfalls versucht eine 500 KB große SQL Datei bei phpmyadmin hochzuladen. bei knapp 60 % brach es ab.


    LG.L

  • Die Kunden in ispCP haben alle eine eigene php.ini zu finden unter [siehe Wikieintrag [url=http://www.netcup-wiki.de/wiki/H%C3%A4ufig_gestellte_Fragen_zu_ispCP#Wie_kann_ich_die_php.ini_der_einzelnen_vHosts_bearbeiten.3F]Häufig gestellte Fragen zu ispCP - Wie kann ich die php.ini der einzelnen vHosts bearbeiten[/url]]. Neben dem RequestLen muss man auch das upload Limit und weitere Werte in der richtigen php.ini passen. Welche php.ini für PHPmyAdmin verwendet wird, muss man ggf. extra prüfen.
  • Die php.ini für die einzelnen Benutzer habe ich bereits berücksichtigt.


    z.b
    "/var/www/fcgi/eascriptable.de.vu/php5/php.ini"



    Nun dachte ich mir aber das der ISPCP "Benutzer" ebenfalls die Ini von hier bezieht
    "/etc/php5/cgi/php.ini" so gibt es mit die phpinfo() ebenfalls aus.


    Scheinbar ist es aber folgende: /var/www/fcgi/master/php5/php.ini
    Diese habe ich ebenfalls editiert damit meine Upload_size größer ist, jedoch alles weiterhin ohne Erfolg


    //Edit
    Vielleicht kann ja jemand was aus der phpinfo() entnehmen


    phpinfo()