"Undelivered Mail Returned to Sender" an Microsoft

  • Hallo zusammen,


    ich besitze momentan einem vServer mit Debian Jessie auf welchem ein SMTP-Server mit Mailcow und eine Nextcloud läuft. Das Problem welches ich beschreibe betrifft den Mailserver.
    Ich kann an jeden Anbieter Mails senden. Diese werden auch zugestellt bis auf an Hotmail/Outlook. Kurz an Microsoft. Sobald ich die Mail versende, kommt eine Mail zurück mit dem Betreff "Undelivered Mail Returned to Sender" und folgendem Inhalt:



    Reporting-MTA: dns; mail.xy.eu

    X-Postfix-Queue-ID: 4F50720B30

    X-Postfix-Sender: rfc822; simon@xy.eu

    Arrival-Date: Wed, 21 Jun 2017 14:39:24 +0200 (CEST)Final-Recipient: rfc822; ali_k....@hotmail.com

    Original-Recipient: rfc822;ali_k....@hotmail.com

    Action: failed

    Status: 5.0.0

    Remote-MTA: dns; mx4.hotmail.com

    Diagnostic-Code: smtp; 550 SC-001 (COL004-MC4F50) Unfortunately, messages from

    46.XY.XY.179 weren't sent. Please contact your Internet service provider

    since part of their network is on our block list. You can also refer your

    provider to http://mail.live.com/mail/troubleshooting.aspx#errors.



    Der Link verrät mir nur, dass ich mich an meinen Serverprovider melden soll. Netcup kann sich aber nicht wirklich einen Reim darauf machen und mir wohl auch nicht helfen.


    Weiß jemand was ich ändern muss damit die Mails zugestellt werden? Empfangen kann ich diese ohne Probleme. SPF und DKIM-Records im DNS sind gesetzt und werden laut diversen Testwebsites auch anerkannt. Hat irgendwer eine Idee?



    Anbei ich bin Informatiker in Ausbildung und hätte - sofern Möglich auch den technischen Hintergrund erklärt. :)


    Liebe Grüße

    Simon

  • zumindest MS und Yahoo führen offenbar interne Blacklists, insofern ist ja schonmmal "nett", dass du ueberhaupt ein entsprechende Mail bekommst. Z.T. War es schon (s. div. Meldungen im Forum), dass Mails klar angenommen wurden, aber beim Empfänger nie ankamen. Warum der IP-Range auf einer Blacklist steht, kann dir nur MS sagen.

    Gruss

  • Sende mal eine Mail an den Mailtester, und schau, ob da alles passt.


    Prüfe hier, dass du auf keinen (relevanten) Blacklists stehst. Ansonsten dort ein Delisting beantragen.


    Wenn bis hierhin alles ok ist, melde dich hier bei Microsoft SNDS an, füge dort die IP hinzu (sodass sie dort sichtbar ist) und beantrage anschließend hier ein Delisting der IP. Du solltest in Kürze eine Rückmeldung erhalten, dass die IP wieder freigegeben ist. Danach sollte der Versand an Hotmail / Outlook / Live erfolgreich möglich sein.

  • Du solltest in Kürze eine Rückmeldung erhalten, dass die IP wieder freigegeben ist. Danach sollte der Versand an Hotmail / Outlook / Live erfolgreich möglich

    Meiner Erfahrung nach stellen sie sich (selbst falls das Delisting zurecht beantragt wurde) beim ersten mal quer, dann einfach auf die "Absage" zum Delisting nochmal (etwas bestimmter) antworten.

    Im Normalfall wird es dann von einem echten Menschen geprüft, der die Freischaltung dann durchführt, oder den Prozess nochmal (unbegründet) ablehnt.

    Darauf dann einfach nochmal (etwas bestimmter) antworten. Darauf sollte, wenn Microsoft nichts mehr (begründet) zu reklamieren hat, bei normalsterblichen ein Delisting durchgeführt werden.

  • Fehlercode SC-001 scheint mir nicht zu bedeuten, dass Du auf der Microsoft-Blacklist stehst, eher das du auf irgend einer Blacklist stehst, prüfe das mal z.B. mit http://rbl-check.org/


    Man kann dir übrigens schlecht helfen, denn mir scheint Du hast im Ursprungsposting Angaben verschleiert die zur Beurteilung nötig wären - denn die teils unkenntlich gemachte IP-Adresse Deines MTA passt mit mail.xy.eu nicht zusammen, ich bezweifle, dass es um die Domain xy.eu geht.

  • Sowas kriege ich auch. Da steht dann drin:


    Code
    1. [deleted] host
    2.     outlook-com.olc.protection.outlook.com[104.47.33.33] said: 550 5.7.1
    3.     Unfortunately, messages from [185.183.156.191] weren't sent. Please contact
    4.     your Internet service provider since part of their network is on our block
    5.     list (AS3150). You can also refer your provider to
    6.     http://mail.live.com/mail/troubleshooting.aspx#errors. (in reply to MAIL
    7.     FROM command)

    Einen richtigen Reim kann ich mir nicht draus machen, denn AS3150 ist von 2000 NTT angelegt worden, und da sind derzeit gar keine IP-Adressen mehr drin.


    Zum Glück habe ich nur ganz wenige Kontakte, die sich einen outlook/hotmail-Account eingetreten haben.

  • Unfortunately, messages from [185.183.156.191] weren't sent. Please contact
    your Internet service provider since part of their network is on our block
    list (AS3150). You can also refer your provider to

    Also wenn dem tatsächlich so ist, dann läuft bei Microsoft hier einiges falsch. Der IP-Adressbereich gehört zu netcup und hier in der Meldung wird angegeben, dass dieser noch zu einem alten AS der NTT America gehören würde.

    Da macht es gerade Sinn netcup und Microsoft einmal Bescheid zu geben, damit hier etwas erreicht werden kann.

  • War bei mir genauso, bei nem frisch gebuchtem Server. In der Doku steht auch irgendwo, dass neue/unbekannte IPs wohl erst geblockt sind und sich den Zugriff quasi verdienen müssen. Heißt: freischalten lassen, dann geht der Zugriff eingeschränkt. Wenn es auf Dauer ohne Probleme läuft wird die Einschränkung auch aufgehoben.

  • Ein Mitarbeiter von Microsofts Mail Team (Spam Analysis) antwortet regelmäßig auf der mailop.org Mailingliste. Dort weißt er in solchen Fällen immer auf das von thomba vorgeschlagene Verhalten hin:

    Code
    1. Open a HotMail Ticket http://go.microsoft.com/fwlink/?LinkID=614866&clcid


    Dort dann nach der ersten Antwort (kommt vom Robot) erneut antworten und ggf. ein drittes Mal antworten. In der Regel kommt man dann dort runter. Zusätzlich im SNDS registrieren und die IP verifizieren. Das hilft normalerweise beim Ticket und man hat beim ersten menschlichen Kontakt schon eine positive Antwort.


    Ps.: Die mailop.org Mailingliste kann ich nur empfehlen. Falls bei den großen Providern Probleme auftreten, weiß man es relativ zügig und muss gar nicht erst an seinem Setup forschen ;-)

  • Hallo Leute,


    ich bin neu hier im Forum (aber nicht als Kunde bei Netcup) und hatte exakt dieses Problem, nachdem der Mailversand vorher monatelang problemlos lief.

    Ich las diverse Foren (auch dieses) und bastelte mir mögliche Lösungswege zusammen inklusive MS-Support.

    Im Laufe eines stressigen Arbeitstages kam mir heute vermutlich die zündende Idee.


    Mir wurde von MS gesagt, meine IP sei nicht auf der Blocklist, der Server behauptete das aber fleißig. Ich probierte also mal, ob man so dämlich denken kann, wie ich befürchtete und siehe da, meine dynamische IP hier zuhause war gelistet. Ich vermute, dass große Anbieter bei MS whitelisted sind und dieser Test bei Mails über deren Server übergangen wird.


    Die Lösung:


    Die Client-IP im RECEIVED-Header überschreiben. Da MS auch noch routbare (nicht private) IPs erwartet, geht einfaches Verbergen nicht. Ich ersetze daher aktuell die Client-IPs durch meine Server-IP. Die ist routbar, hat n gültigen rDNS und ist nicht blacklisted.

    Solltet Ihr DKIM nutzen, achtet darauf, dass der ganze Rewrite-Kram VOR der Signierung passiert. Und ja, achtet auch auf den SPF, meiner enthielt noch ein ptr.


    Und siehe da: Meine Mails gehen wieder durch!


    Gutes Gelingen!


    P.S.: der MS-Support sucht noch nach dem Fehler.

  • Sowas kriege ich auch. Da steht dann drin:


    Code
    1. [deleted] host
    2.     outlook-com.olc.protection.outlook.com[104.47.33.33] said: 550 5.7.1
    3.     Unfortunately, messages from [185.183.156.191] weren't sent. Please contact
    4.     your Internet service provider since part of their network is on our block
    5.     list (AS3150). You can also refer your provider to
    6.     http://mail.live.com/mail/troubleshooting.aspx#errors. (in reply to MAIL
    7.     FROM command)

    Einen richtigen Reim kann ich mir nicht draus machen, denn AS3150 ist von 2000 NTT angelegt worden, und da sind derzeit gar keine IP-Adressen mehr drin.


    Zum Glück habe ich nur ganz wenige Kontakte, die sich einen outlook/hotmail-Account eingetreten haben.

    Falls das Problem noch besteht (ich hatte das gleiche nun auch), hier mal ein Update von mir.
    https://forum.netcup.de/admini…e-lang-eine-probleme-gab/

  • Nachtrag: bist Du Dir sicher, daß mit dem DNS alles in Ordnung ist?

    sprich was verwendest Du als HELO namen?

    welchen rDNS hast Du definiert?


    es klappt ohne irgendwelcher Änderungen an der postfix-Konfig. (verwende 2.6.6)


    Code
    1. Dec 3 17:26:30 vhost01 postfix/smtp[18458]: Host offered STARTTLS: [outlook-com.olc.protection.outlook.com]
    2. Dec 3 17:26:31 vhost01 postfix/smtp[18458]: 1131D41D9B: to=<###@outlook.com>, relay=outlook-com.olc.protection.outlook.com[104.47.33.33]:25, delay=1.9, delays=0.13/0.01/0.62/1.1, dsn=2.6.0, status=sent (250 2.6.0 <5A2425B4.3060404@###> [InternalId=67615670188496, Hostname=BN3NAM01HT122.eop-nam01.prod.protection.outlook.com] 13057 bytes in 0.296, 42.991 KB/sec Queued mail for delivery)


    smtp_helo_name = mail.domain.tld


    smtp_bind_address = IPv4

    smtp_bind_address6 = IPv6


    und die rDNS lösen diese beiden IP-Adressen zu domain.tld auf ...

    ebenso existieren die A bzw. AAAA DNS Einträge f. domain.tld;


    Falls hier jemand - so wie ich - mehr als nur eine IPv6 Adresse vom /64-Prefix verwendet,

    sei hier der Hinweis gegeben, daß

    http://domain.tld bzw. https://domain.tld nur dann funktioniert,

    wenn

    (a) die selbe IPv6 auch f. den Apache verwendet wird

    (b) diese IPv6 als weitere IP Adresse, auf welche der Apache horcht

    f. diesen vHost verwendet wird;