Mail account einrichten Debiam/Froxlor, Postfix/Dovecot

  • Hallo zusammen,
    ich habe ein vServer mit Froxlor und ich versuche eine Mail einzurichten. Domain habe ich bei einem anderen Anbieten wo ich den A-Eintrag angepasst hatte (vServer-IP eingetragen). Die Seite wird aufgerufen einwandfrei.
    Das Mail-Konto habe ich angelegt und einiges rumprobiert um das zum Laufen zu bringen und viele Beiträge hier gelesen. Jedoch klappt nichts.


    Bitte im Hinweise!


    Vielen Dank!

  • Ich bekomme einfach Thunderbird nicht zum Laufen.


    MX hatte ich nicht geändert. Soll ich da einfach meine Domain eintragen?
    Dann als IMAP-und SMPT-Server auch meine Domain ohne irgendwelche Zusätze?


    Danke!

  • Thunderbird kannst du im Zweifelsfall auch direkt gegen eine IP-Adresse laufen lassen. Wichtiger ist, dass dein Mailserver steht und funktioniert. Zu Froxlor direkt kann ich nichts sagen, das Programm habe ich noch nie eingesetzt.

  • Nur installiert. Soweit ich weiß sind die Grundeinstellungen schon nutzbar. Liege ich da falsch?


    mxtoolbox.com liefert folgendes:

    Quote

    [Blocked Image: http://mxtoolbox.com/public/images/statusicons/warning.png]SMTP TLSWarning - Does not support TLS.[Blocked Image: http://mxtoolbox.com/Public/images/StatusIcons/info.png] More Info[Blocked Image: http://mxtoolbox.com/public/images/statusicons/ok.png]SMTP Reverse Banner CheckOK - 5.45.109.226 resolves to v22014042143317921.yourvserver.net
    [Blocked Image: http://mxtoolbox.com/public/images/statusicons/ok.png]SMTP Reverse DNS MismatchOK - Reverse DNS matches SMTP Banner[Blocked Image: http://mxtoolbox.com/public/images/statusicons/ok.png]SMTP Connection Time1.186 seconds - Good on Connection time[Blocked Image: http://mxtoolbox.com/public/images/statusicons/ok.png]SMTP Open RelayOK - Not an open relay.[Blocked Image: http://mxtoolbox.com/public/images/statusicons/ok.png]SMTP Transaction Time3.572 seconds - Good on Transaction Time

  • Wenn ich das mit Outlook versuche, meldet er:


    Quote

    An Posteingangsserver anmelden (IMAP): Fehler bei der Allgemein-Authentifizierung. Keine der Authentifizierungsmethoden, die vom IMAP-Server unterstützt werden, wird von diesem Computer unterstützt.


    und

    Quote

    Testnachricht senden: Antwort des Servers: 553 5.7.1 <info@xn--80akhj1aedi7b.com>:

  • Ich nehme an, dass du schon das vorkonfigurierte Froxlor mit Debian Wheezy genommen hast, oder?


    Der MX Eintrag muss auf mail.deinedomain.tld verweisen. Die Domain, auf den der MX Eintrag zugewiesen ist, darf nun aber keinen Kunden in Froxlor zugewiesen sein, sonst funktioniert das nicht. Genau das hast du aber gemacht, oder? ;)

  • Poste mal bitte die dovecot einstellungen und die postfix einstellungen:


    Code
    1. dovecot -n


    Code
    1. postconf -n



    und den Inhalt aus /var/log/mail.log und /var/log/mail.err.
    Wenn du dich auch nicht mit der IP-Adresse einloggen kannst hat das nichts mit den Domaineinstellungen zutun, sondern nimmt einer oder beide Dienste (Dovecot & Postfix) etwas aus irgendwelchen Gründen nicht an.



    EDIT:


    was mir noch eingefallen ist... hast du die korrekten daten in thunderbird eingegben? also port, verschlüsselung, passwort übertragung, etc.?
    ich mag mal bezweifeln das froxlor automatisch eine subdomain autoconfig anlegt und da auch noch die korrekte xml config für thunderbird ablegt.

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • Code
    1. root@v22014042143317921:~# postfix -npostfix: invalid option -- 'n'postfix: fatal: usage: postfix [-c config_dir] [-Dv] commandroot@v22014042143317921:~# postconf -nalias_maps = $alias_databaseappend_dot_mydomain = nobiff = nobroken_sasl_auth_clients = yesconfig_directory = /etc/postfixdebugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5default_destination_concurrency_limit = 20inet_interfaces = alllocal_destination_concurrency_limit = 2local_transport = localmailbox_size_limit = 0message_size_limit = 52428800mydestination = $myhostname, $mydomain, localhost.$myhostname, localhost.$mydomain, localhostmydomain = v22014042143317921.yourvserver.netmyhostname = v22014042143317921.yourvserver.netmynetworks = 127.0.0.0/8smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)smtpd_client_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unknown_client_hostnamesmtpd_helo_required = yessmtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_unauth_pipelining, reject_non_fqdn_recipientsmtpd_sasl_auth_enable = yessmtpd_sasl_local_domain = $myhostnamesmtpd_sender_login_maps = mysql:/etc/postfix/mysql-virtual_sender_permissions.cfsmtpd_sender_restrictions = permit_mynetworks, reject_sender_login_mismatch, permit_sasl_authenticated, reject_unknown_helo_hostname, reject_unknown_recipient_domain, reject_unknown_sender_domainvirtual_alias_maps = mysql:/etc/postfix/mysql-virtual_alias_maps.cfvirtual_gid_maps = static:2000virtual_mailbox_base = /var/customers/mail/virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_mailbox_domains.cfvirtual_mailbox_limit = 0virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailbox_maps.cfvirtual_uid_maps = static:2000postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=


    Code
    1. root@v22014042143317921:~# doveconf -n# 2.1.7: /etc/dovecot/dovecot.conf# OS: Linux 3.2.0-4-amd64 x86_64 Debian 7.4mail_location = mbox:~/mail:INBOX=/var/mail/%unamespace inbox { inbox = yes location = mailbox Drafts { special_use = \Drafts } mailbox Junk { special_use = \Junk } mailbox Sent { special_use = \Sent } mailbox "Sent Messages" { special_use = \Sent } mailbox Trash { special_use = \Trash } prefix =}passdb { driver = pam}plugin { sieve = ~/.dovecot.sieve sieve_dir = ~/sieve}protocols = " imap pop3"ssl_cert = </etc/dovecot/dovecot.pemssl_key = </etc/dovecot/private/dovecot.pemuserdb { driver = passwd}root@v22014042143317921:~# service dovecot restart[ ok ] Restarting IMAP/POP3 mail server: dovecot.root@v22014042143317921:~# service dovecot restartdoveconf: Warning: NOTE: You can get a new clean config file with: dove dovecot-new.confdoveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:104: aprefix to all settings inside auth {} and remove the auth {} section codoveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:107: uswd {} has been replaced by userdb { driver=passwd }doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:110: p {} has been replaced by passdb { driver=pam }doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:113: ahas been replaced by service auth { user }[....] Restarting IMAP/POP3 mail server: dovecotdoveconf: Warning: NOTE get a new clean config file with: doveconf -n > dovecot-new.confdoveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:104: aprefix to all settings inside auth {} and remove the auth {} section codoveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:107: uswd {} has been replaced by userdb { driver=passwd }doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:110: p {} has been replaced by passdb { driver=pam }doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:113: ahas been replaced by service auth { user }. okYou have new mail in /var/mail/rootroot@v22014042143317921:~# dovecot -n# 2.1.7: /etc/dovecot/dovecot.confdoveconf: Warning: NOTE: You can get a new clean config file with: dove dovecot-new.confdoveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:104: aprefix to all settings inside auth {} and remove the auth {} section codoveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:107: uswd {} has been replaced by userdb { driver=passwd }doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:110: p {} has been replaced by passdb { driver=pam }doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:113: ahas been replaced by service auth { user }# OS: Linux 3.2.0-4-amd64 x86_64 Debian 7.4mail_location = maildir:%h/maildirnamespace inbox { inbox = yes location = mailbox Drafts { special_use = \Drafts } mailbox Junk { special_use = \Junk } mailbox Sent { special_use = \Sent } mailbox "Sent Messages" { special_use = \Sent } mailbox Trash { special_use = \Trash } prefix =}passdb { driver = pam}passdb { driver = pam}plugin { sieve = ~/.dovecot.sieve sieve_dir = ~/sieve}protocols = imap pop3service auth { user = root}ssl_cert = </etc/dovecot/dovecot.pemssl_key = </etc/dovecot/private/dovecot.pemuserdb { driver = passwd}userdb { driver = passwd}You have new mail in /var/mail/root




    die mail.err ist leer, aber die mail.err1 hat den Inhalt:

    Code
    1. Apr 12 19:54:39 v22014042143317921 postfix/postfix-script[31985]: error: unknown command: ''Apr 12 19:54:39 v22014042143317921 postfix/postfix-script[31986]: fatal: usage: postfix start (or stop, reload, abort, flush, check, status, set-permissions, upgrade-configuration)


    [Blocked Image: http://www.xn--80akhj1aedi7b.com/screen.jpg]

  • bitte keine doppelpost, verwende in die zukunft die edit-funktion.


    auf dem eingetragenen server bei thunderbird sind ledlich pop3-ports offen, mehr nicht.
    allerdings ist unter deiner yourserver.net adresse alles offen.
    ersetzt mal bitte die domain in thunderbird durch

    Code
    1. v22014042143317921.yourvserver.net

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • Sorry, war keine Absicht.


    Habe ich versucht, kommt das selbe wie wenn ich meine IP eingebe. Nach der Login-Daten-Überprüfung kommt eine Fehlermeldung ich solle die Daten überprüfen. Dabei sind diese richtig. Als Login gebe ich meine Mail-Adresse ein und als Passwort das, was ich im Froxlor eingegeben habe.

  • Sorry war keine Absicht.


    Kommt das selbe wie wenn ich meine IP eingebe. Ich bekomme die Fehlermeldung ich soll die Login-Daten überprüfen. Dabei gebe ich meine Mail-Adresse als Login und als Passwort das, was ich im Froxlor eingegeben habe.


    Pff... als ich den letzten Beitrag gepostet hatte, habe ich die Fehlermeldung bekommen, dass ich innerhalb der letzten 30 Sekunden bereits etwas gepostet hatte, jetzt ist es doppelt und ich sehe nicht wie ich das löschen kann. Ich werde hier noch bekloppt :)

  • dann poste mal die letzten 100 zeilen der /var/log/mail.log
    und versuch diese bitte mit zeilenumbruch zu kopieren, ansonsten hab' ich echt probleme das zu lesen. ;)


    btw. die fehlermeldung von thunderbird: "konnte keine einstellungen finden" und "konfigurationsfehler - benutzer oder passwort falsch?" sagen beide etwas völlig unterschiedliches aus. bitte darauf achten.

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • Thunderbird meldet "Konfiguration konnte nicht überprüft werden".
    Da habe ich auch zwei Dateien, eine mail.log und eine mail.log.1
    Ich kann jedoch nur ohne Zeilenumbruch öffnen... Habe diese einfach mal engehängt. Ich weiß nicht welches Programm diese "normal" anzeigen kann.

    dann poste mal die letzten 100 zeilen der /var/log/mail.log
    und versuch diese bitte mit zeilenumbruch zu kopieren, ansonsten hab' ich echt probleme das zu lesen. ;)


    btw. die fehlermeldung von thunderbird: "konnte keine einstellungen finden" und "konfigurationsfehler - benutzer oder passwort falsch?" sagen beide etwas völlig unterschiedliches aus. bitte darauf achten.