SFTP mit Hosting Expert L und WinSCP

  • Hallo, ich schaffe es leider nicht, WinSCP für Hosting Expert L so zu konfigurieren, daß ich eine Verbindung per SFTP herstellen kann. Ich habe im Forum oder Wiki leider nichts Passendes gefunden, was mit hierbei weiterhelfen könnte. FTP mit TLS/SSL Explicit encryption funktioniert hingegen. Versuche ich es per SFTP erhalte ich einen "Network error: Connection to XXX refused." Für XXX habe ich sowohl die IP als auch hostingxyz.xyz.netcup.net (was halt bei FTP-Accounts im WCP angezeigt wird) versucht. Als Usernamen habe ich sowohl den Systemnutzer als auch einen FTP-Account verwendet, funktioniert beides nicht. Kann mir hier jemand weiterhelfen?

  • Das funktioniert leider auch nicht. Ich habe nun unter Webhosting-Zugang ein Kennwort für den Systemnutzer angegeben und bei den Einstellungen für WinSCP unter Shell /bin/bash ausgewählt, aber ich bekomme weiterhin einen Network Error "Connection refused", das Kennwort ist korrekt. Oder kann man da keine Sonderzeichen verwenden?

    Host name ist die IP aus dem WCP und als File Protocol habe ich SFTP ausgewählt.

    Vielleicht wäre es mal eine Überlegung wert, dass netcup für den SFTP-Zugriff übers Webhosting eine Anleitung im Wiki erstellt.

  • So wie martin\ es beschrieben hat funktioniert es. Ich nutze einfach FileZilla für Mac und das funktioniert prima. Versuche es doch mal mit einem anderen Programm um zu sehen ob es damit auch nicht funktioniert. Nur zu sagen es funktioniert nicht wird Dich nicht weiterbringen.

  • Ich hab es eben per KiTTY versucht.
    Mit dem Schema Server-IP und Port 22, Benutzername=Systembenutzer kommt man jedenfalls auf den Server.

    Nur das Passwort bereitete mir ebenfalls Probleme: Es enthält auch Sonderzeichen, die normalerweise automatisch maskiert werden, wenn ich sie als "Auto-login username" und "Auto-login password" vor Start der Session in KiTTY in einem Profil anlege.


    Dann habe ich es zwei Mal mit der manuellen Passwort-Eingabe direkt auf der Konsole versucht:

    Eingabe des Passworts mit unmaskierten Sonderzeichen: gescheitert, anschließend die Sonderzeichen mit Backslash maskiert: ebenfalls gescheitert.


    Dann temporär das Passwort ohne Sonderzeichen neu angelegt; Das funktioniert … Ich bin drin.
    Bin aber nicht der Meinung wie Atavismus, dass bei der Software was falsch läuft - die funktioniert nämlich ohne Zicken oder Extramaskierung bei einem anderen Hosting (Passwörter ebenfalls mit Sonderzeichen).

  • Nach diesen Antworten musste ich das schon noch mal testen. Was soll ich sagen? Man klebt es mir ja schon auf den Avatar: Anfänger.
    Wobei sich der Anfänger auf das mir ungewohnte Verwaltungsbackend bezieht. Im ControlPanel Webhosting gibt ja es ja unter der domain xxxxx.netcup.net die Möglichkeit, die Zugangsdaten des Webhosting-Zugans und den FTP-Zugang -scheinbar- getrennt einzustellen. Offenbar habe ich mir dabei die Passwörter immer wieder selbst überschrieben und dann an der Stelle gepostet, wo es zufällig funktionert hat - genau da verwendete ich mal Passwörter ohne Sonderzeichen. Und schon kommt eine Theorie zu Stande...


    Also - alles zurück, ich behaupte das Gegenteil. Die Zugangsdaten für den SSH-Account sind demnach:
    Host: Server-Ip

    Port: 22

    Benutzer; Systembenutzer

    Passwort: Das, was unter Webhosting-Zugang angelegt wurde, und das funktioniert halt eben auch mit Sonderzeichen und sollte nicht mit einem FTP-Passwort für die Hauptdomain überschrieben werden,