Mailserver Dovecot mit Postfix installieren - Ich bekomme nichts hin

  • Hallo,


    ich sitze seit gestern Abend daran einen Mailserver auf meinem Server mit Froxlor zu installieren, jedoch bekomme ich es einfach nicht gebacken...


    Zuerst habe ich es mit Postfixadmin und Dovecot ohne Froxlor versucht, womit ich eine Testmail verschicken konnte, jedoch nicht mit Thunderbird verbinden, als ich das heute Morgen nochmal neu installiert habe, ging es natürlich nicht mehr...


    Jetzt habe ich es über Froxlor versucht, aber dadurch werde ich auch nicht schlau...
    [Blocked Image: https://i.gyazo.com/7491696c75526a3640b51d810a1f37d2.png] Dort habe ich dann alles abgearbeitet und das mysql Passwort vom froxlor Benutzer angegeben.


    Und über meinen Homepagekunden habe ich dann eine e-Mail erstellt: admin@meinedomain.de
    Diese kann ich aber nicht über Thunderbird aufrufen...


    MX-Einträge
    [Blocked Image: https://i.gyazo.com/ab5a4afcafcf6028d06b252a1c609bbc.png]




    Muss ich noch irgendwo anders etwas einstellen oder habe ich etwas vergessen?
    weil so funktioniert es ja nicht... :thumbdown:


    Greetz

  • Hallo,
    das kann ganz viel sein:
    Ist die Firewall für die Ports offen? Haben Postfix und Dovecot eine funktionierende Datenbankanbindung? Hat Thunderbird den richtigen Benutzernamen und das Passwort? Was sagt die /var/log/mail.log bei einem Verbindungsversuch?


    Auch wenn ich dir nicht den Spaß nehmen will, ein Mailserver produktiv zu betreiben ist viel Arbeit, fordert einiges an Erfahrung und auch mal die ein oder andere Nachtschicht von einem ab. Wenn es "nur funktionieren" muss ist vielleicht doch ein fertiger Service (Groupware etc.) besser.


    Um helfen zu können brauchen wir mehr Details: Was ist die Fehlermeldung? Bei welchem Schritt scheitert es? Gibt es in den Logdateien ein Verbindungsversuch?


    Viele Grüße!
    margau

  • mail.info / mial.err / mail.warn

    Code
    1. Apr 8 17:32:42 v22017034377546214 postfix/smtpd[15810]: connect from localhost[::1]Apr 8 17:32:42 v22017034377546214 dovecot: auth: Fatal: Unknown database driver 'mysql'Apr 8 17:32:42 v22017034377546214 dovecot: master: Error: service(auth): command startup failed, throttling for 60 secsApr 8 17:32:42 v22017034377546214 postfix/smtpd[15810]: fatal: no SASL authentication mechanismsApr 8 17:32:43 v22017034377546214 postfix/master[15518]: warning: process /usr/lib/postfix/smtpd pid 15810 exit status 1Apr 8 17:32:43 v22017034377546214 postfix/master[15518]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling



    Dies kommt, wenn ich über Postfixadmin eine e-Mail verschicken möchte.
    Postfixadmin sagt zwar, dass die Mail gesendet wurde, jedoch kommt diese nicht an.


    Bei Thunderbird wird mir das angezeigt:
    [Blocked Image: https://i.gyazo.com/9d564bc4881b44bdb107fd27a659f2ec.png]


    Das Passwort bzw. der Benutzername ist nicht falsch.



    Greetz

  • Hallo,
    steht doch da da:
    dovecot: auth: Fatal: Unknown database driver 'mysql'
    fatal: no SASL authentication mechanisms


    Offensichtlich stimmt was mit der Verbindung zur Datenbank nicht.


    Die von Froxlor angegebenen Datenbankscripte sind alle installiert?


    Viele Grüße!
    margau

  • Offensichtlich stimmt was mit der Verbindung zur Datenbank nicht.


    Die von Froxlor angegebenen Datenbankscripte sind alle installiert?

    Ich habe das eben bzw. vorhin neuinstalliert und nicht die Installation über Froxlor, mit apt-get install dovecot-mysql hat die Testmail dann doch geklappt.


    Ein sehr dummer Fehler von mir...
    Nun kann mich auch mit Thunderbird connecten :)


    Jetzt muss ich nur noch Roundcube installieren und fertig.



    Ich bedanke mich für deine Hilfe!


    Greetz