froxlor - letsencrypt installation question

  • Hello all,

    I'm using one of my websites with Trust safe Pro ssl certificate, but for the other small websites i would like to use let's encrypt.

    SSL already working and activated in my vserver. But when i tried to activate let's encrypt from froxlor , i cannot access ssl copy-paste area under the domain/ssl tab. I successfully created ssl certificates under root with cronjob (domain.conf , domain.csr, domain.csr.conf , domain.key)

    Also it is not showing ssl certificates under froxlor ssl tab.

    When i tried to reach my website i got ; SEC_ERROR_UNKNOWN_ISSUER error in mozilla.

    How can i fix it? Thanks!

    1. I used page for checking details
  • Hi,

    i think this happens, because the tutorial lets you generate a self signed cert... that has nothing to do with letsencrypt.

    As you may know, SSL Certificates must be created by an certified authoritiy. Thats the reason why you have to use letsencrypt.

    Im not sure how certbot works with froxlor - but i would recommend it to you (just give it a try, maybe it works with froxlor...). Thats a simple program, that you can install from the Debian Repos. It will help you to get new SSL certs from letsencrypt (and also to keep those certs up to date).

    Just a short tutorial from my usage with Debian Buster:

    - Install the packages certbot and python-certbot-apache

    - Make sure that your domain points at least with an A-Record to your server

    - Test whether the A-Record works (run "host <your domain>")

    - Run "certbot certonly --apache -d <your domain>"

    Then just read the output from certbot. It will tell you, whether there are problems or nor and where the certs are saved. It's not possible to move the certs, because the auto update will not work in this case. (auto update is done by a pre-installed cronjob or via executing "certbot renew --apache" by yourself)

    I hope that this will help you.

    Otherwise, feel free to ask, if something doesnt work.