System frisch aufgesetzt. VHost Settings (Docroot) in Froxlor greifen nicht

  • Leider wurde ich weder im WIKI noch im Forum fündig, daher probiere ich hier mein Glück mit einem neuen Thema.

    System wurde frisch aufgesetzt... VServer, Debian 8.1, Froxlor...

    Benutzer wurde angelegt, Domain wurde angelegt, Externes DNS zeigt auf den Server...

    Wenn die Domain aufgerufen wird lande ich unter: var/WWW/ also dem Apache Standard Root.

    In Froxlor ist jedoch var/customer/webs/Benutzer/Domain eingestellt. Doch dieser Einstellung greift leider nicht.

    Jegliche Versuche den Pfad in den Settings anzupassen endeten damit, das Froxlor und Webseiten nicht mehr erreichbar waren.


    Über eure Antwort würde ich mich sehr freuen!

    Grüße

  • OK, ich weis nicht wo oft ich gestern und heute das System neu aufsetzen hab lassen, da nach Einstellungsexperimenten Froxlor nicht mehr erreichbar war. Nagut, hätte besser ein Snapshoot benutzen sollen....


    Na jedenfalls habe ich das System erneut aufgesetzt. Alle Einstellungen wie beschrieben erneut gesetzt. Cronjobs Settings kontrolliert etc.

    Doch im Punkto Cronjob sah alles ok aus. Alle 5 Minuten die Webkonfig aktualisieren etc. ansonsten habe ich alles auf Default gelassen.


    Durch Zufall habe ich nochmal den Aufruf der Domain gecheckt und nun lande ich im richtigen Verzeichnis!!!

    Doch was ist nun anders??? Ich habe nichts an der Routine geändert. Es kann passieren, dass ich bei Bedarf das System erneut aufsetzen muss. Um Probleme zu vermeiden müsste ich unbedingt wissen was nun anders ist oder auf was ich bei besagtem Bug achten sollte.


    Bin bisschen verunsichert :o

    Hast Du mehr Infos hinsichtlich des Problems?

    Danke nochmals!

  • Ich weiß leider nicht, was du wie gemacht hast. Manchmal macht man Dinge ganz automatisch ohne, dass man es selbst merkt.


    Mach am besten ein Snapshot und freu dich, dass es funktioniert. Ich hatte mit Froxlor immer einige Probleme und bin irgendwann zu der Konkurrenz gewechselt. Das ist aber schon Jahre her und ich bin mir nicht sicher, ob sich bei Froxlor mittlerweile was geändert hat.

  • Ich probiere gerade das Angebot von netcup aus, da ich nach einer Alternative zu meiner bisherigen Variante suche.

    netcup bietet unter Stretch Froxlor nicht an und ich wollte größeren Aufwand vermeiden Froxler selbst zu installieren.

    Viele Anbieter pflegen Ihre builds auch hinsichtlich eventueller Vorkonfigurationen. So jedenfalls bei vielen Plesk Resellern.

    Ausserdem weis ich noch nicht ob Froxlor die richtige Wahl ist. Doch Plesk möchte ich eigentlich nicht mehr verwenden.

    Gibt es weitere gute Webhosting Management Systeme?

  • Hehe guter Vorschlag! Der Aufbau der Seite konnte durch Verbindungsprobleme nicht durchgeführt werden. Insofern hatte ich das Problem ausgeschlossen. Aber auch nicht überprüft. In diesem Fall sollte er nichts in den Cache schreiben. Anders wäre es eventuell, wenn sich um eine custom Fehlerseite gehandelt hätte. Ich hab vorhin gesehen, dass es an einer Weiterleitung lag. Manche Browser setzen automatisch ein www. vor die Domain, wenn man nur den Domainnamen schreibt. Es gab ein Problem beim redirect... **rotwerd

    Ich konnte es nicht sehen weil mein Browser - MS sei dank - mich verarsc.. hat.

    Problem ist gelöst und noch wichtiger, ich weis woran es lag ^^

  • Es gibt übrigens etliche Verwaltungssysteme. Es kommt halt drauf an, was du gerne erreichen willst.


    Ich habe mir eigentlich vorgenommen ISPConfig auszuprobieren. Derzeit nutze ich i-MSCP.

    Schaue es dir ruhig mal an. Warte aber noch mit dem kompletten Umzug. Es wird gerade die Unterstützung für rspamd umgesetzt. Ich selber setze das ISPConfig seit ein paar Jahren ein. Ich hatte bis auf einen kleinen Fehler keine Probleme (das war aber auch ein mit selbstverschuldeter). Man sollte aber auch ein Testsystem (vielleicht zuhause auf einer VM) zum spielen haben um alles auszuprobieren.

  • Schaue es dir ruhig mal an. Warte aber noch mit dem kompletten Umzug. Es wird gerade die Unterstützung für rspamd umgesetzt. Ich selber setze das ISPConfig seit ein paar Jahren ein. Ich hatte bis auf einen kleinen Fehler keine Probleme (das war aber auch ein mit selbstverschuldeter). Man sollte aber auch ein Testsystem (vielleicht zuhause auf einer VM) zum spielen haben um alles auszuprobieren.

    Ist bekannt, wann rspamd vollständig implementiert ist?


    Hast du Erfahrung mit dem Umzug von i-MSCP zu ISPConfig? Insbesondere der Mailumzug würde mich interessieren.

  • Ist bekannt, wann rspamd vollständig implementiert ist?


    Hast du Erfahrung mit dem Umzug von i-MSCP zu ISPConfig? Insbesondere der Mailumzug würde mich interessieren.

    Wenn ich das im Forum richtig verfolg habe, wird das mit der nächsten Version kommen. Du kannst natürlich jetzt schon rspamd einsetzen, aber dann fehlt die Integration.

    Zum Umzug kann ich nichts sagen. Ich habe i-MSCP nie im Einsatz gehabt. Wenn es dazu geht, die Mail Postfächer zu sichern, kannst du dies mittels imapsync oder ähnlichem realisieren. Wenn es nur ein paar Accounts sind, kann man das ggf. auch manuell mit dem Mailclient oder imapsize unter Windows erledigen. Wenn die Ablagestruktur gleich ist, reicht sogar ein rsync.