FTP-Server auf Froxlor einrichten

  • Ich bin nach der Anleitung von Froxlor vorgegangen (Debian Wheezy->Ftp-Server->ProFTPd) certifikat wurde erstellt, aber login mit Filezilla Funktioniert leider nicht. Habe schon paar mal mit den >neuen Kunden< >neue Domain< anlegen, rumexperimentiert. Muss ich irgendwas noch konfigurieren?o,O

    Ich las in Foren einiges über die auth.log etc. aber diese gibt es in meinem proftpd ordner nicht.


    Sry. Für fehlende Infos, weis gerade nicht wo ich mich weiter lang hangeln könnte. Mein Kumpel der mir sonst immer half, ist derzeit im Urlaub und den will ich nur ungern mit so ein rumgerätsel belästigen.

  • Die auth.log liegt auch direkt in /var/log und zeichnet u.a. ungültige LogIn Versuche auf, allerdings muss dazu überhaupt ein LogIn durchgekommen sein, was bei einer fehlerhaften Verbindung nicht der Fall ist.

    Filezilla zeigt mir den Fehler "GnuTLS error -110: The TLS connection was non-properly terminated".

    Brauche ich eventuell noch ein Key für den Client? Warum kommt dieser Fehler? Vor der Verbindung gebe ich vom Client aus doch an, das ich dem Zertifikat vertraue... o.O

  • Beschreib doch mal was Du überhaupt alles eingerichtet hast und wie die Umgebung konfiguriert ist, d.h. iptables .... und wie Du das Zertifikat eingerichtet hast.

    Ich habe Froxlor und Debian als Image über das Servercontroll-zentrum von Netcup installiert. Iptables lassen port 22 und 21 rein und raus. Habe dies auch nochmal mit einem Online-tool getestet.

    Ich hab leider gerade keinen Zugriff auf die Froxlor Administration, um die Commandos die ich verwendet habe zu kopieren. Ich hoffe es ist klar, welche einen dort angeboten werden und das keine Bugs an dieser Stelle existieren. Falls da aber doch irgendwas falsch gemacht werden kann, kann ich die Commandos gern noch gegen 17:30uhr nachreichen.

    Ich bin in der Froxlor Administration also auf "System->Konfiguration"-glaube ich heißt das. Wo man dann die 3 Kategorien auswählen muss. Diese waren bei mir "Debian Wheezy", "Ftp-Server", "ProFTPd". Danach gibt Froxlor einen die Anleitung, wo auch das Commando für den Key vorgefertigt ist. Habe dann die ganzen Codes durch putty geschleudert. Kamen keine Fehler.

    Kunde und Domain angelegt.

    In Filezille Login mit serverip, und den Kundendaten aus Froxlor probiert.->Fehler


    Ich habe auch davon gelesen das nicht DNS und ProFTPd installiert sein dürfte. Das ist auch nicht der Fall.

  • sind die PassivePorts in der proftpd.conf enabled ? Und im Firewall auch frei ?

    Am Thema vorbei noch die ketzerische Frage, warum du eigentlich noch wheezy einsetzt - da läuft der LTS-Support nächstes Jahr eh aus ...

    Gruss

  • was mir als erstes auffällt. es wird eine total andere IP angezeigt, als die die ich derzeit habe


    Code
    1. Jul 25 18:11:43 serveradresse sshd[3586]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=>nicht meine ip< user=root
    2. Jul 25 18:11:45 serveradresse sshd[3586]: Failed password for root from >nicht meine ip< port 43915 ssh2
    3. Jul 25 18:11:47 serveradresse sshd[3586]: Failed password for root from >nicht meine ip< port 43915 ssh2
    4. Jul 25 18:11:49 serveradresse sshd[3586]: Failed password for root from >nicht meine ip< port 43915 ssh2
    5. Jul 25 18:11:49 serveradresse sshd[3586]: Received disconnect from >nicht meine ip<: 11: [preauth]
    6. Jul 25 18:11:49 serveradresse sshd[3586]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=>nicht meine ip< user=root
    7. Jul 25 18:11:56 serveradresse sudo: root : TTY=pts/0 ; PWD=/var/log ; USER=root ; COMMAND=/usr/bin/nano auth.log
    8. Jul 25 18:11:56 serveradresse sudo: pam_unix(sudo:session): session opened for user root by root(uid=0)


    warum geht der über Port 43915?




    sind die PassivePorts in der proftpd.conf enabled ? Und im Firewall auch frei ?

    Am Thema vorbei noch die ketzerische Frage, warum du eigentlich noch wheezy einsetzt - da läuft der LTS-Support nächstes Jahr eh aus ...

    Gruss

    Netcup bietet das so im Paket an. Als ich damals versuchte Froxlor selber zu installieren. Funzte es nicht.


    Hab jetzt den Port 43915 in Firewall Freigegeben. Diesen Port kann ich NICHT in "PassivePort" in der proftpd.conf schreiben, da sonst proftpd nicht mehr restarten will.

  • Auch wenn netcup das Image so anbietet muss es natürlich noch konfiguriert werden. Entweder es gibt ein extra proftpd Log oder aber der Login kommt erst gar nicht an, was ich ja eher vermute. Die Passiv Ports müssen natürlich konfiguriert und in den iptables freigegeben werden.


    Das obige Log zeigt nur die versuchten SSH Logins. Überprüfe mal das was thys gesagt hat.

  • checke ich das mit sysmctl status proftpd.service?Dann ja


    Code
    1. systemctl status proftpd.service
    2. ● proftpd.service - LSB: Starts ProFTPD daemon
    3. Loaded: loaded (/etc/init.d/proftpd)
    4. Active: active (running) since Tue 2017-07-25 18:30:59 CEST; 1h 50min ago
    5. Process: 3891 ExecStop=/etc/init.d/proftpd stop (code=exited, status=0/SUCCESS )
    6. Process: 4060 ExecStart=/etc/init.d/proftpd start (code=exited, status=0/SUCCE SS)
    7. CGroup: /system.slice/proftpd.service
    8. └─4067 proftpd: (accepting connections)

    außerdem steht in der daemon.log kein fail.


    in der auth.log steht nichts von ftp. Nur Cron und sshd

    im ordner proftpd gibt es keine log dateien.


    Im ordner var/log habe ich folgende dateien

    alternatives.log aptitude btmp dmesg fail2ban.log fsck mail.info messages mysql.log proftpd syslog.2.gz wtmp

    apache2 auth.log daemon.log dpkg.log faillog kern.log mail.log mysql mysql.log.1.gz syslog unattended-upgrades

    apt boot.log debug exim4 fontconfig.log lastlog mail.warn mysql.err mysql.log.2.gz syslog.1 user.log


    die "proftpd" ist leer.