Froxlor + SSL = /

  • Hey,


    Über http funktioniert bei mir alles.


    Ich habe die IP X:443 geaddet (in froxlor) und dann bei der Domain X.de diese IP ausgewählt. Als vHosteinstellungen (gesetzt durch die IP) wird SSLEngine auf on gestellt und die beiden Dateien (key,cert) angegeben. Die IP mit dem Port 80 ist bei dieser Domain abgewählt!


    Rufe ich die Domain ohne https auf, lande ich im www Verzeichnis. (Domain ist nur auf die IP geschaltet) rufe ich die Seite mit Port 443 auf, lande ich im Userverzeichnis, was soweit gewollt ist. Der Port bleibt in der URL-Zeile. Über xd.de kommt ein Error (nicht erreichbar usw).


    Klicke ich auf ein Element, so wird mir die Systemsubdomain angezeigt. Wie stelle ich die Domain so ein, dass diese fest verbunden ist und es nicht nur eine Weiterleitung ist? Und vorallem würde dann ssl funktionieren?



    Simon


    Mit dem SSL ist gelöst.

  • Ups..


    Hatte einen Listen Haken in Froxlor drin. Ich weiß nicht wo zu der gut ist aber mir hat er nur Probleme beschert.


    Mit dem SSL trage ich alles bei den Domains (über Port 80) ein.
    Redirect https://X
    </VirtualHost X:443>
    X
    </VirtualHost>


    So "trickse" ich Froxlor aus. Funktioniert auch prima so.

  • Leider funktioniert froxlor mit https bei mir derzeit nicht. Ich habe beim 'Kunden' die ssl Zertifikate hinterlegt und auch die IP / Port in der admin Oberfläche hinterlegt. Leider funktioniert eine Verbindung über https nicht. Der Port wird anscheinend nicht geöffnet. Über http kann ich auch die Domain zugreifen.


    Kannst du deinen Trick etwas genauer beschreiben? Was genau bewirkt der redirect?



    Viele Grüße


    Dominic

  • Nunja ich habe etwas getrickst...


    Zuerst unter IPs die SSL-IP komplett entfernen.
    Dann bei der Domain domain1.tld in die vhosts gehen:


    Redirect / https://domain1.tld #Weiterleitung von http zu https
    </VirtualHost>
    <VirtualHost IP:443> #Neuer Vhost Eintrag
    ServerName domain1.tld
    ServerAlias *.domain1.tld
    [...]
    SSLEngine on
    SSLCertificateFile <PfadZumZertfikat>
    SSLCertificateKeyFile <PfadZumKey>


    Sprich wir erstellen einfach einen vhost mit Froxlor. Dasselbe könnte man auch manuell im Apache Pfad machen. Nur finde ich die Froxlor Methode einfacher, da ich dazu nur meinen Browser brauche und auch mal was am Tablet ändern kann.

  • Derweil kommt ein anderer Fehler, das Zertifikat wird wohl nicht korrekt übermittelt. Das Zertifikat habe ich beim Kunden in die Textboxen eingefügt.


    Welche Einstellung ist derzeit Fehlerhaft?

  • Du machst das ganze über die Froxlor eigenen Einstellungen. Ich hatte mir das ganze, da ich am Anfang in der Froxlor-IP gefailt habe, über den vhost Umweg gelöst. Ich weiß nicht gemau wie das ganze dann bei dir aussieht. (Und teste alles am PC, Android heult manchmal unnötig rum(bei openssl, sollte dieses verwendet werden))


    Ansonsten erstmal schauen ob die Dateien existieren, ggf. neu anfordern. Und die Apache (bzw nginx) Logs lesen.




    Simon

  • ich hab jetzt mal versucht den trick mit dem zweiten vhost anzuwenden.. leider ohne erfolg...aktuell ist der vserver so nicht zu benutzen, ich bekomme weder den snapshot zurückgespielt, noch funktioniert der apache..


    Kann gerne noch mal alles neu installieren, das sollte das kleinste problem sein. Wichtig ist nur, dass alle domains via SSL funktionieren, da ich gerne etwas sicherheit im berieb hätte

  • </VirtualHost>
    <VirtualHost 46.12.23.56:443>
    ServerName website.de
    ServerAlias *.website.de
    SSLEngine on
    ServerAdmin admin@website.de
    php_admin_value open_basedir "/var/customers/webs/user:/tmp"
    DocumentRoot "/var/customers/webs/user/"
    SSLCertificateKeyFile /var/customers/certs/cert.key
    SSLCertificateFile /var/customers/certs/cert.crt
    SSLCACertificateFile /var/customers/certs/cert.ca-bundle


    danke 03simon10
    so funktioniert es...

  • Vielen Dank für die Anmerkung, ich löse das über die .htaccess Datei.


    Übrigens, wer Dienste installieren möchte wie wordpress, muss noch den directory-Tag hinzufügen...



    <Directory /var/customers/webs/user>
    Options -Indexes +FollowSymLinks -Includes -MultiViews
    AllowOverride FileInfo
    Order allow,deny
    allow from all
    </Directory>


    Leider funktioniert nach der aktion der Mailserver nicht mehr, hat jemand eine idee, wie ich den Postfix wieder hinbekomme?