Standard Froxlor Login Pfad ändern

  • Hallo,


    ich bin derzeit auf der Suche nach einer Lösung zu folgendem Problem:


    Wenn man sich bei Froxlor einloggen möchte navigiert man standartgemäß auf http://IPODERHOSTNAME.XY/froxlor.


    Ich möchte hingegen aber, dass dieses /froxlor in z.b. /login umbenannt werden kann oder noch besser: http(s)://login.meinedomain.xy


    Gibt es eine Möglichkeit dies zu realisieren.


    Mit freundlichen Grüßen
    ITX

  • Du kannst den vHost verändern, inwiefern das Froxlor selbst stören könnte kann ich dir nicht sagen.


    Die vHosts befinden sich im Normalfall hier: /etc/apache2/sites-available/



    lg.
    Alex

    [size=10]

    "This is Linux land. In silent nights you can hear the Windows machines rebooting."


  • Danke für deine Antwort..


    Jedoch wirkt sich das Problem so aus, dass egal welche Domain ich drauf leite immer /froxlor nach der Domain stehen muss..


    Habe schon die Subdomain login.domain.xy auf /var/www/froxlor/ gelegt. Es funktioniert auch jedoch bekomme ich den Text angezeigt:


    "Eine neuere Version von Froxlor wurde installiert, aber noch nicht eingerichtet.
    Nur der Administrator kann sich anmelden und die Aktualisierung abschließen."


    Was ja nicht der Fall ist, es zeigt ja lediglich nur eine andere Domain auf diesen Pfad. Das verwirrt mich etwas.


    Für mich heißt es, dass irgendwo festgelegt sein muss, dass NUR eine Domain (ich denke mal der Hostname und die IP) drauf zugreifen dürfen.


    Eine Pseudoanmeldung ist auch möglich, bzw. eine Session ID wird erstellt jedoch passiert dann nichts weiter.

  • Muss es unbeding Froxlor sein? Könnte dir sonst Zpanel empfehlen, Installer für CentOS und Ubuntu. Meiner Meinung nach sehr viel besser als die Konkurenz. Und login.domain.xy ist dort Standart :)

  • Warum nehm ich nicht ispConfig, Plesk oder Cpanel?


    Ich denke es liegt eher daran, das ich gerne mit Froxlor arbeiten möchte, da ich dort sehr viel und sehr einfach selbst machen kann.


    Davor hatte ich Jahrelang Erfahrung mit ispConfig, doch wegen der Kundenunfreundlichkeit, da es viel zu komplex für den einfachen Kunden ist, nutzte ich nun Froxlor.


    Deswegen möchte ich auch eine Lösung für das Problem erarbeiten mit euch und nicht einfach auf ein anderes System umsiedeln.

  • Soweit ich das in Erinnerung habe ist es möglich, das /froxlor wegzulassen. Dafür musst Du unter Einstellungen > Systemeinstellungen den Hacken "Froxlor direkt über den Hostnamen erreichbar machen" aktivieren. Ich meine so habe ich das damals gemacht, bin nicht ganz sicher.

  • Ich weiss gar nicht wo das große Problem ist.. wenn ich in /var/www den froxlor Ordner einfach per

    Code
    1. mv froxlor login


    umbenenne in login, erreiche ich den über http://domain.tld/login


    Oder verstehe ich da was nicht?


    EDIT: ah, okay, das resultiert in einigen Emails dass cron nicht laufen kann...

  • Lege Dir einen manuell erstellten vHost an und setze bei dem das DocumentRoot auf den Froxlor Ordner. Es hindert Dich ja niemand daran einfach eine neue vHost File in /etc/apache2/sites-available zu erstellen und diese dann in sites-enabled zu linken.


    Und wie das ungefähr aussehen muss, kannst Du dir ja an der aktuellen Konfiguration abschauen.

  • Hey danke und genau das hat auch funktioniert :)


    Die vHost sieht nun so aus:


    Code
    1. NameVirtualHost IP:80
    2. <VirtualHost IP:80>
    3. DocumentRoot "/var/www/froxlor/"
    4. ServerName login.domain.xy
    5. </VirtualHost>