Lieber Besucher, herzlich willkommen bei: netcup.de Kundenforum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

[netcup] Alex

Support Mitarbeiter

  • »[netcup] Alex« wurde gesperrt
  • »[netcup] Alex« ist der Autor dieses Themas

Wohnort: Karlsruhe

Beruf: Administration & Service

  • Nachricht senden

1

Donnerstag, 25. März 2010, 15:02

Installation von Froxlor unter Debian Systemen per APT

  1. Aktualisieren des Systems mit folgenden Befehlen

    Quellcode

    1
    
    apt-get update && apt-get upgrade

  2. Einfügen folgender Zeilen in der /etc/apt/sources.list

    Quellcode

    1
    2
    
    deb http://debian.froxlor.org lenny main
    deb-src http://debian.froxlor.org lenny main

  3. Importieren des GPG Keys für APT

    Quellcode

    1
    2
    
    gpg --keyserver gpg-keyserver.de --recv-keys 4F9E9BBC
    gpg --export 4F9E9BBC|apt-key add -

  4. Installation von Froxlor

    Quellcode

    1
    2
    
    apt-get update
    apt-get install froxlor

  5. Abschliessend sollte der Apache einmal neugestartet werden

    Quellcode

    1
    
    /etc/init.d/apache2 restart



Nach der Installation aller benötigten Pakete und Froxlor selbst http://ip-adresse/froxlor aufrufen und benötigte Informationen angeben.

Abschliessend nach dem Login die Dienstkonfigurationen unter Server -> Konfiguration durchführen.

2

Donnerstag, 25. März 2010, 15:27

Klingt sehr gut ;)

Gibt es auch ein "einfaches" Update von SysCP auf Froxlor?
Denke mal, das nur die config Dateien verschoben werden müssen?
Hat jemand Erfahrung damit?
Rechtschreibfehler sind unter Creative Commons BY-NC-ND 3.0 DE lizenziert.

3

Donnerstag, 25. März 2010, 15:35

Klaro, mit der Suche hier zu finden:
http://forum.netcup.de/showthread.php?t=1567

[netcup] Alex

Support Mitarbeiter

  • »[netcup] Alex« wurde gesperrt
  • »[netcup] Alex« ist der Autor dieses Themas

Wohnort: Karlsruhe

Beruf: Administration & Service

  • Nachricht senden

4

Donnerstag, 25. März 2010, 15:36

Zitat von »cw1;15770«

Gibt es auch ein "einfaches" Update von SysCP auf Froxlor?


Wird gerade verfasst da die hier verlinkte nicht ganz vollständig ist.

5

Freitag, 26. März 2010, 18:20

Hallo,

ich erhalte bei Schritt 3 bei

Quellcode

1
gpg --export 4F9E9BBC|apt-key add
folgenden Fehler:

Zitat

gpg: '' kann nicht geöffnet werden: Datei oder Verzeichnis nicht gefunden
Versuche ich nun gpg zu installieren kommt:

Zitat

apt-get install gpg
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
E: Konnte Paket gpg nicht finden
Mit apt-cache search gpg erhalte ich folgende Paket, die ähnlich klingen:

Zitat

pgpgpg - Wrapper zur Verwendung von GnuPG in Programmen, die für PGP entwickelt wurden
gpgsm - GNU privacy guard - S/MIME version
gpgkeys - GPG Keymanagement Frontend
gpgv - GNU Datenschutzwächter - Signatur-Überprüfungs-Werkzeug
In der sources.list stehen folgende Paketserver:

Zitat

deb http://ftp2.de.debian.org/debian/ lenny main
deb-src http://ftp2.de.debian.org/debian/ lenny main

deb http://security.debian.org lenny/updates main

deb http://debian.froxlor.org lenny main
deb-src http://debian.froxlor.org lenny main
Wie bekomme ich den Fehler bei Schritt 3 nun gelösen?

Danke

Gruß
Tobias
vServer Saturn KVM* & Xmas vServer | Favorit: Debian 64Bit mit Froxlor und Apache2, Postfix, Dovecot, MySQL, Bouncer usw. ;)

Wohnort: Wien (Österreich)

  • Nachricht senden

6

Freitag, 26. März 2010, 19:04

Zitat von »TobiasH;15866«

Wie bekomme ich den Fehler bei Schritt 3 nun gelösen?

Das sollte das richtige Paket sein:

Zitat

gpgv - GNU privacy guard - signature verification tool



MfG Christian

7

Freitag, 26. März 2010, 19:13

Anscheinend nicht, denn es kommt:

gpgv ist schon die neueste Version.
vServer Saturn KVM* & Xmas vServer | Favorit: Debian 64Bit mit Froxlor und Apache2, Postfix, Dovecot, MySQL, Bouncer usw. ;)

8

Freitag, 26. März 2010, 19:34

Hallo,
Zu deinem Problem das hatte ich auch ... Die Befehle im Froxlor Forum untscheiden sich nur in einer Kleinigkeit aber mit dem hats funktioniert:

Quellcode

1
gpg --export 4F9E9BBC|apt-key add -

9

Freitag, 26. März 2010, 19:40

Wunderbar, das funktioniert. :)

Danke
vServer Saturn KVM* & Xmas vServer | Favorit: Debian 64Bit mit Froxlor und Apache2, Postfix, Dovecot, MySQL, Bouncer usw. ;)

10

Sonntag, 11. April 2010, 13:46

So, habe Froxlor mal eben schnell laut dieser Anleitung auf meinem alten Vserver installiert. Frische Debian Lenny 64 bit Installation, danach per apt-get Froxlor installiert.
Versuche ich jetzt aber http://meine-ip/froxlor aufzurufen, versucht er den php Quellcode zu öffnen.
php5 wurde aber mitinstalliert, und php5.load/conf sind im mods-enabled Verzeichnis vorhanden.
Hat jemand einen Tipp für mich ? :)

11

Sonntag, 11. April 2010, 13:54

Wichtig:

Nach der Insterlation von Froxlor (per APT) einmal Apache per Hand neustarten und den Browser Cache löschen dann gehts :)

12

Sonntag, 11. April 2010, 13:56

Zitat von »Seb;16648«

Wichtig:

Nach der Insterlation von Froxlor (per APT) einmal Apache per Hand neustarten und den Browser Cache löschen dann gehts :)


Stimmt, war ein Problem mit dem Browser Cache. Vielen Dank :)

Wohnort: Wien (Österreich)

  • Nachricht senden

13

Sonntag, 11. April 2010, 14:55

Überprüfe einmal ob deine Modul Config (php5.conf) so eine oder ähnliche Zeile enthält:

Quellcode

1
AddType application/x-httpd-php .php

Ist das PHP Modul auch sicher aktiviert? Zur Sicherheit noch folgendes ausführen:

Quellcode

1
a2enmod php5

Danach einmal den Apache neustarten. Wenn es dann noch immer nicht funktioniert schau einmal ins Error Log vom Webserver/vHost.

EDIT: Ups, ich habe die zweite Seite übersehen :D


MfG Christian

14

Freitag, 30. April 2010, 18:03

Ich hab ein kleines Problem.

Bis zu Schritt frei läuft alles gut, nur wenn ich per apt-get froxlor installieren soll, meldet es mir, das es das Package nicht finden konnte..

Die sources.list ist bearbeitet..

15

Freitag, 30. April 2010, 18:06

Hallo,
Gib mal bitte die ausgabe von folgendem befahl an:
"cat /etc/apt/sources.list/"

(Gibt den Inhalt der Sources - List aus dann sehen wir ja ob es daran liegt ;))

16

Freitag, 30. April 2010, 18:07

Folgendes steht in der sources.list

Zitat


deb http://ftp2.de.debian.org/debian/ lenny main
deb-src http://ftp2.de.debian.org/debian/ lenny main

deb http://security.debian.org lenny/updates main
deb http://debian.froxlor.org lenny main
deb-src http://debian.froxlor.org lenny main


Also genau das, was laut Anleitung stehen sollte.

kostaki

Kunde

Wohnort: Berlin

Beruf: Systemadministrator & Programmierer

  • Nachricht senden

17

Freitag, 30. April 2010, 18:26

haste ein apt-get update gemacht?

18

Freitag, 30. April 2010, 18:27

Ja, zu beginn der Installation (Wird ja als erster gemacht mit der Anleitung)

19

Freitag, 30. April 2010, 18:29

nachdem du die sourcelist erweiter hast?

20

Freitag, 30. April 2010, 18:38

Nein, bevor ich sie erweitert habe.