Froxlor / Apache: Starting web server: apache2(98)Address already in use: AH00072: make_sock: could not bind to address

  • Moin zusammen,


    ich hätte da mal wieder ein Problem.

    Ich hab heute Froxlor & Certbot konfiguriert. Das ging soweit auch alles gut, mal abgesehen davon das nach einiger Zeit der Apache weg war.


    Fehlermeldung besagt:


    Code
    1. Starting web server: apache2(98)Address already in use: AH00072: make_sock: could not bind to address meine.ip:443
    2. no listening sockets available, shutting down
    3. AH00015: Unable to open logs
    4. Action 'start' failed.
    5. The Apache error log may have more information.
    6. .
    7. Stopping web server: apache2.
    8. Started LSB: Apache2 web server.
    9. Unit apache2.service cannot be reloaded because it is inactive.


    netstat -ltnp | grep :443
    liefert keinerlei Angaben.


    Ich habe mittlerweile, aus purer Verzweiflung, den kompletten SiteEnabled-Ordner und die ports.conf aus dem Apache-Ordner verschoben.

    Die Fehlermeldung bleibt aber bestehen.

    Gemacht hab ich das um etwaige doppelte Portangaben auszuschliessen die ich mittels "grep 443 /etc/apache2/sites-enabled/*" gesehen hatte.


    Nun weiß ich aber nicht mehr weiter wo ich noch gucken bzw. was ich noch machen könnte.


    Hat jemand eine Idee?

  • Hallo Nukular,


    das Problem kommt mir bekannt vor, denn das gleiche hatte auch ich schon bei meinem Server. Grund dafür ist eine Einstellung in Froxlor, bei der man entscheiden kann, dass für eine Domain ein eigener "Listen" Eintrag in der Konfiguration gemacht werden soll. Dieser Eintrag wird dann beißt sich dann jedoch mit den Einträgen in der ports.conf von Apache.

    Damit du wieder auf dein Froxlor zugreifen kannst, empfiehlt es sich, die "Listen 443" in der Apache2 ports.conf zu kommentieren (#). Danach solltest du Apache wie gewohnt starten können.


    Beste Grüße


    Bob Achten

  • Danke für deine schnelle Antwort.


    Ich hatte gehofft das hab ich schon gemacht, in dem ich die ports.conf und den gesamten sites-enabled Ordner aus dem Apache-Verzeichnis verschoben hab.


    Leider bleibt der Fehler dennoch bestehen.

  • Ok der Server lässt sich jetzt wieder starten ...

    Ich hab die Ordner sowie die Ports.conf wieder zurück kopiert (letztere mit auskommentierten Ports) und jetzt startet er.
    Dafür kommt jetzt beim Aufruf der Webseite:


    Fehler: Gesicherte Verbindung fehlgeschlagen


    Ein Fehler ist während einer Verbindung mit ip-adresse aufgetreten. SSL hat einen Eintrag erhalten, der die maximal erlaubte Länge überschritten hat. Fehlercode: SSL_ERROR_RX_RECORD_TOO_LONG

  • Hallo Nukular,


    der Fehler kann mehrere Ursachen haben. Zum einen tritt er gerne auf, wenn man z.B. über das HTTP Protokoll versucht die Webseite auf Port 443 auf zu rufen (z.B. http://server:443/) zum anderen kann er ebenfalls bedeuten, dass das SSL Zertifikat falsch im apache eingebunden ist.

    Eine Mögliche Lösung findest du z.B. unter https://knowledge.rapidssl.com…ctp=LIST&viewlocale=en_US


    Beste Grüße


    Bob Achten


  • Uff ... so Fehler gefunden ... bzw. die Fehler gefunden ...

    Das Anleitungen auch immer Fehler haben müssen bzw. nicht vollständig sind ... schlimm ;)


    Ursprüngliche Anleitung: https://nichteinschalten.de/fr…it-letsencrypt-verbinden/


    1. Der Server selbst braucht noch ein selbst ausgestelltes Zertifikat siehe: https://forum.froxlor.org/inde…es-not-exist-or-is-empty/

    2. Im Froxlor unter "IPs und Ports" bei den eingetragenen IPs das Listen deaktivieren, vorrausgesetzt man hat die Ports in der ports.conf eingetragen.

    3. Ebenfalls unter "IPs und Ports" müssen "Pfad zum Zertifikat" und "Pfad zum SSL-Private-Key" eingetragen werden. In meinem Fall: /etc/ssl/froxlor-custom/domain.de.crt & /etc/ssl/froxlor-custom/domain.de.key

  • Nachtrag ...


    Nach einiger Zeit war meine via HTTPS wieder nicht erreichbar ... wie sich herausstellte und ich auch schon im Vorfeld vermutete, war Froxlor "schuld".

    Das Entfernen der Einstellung "Erstelle vHost-Container" half und die Webseite ist nun auch dauerhaft via HTTPS erreichbar.