Eigene Nameserver für .com-Domain

  • Hallo zusammen,


    ich habe auf drei vServern mit CoreDNS jeweils einen DNS-Server aufgesetzt, welche nach dem Wechsel DNS für alle meine Domains übernehmen sollen. Dies funktioniert mit meinen .de-Domains bisher genau so, wie ich es erwarten würde.


    Heute habe im CCP von Netcup die DNS-Einstellungen einer .com-Domain auf die eigenen Nameserver umgestellt. Diese eigenen Nameserver haben Hostnames aus einer .de-Domain.

    • ns1.meinedomain.de
    • ns2.meinedomain.de
    • ns3.meinedomain.de

    Nun habe ich in dieser Antwort eines anderen Threads bereits gelesen, dass im CCP lediglich die Hostnamen der DNS-Server eingetragen werden sollen. Sobald ich das aber bei meiner .com-Domain mache, zeigt mit der DNS-Checker nach einiger Zeit, dass keine NS-Einträge für die Domain vorhanden sind.


    Ist es nicht möglich, eine .com-Domain mit Nameservern aus einer .de-Zone zu betreiben oder habe ich hier einen Denkfehler gemacht?


    Liebe Grüße

  • Ist es nicht möglich, eine .com-Domain mit Nameservern aus einer .de-Zone zu betreiben oder habe ich hier einen Denkfehler gemacht?

    Doch, das ist möglich. Ich betreibe eine .es-Domain mit DNS-Servern aus der .de-Zone.

    Irgendwo wirst du wahrscheinlich einen Denkfehler haben.


    Mir hat bei solchen Problemen schon oft https://zonemaster.net/ geholfen.

    Die haben aktuell nur einen Bug mit der Internationalisierung. Vor dem Test einmal die Sprache auf Französisch und anschließend wieder auf Englisch wechseln.


    Edit: Wenn du mir die Domain nennen magst (auch gerne per PN), kann ich mal genauer hinschauen. Vielleicht fehlen auch nur die NS-Einträge auf den DNS-Servern. Die sollten mit denen übereinstimmen, die du bei der Domain im CCP eingetragen hast.

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • Danke für deine Antwort!

    Irgendwo wirst du wahrscheinlich einen Denkfehler haben.

    Das vermute ich auch aktuell (oder Netcup hat etwas durcheinander gebracht; möglich ist das).

    Quote

    Mir hat bei solchen Problemen schon oft https://zonemaster.net/ geholfen.

    Die haben aktuell nur einen Bug mit der Internationalisierung. Vor dem Test einmal die Sprache auf Französisch und anschließend wieder auf Englisch wechseln.

    Danke für den Tipp, die Seite kenne ich sogar schon. Sie zeigt mir aktuell aber leider nur "No data for this test".

    Quote

    Edit: Wenn du mir die Domain nennen magst (auch gerne per PN), kann ich mal genauer hinschauen. Vielleicht fehlen auch nur die NS-Einträge auf den DNS-Servern. Die sollten mit denen übereinstimmen, die du bei der Domain im CCP eingetragen hast.

    Sehr gerne, danke für das Angebot. Ich schicke dir die Daten gleich per PN zu.

  • Sie zeigt mir aktuell aber leider nur "No data for this test".

    Genau aus dem Grund habe ich das hier geschrieben:

    Die haben aktuell nur einen Bug mit der Internationalisierung. Vor dem Test einmal die Sprache auf Französisch und anschließend wieder auf Englisch wechseln.

    Ich schaue mir das mal genauer an, was du mir geschickt hast.

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • Um den Thread hier parallel auf dem aktuellen Stand zu halten:


    In der .com-Zone sind als Nameserver noch die von netcup eingetragen. Jedoch gibt es auf den Nameservern von netcup keine Zone für die Domain:


    Code
    1. nslookup -q=ns <domain>.com. 192.5.6.30
    2. <domain>.com nameserver = root-dns.netcup.net
    3. <domain>.com nameserver = second-dns.netcup.net
    4. <domain>.com nameserver = third-dns.netcup.net
    Code
    1. nslookup -q=soa <domain>.com. 46.38.225.225
    2. *** <domain>.com wurde von root-dns.netcup.net nicht gefunden: Query refused.

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • Kleine Ergänzung: Interessanterweise scheint das aber nur der Fall zu sein, wenn noch gecachte Einträge vorhanden sind.


    Frage ich z. B. das SuperTool (https://mxtoolbox.com/SuperTool.aspx), so bekomme ich folgende Antwort:

    Quote

    Sorry, we couldn't find any name servers for '<domain>.com'

    Ähnlich schaut es bei dnschecker.org aus (Screenshot).

  • Hier auch nochmal zur Verdeutlichung, was die Befehle oben bedeuten:


    Dieser Befehl fragt direkt den primären Nameserver von der .com-Zone nach den hinterlegten Nameservern für <domain>.com: nslookup -q=ns <domain>.com. 192.5.6.30

    Antwort:

    root-dns.netcup.net

    second-dns.netcup.net

    third-dns.netcup.net


    Dieser Befehl fragt den primären Nameserver von netcup (root-dns.netcup.net) nach dem SOA-Record für <domain>.com: nslookup -q=soa <domain>.com. 46.38.225.225

    Antwort:

    *** <domain>.com wurde von root-dns.netcup.net nicht gefunden: Query refused.


    Bedeutet also: Die netcup-Nameserver haben brav die Zone gelöscht. Bei den Nameservern von .com ist die Änderung aber nicht angekommen.

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • In der .com-Zone sind als Nameserver noch die von netcup eingetragen. Jedoch gibt es auf den Nameservern von netcup keine Zone für die Domain:

    Ein Klassiker - den Bug gibt es öfter mal bei Netcup zu sehen.

    cltrmx hier hilft es, wieder die Netcup Nameserver einzustellen und danach, mit Abstand von 1 bis 4 Stunden wieder die externen Server einzutragen.


    Ggf. ist das auch ein Fall für den Netcup Support

  • Ein Klassiker - den Bug gibt es öfter mal bei Netcup zu sehen.

    cltrmx hier hilft es, wieder die Netcup Nameserver einzustellen und danach, mit Abstand von 1 bis 4 Stunden wieder die externen Server einzutragen.


    Ggf. ist das auch ein Fall für den Netcup Support

    Das hatte ich heute Nachmittag schon mal versucht (zugegeben ohne 4h zu warten). Da waren bei den "großen2 DNS-Servern überall wieder Netcup eingetragen und alles hat funktioniert.


    Habe den Support kontaktiert, mal schauen, was da bei rum kommt.

  • Update meinerseits bzw. des Supports:

    Ab gestern Nachmittag (ca. 24h nach dem Ausfall) wurde die Domain durch die meisten Nameserver wieder korrekt aufgelöst. (Ich konnte Emails bekommen, juhu!) An den Einstellungen hatte ich nichts mehr geändert.


    Der Support hat sich dann heute bei mir gemeldet und meine Anfrage an die entsprechende Abteilung weitergegeben. Dabei kam folgende Antwort heraus:

    Quote
    Code
    1. Es ist im Nachhinein natürlich immer ein wenig schwierig, den genauen Ablauf zu rekonstruieren. So wie ich es sehe, gab es eine Einschränkung bei der Registrierungsstelle, weswegen die Änderung nicht zeitnah übernommen wurde. Sollte so etwas nochmals auftreten, wechseln Sie am besten erst einmal zurück auf die netcup Nameserver und kontaktieren uns, dann untersuchen wir das gerne für Sie, bzw. nehmen auch Kontakt mit der Registrierungsstelle auf, falls nötig.

    Meines Verständnisses nach ist das beschriebene Vorgehen genau jenes, was auch die Mitglieder des Forums empfohlen haben. Bleibt zu hoffen, dass dieser "Schluckauf" der Registrierungsstelle in Zukunft nicht mehr so häufig auftritt.


    Danke noch mal an alle, die mir hier geholfen haben :)