Let's Encrypt - automatische Verlängerung geht nicht

  • Hallo,


    ich bekomme vermehrt Mails vom Let's Encrypt Expiry Bot das meine SSL Zertifikate demnächst ablaufen.

    Im CCP sehe ich in der Beschreibung unter Let's Encrypt, dass diese eigentlich automatisch verlängert werden sollten (Hinweis: Das Zertifikat wird automatisch 30 Tage vor Ablauf verlängert.)

    Wenn ich aktive auf Ernuern klicke funktioniert es, bloss die automatisierte Erneuerung klappt nicht.


    Bin ich ein Einzelschicksal oder gibt es generell ein Problem damit?


    Danke und lG

    Stefan

  • Wenn ich das richtig in Erinnerung habe, wird im WCP erst 7 oder 8 Tage vor Ablauf erneuert

    Die Angabe der "30 Tage" ist falsch. Sollte die Erneuerung aber nicht klappen, bekommst du

    eine Nachricht von netcup. Genauso, wenn das Zertifikat verlängert wird.

    It's me, only me, pure michi

    RS 500 SAS G8 Ostern 19

    VPS: 50 G7 |B Ostern 2017|200 G8 Aktion| 200 G8

    WH: SmallEi | Adv17 Spezial Family |4000 SE|1000 WaD

  • Wenn ich das richtig in Erinnerung habe, wird im WCP erst 7 oder 8 Tage vor Ablauf erneuert

    Die Angabe der "30 Tage" ist falsch. Sollte die Erneuerung aber nicht klappen, bekommst du

    eine Nachricht von netcup. Genauso, wenn das Zertifikat verlängert wird.

    am 24.5 läuft es ab und bis dato ist nichts passiert. Ein paar Tage habe ich ja noch.

  • Die Option muss deaktiviert sein, damit das klappt. LE erwartet Statuscode 200 und nicht 301. Hat früher so geklappt, jetzt wohl nicht mehr

    Ich weiß zwar nicht in welchen Abständen LE es versucht, aber ich habe nachdem ich dir geantwortet habe die Umleitung entfernt, jedoch hat sich bis jetzt noch nichts getan. Wie bereits erwähnt warte ich noch einfach ein paar tage. Was sagt den der Netcup Support dazu?

  • Ich weiß zwar nicht in welchen Abständen LE es versucht, aber ich habe nachdem ich dir geantwortet habe die Umleitung entfernt, jedoch hat sich bis jetzt noch nichts getan. Wie bereits erwähnt warte ich noch einfach ein paar tage. Was sagt den der Netcup Support dazu?

    Der Support wird dir genau das sagen, was ich dir gesagt habe. Am einfachsten ist es einfach das Zertifikat zu verlängern

  • Die Option muss deaktiviert sein, damit das klappt. LE erwartet Statuscode 200 und nicht 301. Hat früher so geklappt, jetzt wohl nicht mehr

    Das kann eigentlich nicht sein. Ich habe die Option bei meinen Domains aktiviert und die automatische Verlängerung funktioniert trotzdem.

  • Das kann eigentlich nicht sein. Ich habe die Option bei meinen Domains aktiviert und die automatische Verlängerung funktioniert trotzdem.

    Dann scheint das wohl von Instanz zu Instanz unterschiedlich zu sein. Beim Reseller Tarif (also die neuste Plesk Version) ist genau dies der Fall und mir wurde das so vom Support zurückgegeben, dass diese Option deaktiviert werden soll für LE. Bei meinen alten Tarifen war diese Funktion aber immer aktiv und es hat trotzdem geklappt.

  • KlausWei

    Ich würde es lieber anders machen, wie bereits oft im Forum vorgeschlagen: Domain auf einen eigenen Ordner zeigen lassen und dort mittels .htaccess-Datei umleiten. Dann hast Du für die ursprüngliche Domain bei Bedarf sogar HTTPS über Let's Encrypt ;)


    Die Weiterleitungsoptionen in Plesk sind zwar für den schnellen Einstieg recht nett und praktisch, aber im Endeffekt schränkt man sich damit nur unnötig ein.