DNS-Record für Teamspeak3 Server

  • Hallo zusammen,


    ich habe eine Domain und möchte eine IP-Adresse mit Port als A-Record einstellen.

    Nachdem ich den DNS-Record bearbeitet bzw. hinzugefügt habe, erscheint die Meldung, dass dies ein falsches Format sei.

    Bis jetzt konnte ich nicht - auch nicht in Verbindung anderer Records - die IP-Adresse des Teamspeak 3 Servers hinzufügen.


    Liebe Grüße,

    Steve Timmermann

  • Ich muss mich nochmal melden.

    Screenshot_36.png


    Ich habe das bereits so gemacht. Ein wenig öfter, um wirklich sicher zu gehen. Ich habe sowohl die Subdomain ts.domain.tld als auch meine Domain ohne Subdomain angegeben. Ich muss mich mit dem Port vom TS3 verbinden, bei mir verbindet er sich zwar auf einen TS3 Server, aber das ist nicht der richtige.


    Die IP's sind soweit richtig, der Port ebenso. Der DNS ist also auch schon "übertragen", da ich mich mit dem Hauptserver mit der IP und dem Standard-Port verbinde.

    Mein Ziel wäre natürlich, dass ich mich mit der Domain ohne Subdomain verbinde.


    Grüße

  • Wenn ich diese nicht habe? Ich hoste über 4netplayers bzw. 4players. Die IPv6 wird mir nicht angezeigt.

    Oh gott 4netplayers. Hab mich immer gefragt, wer da seine TeamSpeak Server hostet. Ist zwar jetzt off-topic, aber was hat dich dazu bewegt, dort den TeamSpeak Server zu mieten? Die Slotpreise sind genauso hoch wie bei N1trado, bei 4netplayers musst du aber für dateitransfer extra blechen und deren Werbung ist sowieso noch überall. Und was wagen die es eigentlich, die NATIVE Verschlüsselung nur gegen Aufpreis zu entsperren?! Und dass die kein IPv6 unterstützen, ist ja zusätzlich peinlich.


    Zurück zu deiner Frage: Nein, IPv6 brauchst du nicht, damit deine SRV-Records funktionieren. Das war nur eine Ergänzung von mir.


    Wenn du möchtest, kann ich dir gerne kostenfrei zeigen, wie du einfach einen TeamSpeak auf einem kleinen VPS bei netcup aufsetzen kannst. Da hast du dann volle Freiheit ... Ich wünsche eigentlich keinem die Qualen, die man bei 4netplayers erleidet.

  • Ja, das war ein Fehlkauf von vor 4 Monaten.. habe ihn bis dato nicht genutzt und leider dort eine lange Mindestlaufzeit genommen..

    Zahle zwar für viele Slots überhaupt nichts, dennoch funktioniert der Kram nicht so ganz. Vielleicht habe ich einfach nur etwas übersehen bzgl. der DNS?


    Grüße

  • Hay,

    Die IP's sind soweit richtig, der Port ebenso. Der DNS ist also auch schon "übertragen", da ich mich mit dem Hauptserver mit der IP und dem Standard-Port verbinde.

    Mein Ziel wäre natürlich, dass ich mich mit der Domain ohne Subdomain verbinde.

    und immer im Hinterkopf haben, dass sich die DNS-Einträge u.U. erst nach 48h verteilt haben.


    Wenn Du Zuhause eine Linux-Kiste stehen hast, gerne mal einen


    dig _ts3._udp.deinedomain.tld SRV


    machen und schauen, ob der auch den gewünschten Eintrag zurückliefert.


    Und bei den vielen SRV-Einträgen... kannst Du sicher sagen, welcher benutzt wird - vielleicht wird ja einer der komplett falschen benutzt (Nr. 3 und Nr. 4)? Oder der halbfalsche (Nr. 2). Bei zufälliger Wahl Wahrscheinlichkeit 75% dass es nicht klappt. Ich selbst habe mit Teamspeak und SRV-Einträgen bislang noch nicht arbeiten müssen, aber weniger (dafür richtig) ist mehr.


    ich würde den mit _ts3._udp SRV 0 5 10174 ts.domain.tld stehen lassen, alle anderen löschen und einen expliziten ts A IP aufnehmen und dann sollte es (nach spätestens 48h) auch funktionieren.


    CU, Peter

  • Hallo,


    ich habe bis jetzt gewartet und gehofft, dass er die IP-Adresse als DNS abspeichert bzw. übernimmt.

    Ich habe verschiedene Varianten versucht, dennoch lässt er den DNS nicht zu.


    Ich habe es mit meinen verschiedenen Domains in verschiedenen Varianten ausprobiert. Keine hat so wirklich funktioniert.

    Bei dem Beispiel im Bild fragt er mich nach einem Passwort, obwohl ich keines habe, wenn ich den TS3 joinen möchte.

    Sieht so aus als würde ich auf die Haupt-Adresse zugreifen wollen, also den Standard-Port. Ich brauche aber den eigenen Port.


    Grüße

  • Es könnte helfen, wenn du nie Daten nicht alle schwärzen würdest, um das Ganze besser kontrollieren zu können. Ggf. per Privater Nachricht?


    Beachte auch, dass DNS-Änderungen ne ganze Weile brauchen können - und auch Computer, sogar Router, das ganze auch noch gern mal im Cache halten.


    Gruß

    René

  • Habe dir schon geantwortet. Die DNS-Einträge sehen soweit gut aus.


    Wie in der PM angesprochen mal bitte mit nslookup -q=srv _ts3._udp.deinedomain.xyz gegenprüfen, ob die korrekten Einträge bei dir zuhause überhaupt ankommen.


    Gruß

    René

  • Hat alles wunderbar funktioniert, das lag daran, dass ich einen Gedankenfehler hatte.

    Ich habe mich mit der Subdomain ts.domain.xyz verbunden und nicht wie ich dort geschrieben habe, über die Hauptdomain.

    Vielen Dank für die Hilfe, durch eure Hilfe war das erst ersichtlich!


    Guten Rutsch!