Magento 2.1 installation

  • Hallo Zusammen,


    nach vielen versuchen habe ich endlich Magento 2.1 über WCP installieren können.

    Nun rufe ich die Seite auf und bekomme viele 404 Fehler.

    z. Bsp.:

    GET http://www.....de/pub/static/frontend/Magento/luma/de_DE/requirejs/require.js net::ERR_ABORTED 404 (Not Found)

    GET http://www.....de/pub/static/frontend/Magento/luma/de_DE/mage/calendar.css net::ERR_ABORTED 404 (Not Found)


    Ich habe dann unter httpdocs/.../pub/static/ nach geschaut, der Ordner frontend ist nicht vorhanden.


    Habt ihr ein Idee wie ich Magento Fehlerfrei installieren kann? Oder was muss ich machen damit es funktioniert?



    Mein Paket ist:


    Webhosting 4000 SE


    Website Entwicklung

    PHP Memory Limit: 512 MB
    PHP Upload Filesize: 128 MB
    PHP Execution Time: 180 s
    PHP Versionen: 5.3/5.4/5.5/5.6/7.0/7.1/7.2/7.3
    PHP via FPM oder Fast-CGI: Ja
    Opcode-Cache Ja
    Zugriff auf Logdateien: Ja
    Individuelle Fehlerseiten: Ja


    Danke

    :)

  • PHP habe ich die Version 7.0.33 ausführen als FPM-Anwendung von nginx bedient.


    memory_limit 512M

    max_execution_time 180

    max_input_time 60 (Standard)

    post_max_size 128M

    upload_max_filesize 128M

    opcache.enable on (Standard)


    und alles andere auf Standard

  • Grundsätzlich halte ich das schonmal bei Magento für zu gering:


    max_execution_time 180

    max_input_time 60 (Standard)


    Kann es sein das hier mit Links gearbeitet wird, die falsch gesetzt wurden. Ich weiß noch von Version 1.x das es neben Typo3 nicht ganz einfach zu installieren ist.


    Will jetzt auch nicht nörgeln und hilft Dir gerade auch nicht weiter, aber Magento ist natürlich ein riesiges Shopsystem für hunderte gleichzeitiger Zugriffe. Nur dafür ist das Webhosting zu schwachbrüstig. Vielleicht gehst Du eher auf Shopware.

    Denken ist wie googeln, nur viel krasser ....

    ——

    Alle Beiträge geben nur meine persönliche Meinung wieder und nicht mehr.

  • Wobei ein 404 nichts mit irgendwelchen Skriptlaufzeiten zu tun hat. Schätze eher komische .htaccess-Parameter.


    Unabhängig davon ist FPM einfach nur Käse. FastCGI ist hier sinnvoller.

    Hach ja, deshalb mein Hinweis: Kann es sein das hier mit Links gearbeitet wird, die falsch gesetzt wurden. Ich weiß noch von Version 1.x das es neben Typo3 nicht ganz einfach zu installieren ist.


    Sonst noch etwas konstruktives ?

    Denken ist wie googeln, nur viel krasser ....

    ——

    Alle Beiträge geben nur meine persönliche Meinung wieder und nicht mehr.

  • Sonst noch etwas konstruktives ?

    Klar. Siehe meinen Post. Btw. ist der Trend zu 2. Accounts schon lange vorbei ;)


    @Threadopener: Schau mal in die Error Logs ob da ggf. mehr zu sehen ist. Da sollte ein Hinweis drauf sein, welche Datei hier explizit nicht geöffnet werden kann.


    Edit: Ich brauche glaub so langsam eine Brille. Da stehen ja die Dateien die nicht gefunden werden.

    Ist die Installation wirklich sauber durchgelaufen? Ggf. einmal über den Webpanel App Pool entfernen und einfach manuell installieren.

  • Versuch mal folgendes in der .htaccess


    Code
    1. # Remove signature of the static files that is used to overcome the browser cache
    2. RewriteRule ^version.+?/(.+)$ $1 [L]
    3. RewriteCond %{REQUEST_FILENAME} !-f
    4. RewriteCond %{REQUEST_FILENAME} !-l
    5. RewriteRule .* ../static.php?resource=$0 [L]

    Ist aber nur ein Versuch.

    Denken ist wie googeln, nur viel krasser ....

    ——

    Alle Beiträge geben nur meine persönliche Meinung wieder und nicht mehr.

  • Versuch mal folgendes in der .htaccess


    Code
    1. # Remove signature of the static files that is used to overcome the browser cache
    2. RewriteRule ^version.+?/(.+)$ $1 [L]
    3. RewriteCond %{REQUEST_FILENAME} !-f
    4. RewriteCond %{REQUEST_FILENAME} !-l
    5. RewriteRule .* ../static.php?resource=$0 [L]

    Ist aber nur ein Versuch.

    ist vorhanden:

  • Ich denke mal du hast die neuste Version heruntergeladen und draufgebügelt...


    Netcup bietet bei den Webhosting-Angeboten Composer an, installiere es am besten hiermit.

    Magento 2 über das FS zu installieren ist nicht sehr sinnvoll.


    Siehe hier: https://devdocs.magento.com/gu…ntegrator_install_ce.html

    Auf die Kommentare, Anmerkungen oder allgemeinen Text von:

    H6G, killerbees19, janxb, whoami0501, philw95, Bensen, DerRené und julian-w


    Kann ich verzichten !