NameCheap Domain auf netcup RootServer zeigen / DNS und IPv6-Konfiguration

  • Hallo,


    ich erlebe das erste Mal Probleme beim Einrichten eines Servers. Ich erreiche einfach den Apache Webserver nicht über die Domain. SSH-Connection über die Domain (nicht IP) funktioniert jetzt.

    Meine Domain liegt bei NameCheap, mein neuer root Server ist bei netcup. Domain:


    Im SCP sehe ich folgende IP-Informationen:

    2022-07-11 17_00_12-Window.png


    Zuerst hatte ich nur IPv4 in den DNS-Einstellungen von NameCheap hinterlegt. Jetzt habe ich auch IPv6 eingetragen, was scheinbar falsch ist:

    2022-07-11 17_03_07-Window.png

    Beim IPv6 Lookup erhalte ich die Fehlermeldung, dass die Adresse nicht erreichbar wäre. Was habe ich bei der IPv6 Konfiguration falsch gemacht?


    Beim Pingen der Domain sehe ich die korrekte IPv4.


    Beim Apache habe ich einen vHost für die Domain angelegt. Aber die Domain ist grundsätzlich nicht über http/https erreichbar.


    Ist meine DNS-Einstellung denn grundsätzlich korrekt?

    Ich bitte Euch, Kunden-Seiten nicht direkt zu erwähnen, damit nicht unnötig Traffic hierher geleitet wird, wenn jemand bspw. nach xymeinkunde.de googlet. :)

    Edited 2 times, last by Akay ().

  • Go to Best Answer
  • Hast du den Server selbst komplett installiert oder eins der netcup-Images installieren lassen? Welche IPv6 Adresse hast du ihm zugewiesen? So wie in deinem Screenshot drinsteht wird es nicht funktionieren, du musst schon eine konkrete, vollständige IPv6 angeben und diese IPv6 muss auch auf dem Server konfiguriert sein.

  • Hast du den Server selbst komplett installiert oder eins der netcup-Images installieren lassen? Welche IPv6 Adresse hast du ihm zugewiesen? So wie in deinem Screenshot drinsteht wird es nicht funktionieren, du musst schon eine konkrete, vollständige IPv6 angeben und diese IPv6 muss auch auf dem Server konfiguriert sein.

    Ist ein Netcup Image mit Ubuntu 22.04 LTS. Habe LAMP, ufw und fail2ban installiert. Ports 80 und 443 sind offen. Habe keine IPv6 zugewiesen. Wusste nicht, dass und wie ich das machen muss. Habe bisher nie IPv6 genutzt.


    Brauche ich IPv6 überhaupt? Wenn nicht, würde ich das einfach aus dem DNS löschen.


    Habe das hier entdeckt:

    2022-07-11 17_24_44-Window.png

    Ich bitte Euch, Kunden-Seiten nicht direkt zu erwähnen, damit nicht unnötig Traffic hierher geleitet wird, wenn jemand bspw. nach xymeinkunde.de googlet. :)

    Edited 2 times, last by Akay: Screenshot hinzugefügt. ().

  • Brauche ich IPv6 überhaupt? Wenn nicht, würde ich das einfach aus dem DNS löschen.

    Wird zwar empfohlen, brauchst du aber nicht unbedingt. Läuft alles auch weiterhin über ipv4 ohne Probleme. Dual Stack schadet halt nie haha

    1x VPS Funny Bunny OST21

    17x VPS 200 G10s

    Like 1
  • Evtl. Auch mal einen anderen Browser versuchen oder bei Google einen "DNS propagation Checker" befragen

    Habe beides schon durch.

    Vier verschiedene Browser, meistens wird automatisch nach https weitergeleitet, was ich selbst nicht im Apache eingestellt habe. Fehlermeldung immer: ERR_CONNECTION_REFUSED


    Im DNS-Tool sehe ich weltweit die korrekte IPv4-Adresse.

    Ich bitte Euch, Kunden-Seiten nicht direkt zu erwähnen, damit nicht unnötig Traffic hierher geleitet wird, wenn jemand bspw. nach xymeinkunde.de googlet. :)

    • Best Answer

    Also plain HTTP geht mit .dev nicht - da brauchst du ein gültiges Zertifikat und musst HTTPS nutzen. Für alle anderen Dienste (ICMP/ping, DNS, SSH, etc.) ist das aber irrelevant.


    Die Adresse mit :: am Ende ist natürlich gültig - bei Netcup gehört einem das gesamte /64 Netz, da wird nicht die erste Adresse für einen Router o.ä. "weggenommen".

    Allerdings muss man die :: Adresse korrekterweise ebenso wie zusätzliche (::1, ::2, etc) im SCP eintragen und im Gastbetriebssystem einrichten.


    Leider kenne ich mich mit Ubuntu und der hier gelieferten Cloud Init Konfiguration nicht aus.

    Die Route sieht dort richtig eingetragen aus, allerdings sollte zusätzlich geprüft werden, ob

    • Dein Client- und/oder Heimnetzwerk überhaupt mit IPv6 mit dem Internet verbunden ist (ping -6 netcup.de ?) und falls ja:
      • `dig <domain> AAAA` den v6 Record zurückgibt
      • `ping -6 <domain/IP adresse>` eine Antwort liefert
    • Deine VM via IPv6 in's Internet kommt (ping -6 netcup.de ?) und falls nein:
      • Router Advertisement im Gastsystem funktioniert (sonst "kennt" der Netcup Router deine IP Adresse nicht)
      • Die IP Konfiguration von Cloud Init auch tatsächlich aktiv ist (`ip a` und `ip -6 r`)

    Wenn diese Basiskonnektivität funktioniert kann man sich den weiteren Diensten (HTTP[S] u.ä.) widmen.

  • Akay

    Selected a post as the best answer.
  • Ich habe per Let's Encrypt https aktiviert bzw. ein SSL-Zertifikat installiert und prompt geht die Seite. Vielen Dank allen Beteiligten.


    IPv6 schaue ich mir die Tage noch an. Dazu brauche ich einen freien Kopf.

    Ich bitte Euch, Kunden-Seiten nicht direkt zu erwähnen, damit nicht unnötig Traffic hierher geleitet wird, wenn jemand bspw. nach xymeinkunde.de googlet. :)

    Edited once, last by Akay ().

    Happy Duck 3
  • die IPv6 (ohne /64) aus #7 kannst du im DNS eintragen, dann sollte das auch funktionieren.

    Ja, das scheint zu funktionieren. Vielen Dank. :)

    Ich bitte Euch, Kunden-Seiten nicht direkt zu erwähnen, damit nicht unnötig Traffic hierher geleitet wird, wenn jemand bspw. nach xymeinkunde.de googlet. :)