Minecraft Server mit lags

  • Hallo


    Ich habe seit kurzem den easyV Profi Server mit:


    4.000 MHz CPU-Leistun
    2.048MB RAM / 4.096MB Flexi-RAM


    Dort läuft nun bisher ein Teamspeak und ein Minecraft Server.
    Während ich beim Teamspeak keinerlei beschwerden habe ist das bei Minecraft leider nicht der Fall.
    Alle 1-2min hat der Server massive Aussetzer die mehrere Sekunden dauern können. Oder das einloggen klappt nicht (timeout).


    Nun bin ich leider ganz neu auf dem Gebiet und habe Probleme die Ursache zu finden. Meine vermutung wäre die CPU da Minecraft soweit ich weiss nur einen Rechenkern nutzt.
    Es gibt auch Empfehlungen bei Windows Servern alle anderen Kerne für den Prozess zu sperren.


    1. Hat irgendjemand eine Ahnung ob der vServer für Minecraft zu schwach ist? (1-5 Spieler)
    2. Wie bekomme ich unter Linux heraus auf welcher CPU Minecraft läuft und ob diese überlastet ist? (Meine 4000Mhz verteilen sich ja sicher auf mehrere Kerne)



    Danke schonmal
    Quenaros

  • Ich habe den vServer 4000 und die gleichen Probleme. Zudem stürzt der Server alle paar Stunden ab.


    Ich vermute die Ursache allerdings bei der Serversoftware und nicht bei netcup. Denn wie du schon sagtest, nutzt Minecraft nur einen Kern. Während mein Minecraft-Server auf dem letzten Loch pfeift, kann man parallel problemlos Left4Dead2 spielen und im TS3 reden. Das läuft alles problemlos weiter.


    Es ist einfach ne vertrackte Geschichte mit Minecraft. Ich mein, eine Serversoftware in Java zu schreiben ist nicht gerade die beste Lösung.

  • Hm ja, das listige ist das der Server auf einem Laptop mit 1,5Ghz(Singlecore) und 1GB RAM über eine DSL Leitung und Dyndns besser lief.


    Ich hoffe da wird noch was gemacht an der Serversoftware. Vielleicht ja nachdem das Speichermanagement überarbeitet wurde (Welches noch schlimmer ist)


    Danke für die Antwort. ^^

  • Quote from clickmaster;30374

    Ich mein, eine Serversoftware in Java zu schreiben ist nicht gerade die beste Lösung.


    Auch, wenn es jetzt Offtopic ist: Aber kannst du diese Aussagen auch irgendwie belegen, was daran so schlecht ist? Denn irgendwie kann ich das so allgemein nicht im Raum stehen lassen :D



    MfG Christian

    "Wer nur noch Enten sieht, hat die Kontrolle über seine Server verloren." (Netzentenfund)

  • Quote from killerbees19;30407

    Aber kannst du diese Aussagen auch irgendwie belegen, was daran so schlecht ist? Denn irgendwie kann ich das so allgemein nicht im Raum stehen lassen :D


    Es wird einfach auf den x Jahre alten Vorurteilen herumgeritten, dass Java 1.2 und 1.3 wirklich grotten langsam war.

  • Bei mir sind permanent 15 Leute drauf und es ist unspielbar. Fängt ab 5-6 Spielern an zu laggen. Du gibst z.B. was in den Chat ein und es dauert 20 Sekunden, bis die anderen es lesen.

  • Welche MC Server Software benutzt du?
    Die nackte Originale?
    Als Beispiel ist die neue von Hey0 also CraftBukkit noch total unausgereift und neigt dazu schnell den ganzen Speicher oder auch mal die CPU auszulasten.


    Also der Hey0 Mod lief bei mir auf dem vServer gleiche Hardware wie du bei 18 Player noch überaus flüssig.

  • Macht ihr vielleicht sogar sehr viel Booom mit dem ganzen TNT?
    Oder ist die Karte schon so riesig abgelaufen?
    Schaue dochmal wärend ihr spielt wie die Auslastung des Servers ist oder schaue auch in der Konsole ob es häufiger vorkommt das der Server sagt: Cant keep up!
    Haben auch andere das Problem, oder nur du?

  • Quote from blacky5;30430

    Cant keep up!
    Haben auch andere das Problem, oder nur du?


    Das zeigt er mir alle paar Sekunden an und sogar schon ab 5-6 Spielern. RAM habe ich ihm 2 GB zugewiesen. Laut den Chatnachrichten klagt jeder Spieler auf dem Server über Lags. Du baust z.B. nen Block ab und es dauert ca. 5 Sekunden, bis du ihn aufsammeln kannst.

  • Moin,
    Hab den v(olks)Server 4000 und auf dem läufts selbst mit 24 Spielern (mehr warens noch nich^^) laggfrei.
    Hab nur grad n Ausfall von Seiten Netcups Oo :D

  • Hey,


    ich habe den easyV PRofi und auch einen MC Server laufen. Dieser laggt auch ständig in fast regelmäßigen Abständen.


    Egal was ich mache, ob ich den Server als reinen Minecraft Server starte, oder mit x Plug-Ins und Bukkit. Lags sind immer und jederzeit vorhanden.


    Ich weiß nicht mehr weiter... -.-

  • Auf welche Distribution lasst ihr das eigentlich alle laufen?


    Und wie sieht euer Befehl aus mit dem ihr Minecraft startet?


    Benutzt ihr ein StartUp Script?


    Wie schaut die Ressourcenlast aus wenn ihr den Minecraftserver beendet habt? (top / htop)




    Flow
    Bukkit kannst momentan eh noch total vergessen, wenn ich richtig gelesen habe ist für die Mod noch kein "InactiveChunkUnload Class" vorhanden.
    Es reißt den Server einfach total in die Knie, weil wirklich jeder Chunk im Speicher verweilt.
    Ich nutze zwar auch schon Bukkit aber nur weil es keine andere so umfangreiche Möglichkeit gibt.

  • Also ich lasse den Server unter Debian Lenny laufen.
    Starten tue ich es mit Multicraft (Server Wrapper) welcher aber auch nur folgenden Befehl ausführt (ich hab den Befehl mit einigen Einträgen erweitert, laggt aber trotzdem danach).


    Code
    java -server -Xms1024M -Xmx1024M -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:ParallelGCThreads=2 -XX:+AggressiveOpts -jar craftbukkit.jar nogui

    Wobei ich aktuell dem MC Server 1536 MB zugewiesenen habe.


    Hier mal ein Screnshot von htop. Weißt du zufällig wieso die Prozesse teilweise doppelt dort auftauchen (PID 382 und 407)? top zeigt die nicht an :/


    [Blocked Image: http://img810.imageshack.us/img810/321/unbenanntdp.th.jpg]


    Okay, wenn ich [x] Hide useland threads bei htop einstelle, dann sind die Prozesse nicht doppelt. Was haben die Balken (1 - 8) oben zu bedeuten? Google hat mir nichts dazu sagen können.


    Wenn der Server aus ist (also MC) dann ist die Auslastung:


    Quote

    Cpu(s): 2.1%us, 1.9%sy, 0.0%ni, 95.0%id, 0.5%wa, 0.0%hi, 0.4%si, 0.0%st

    Liebe Grüße


    PS: Selbst wenn ich den Server wie gesagt ohne Bukkit laufen lasse, laggt der genauso als wenn Bukkit + Plug-Ins eingeschaltet wären. Also keinen Unterschied.