phpmyadmin Pfad ändern

  • Hi vServer-Freunde,


    ich würde gerne den Pfad zu PhpMyAdmin ändern (als erste kleine Hürde).
    Muss ich dafür einfach den Ordner umbenennen und dann den Link zu dem Ordner entsprechend ändern?


    Wenn ich phpMyAdmin dann auch noch per htaccess schützen will, lege ich einfach die htaccess und passwd direkt in den phpMyAdmin-Ordner (oder muss man in dem Link-Ordner auch irgendwas machen)?

  • Quote from sim4000;20037

    vHost ändern, Ordner verschieben und Authentifizierung auf http ändern.
    http://wiki.phpmyadmin.net/pma/Auth_types#http


    Wo ist nun das Problem?


    Danke für die Antwort schonmal, leider hilft mir das aber nicht wirklich weiter.
    Kannst du die Schritte noch genauer erklären?


    • vHost ändern: wie geht das?
    • Ordner verschieben einfach per mv?
    • Quote

      In config.inc.php do not fill in values for $cfg['Servers'][$i]['user'] and $cfg['Servers'][$i]['password']


      Wenn ich da die Werte rausnehmen, ist auth_type http aktiviert?


    Bin Neuling auf dem Gebiet Server (irgendwann muss man ja mal anfangen) :)

  • Habe nun zum Schutz des Verzeichnisses per htaccess bisher folgendes (erfolglos) probiert:



    • Erstmal in der /etc/apache2/apache2.conf den Verzeichnisschutz für das PMA-Verzeichnis erlauben AllowOverride AuthConfig:


      <Directory "/usr/share/phpmyadmin">
      Options Indexes FollowSymLinks
      AllowOverride AuthConfig
      Order allow,deny
      Allow from all
      </Directory>


      jetzt in der config.inc.php im PMA-Verzeichnis den auth-type auf http ändern: $cfg['Servers'][$i]['auth_type'] ='http'

    • Apache neu gestartet -> keine htaccess Abfrage beim Aufruf von /phpmyadmin per Browser
    • Diese Anleitung hat auch nicht dazu geführt, dass ich per htaccess abgefragt werde:
      http://blog.bidinger.de/2009/1…t-mit-htaccess-schuetzen/


    Hat noch jemand eine Idee, was ich machen könnte?

  • Hi, die Anleitung ist so nich mehr ganz richtig, muss ich mal überarbeiten :D


    Du hast ja unter var/www/dein-phpma-ordner nur einen Link auf das eigentliche Verzeichniss gesetzt, hoffe ich zumindest?!


    Es müsste so sein das halt dieser Ordner auf den Installations Ordner von PhpmyAdmin unter /usr/share/phpmyadmin zeigt, richtig? Und genau in diesen Ordner musst du für den .htaccess Schutz mit Abfrage die beiden Dateien .htaccess und .htpasswd liegen haben.
    In die .htaccess musst du nun den absoluten Pfad zur .htpasswd drinne haben, also müsste diese Datei so aussehen:


    htaccess:

    Apache Configuration
    AuthType Basic
    AuthName "KEIN ZUGANG!"
    require valid-user
    AuthUserFile /usr/share/phpmyadmin/.htpasswd

    Und die .htpasswd legst du dann eben auch unter /usr/share/phpmyadmin ab, oder passt den Link in der .htaccess an, was ich auch empfehlen würde, denn es ist nicht gut die Passwort Datei direkt im Phpmyadmin Ordner zu haben, obwohls ja eigentlich verschlüsselt ist, aber trotzdem ;)


    Wenn du alles hast musste dem Apachen noch sagen das er unter var/www eine Abfrage zulassen soll, ändern musst du dafür das rot gedruckte in dieser Datei, also von None auf All, dass gilt dann nur für den Document Root unter var/www, danach sollte deine Abfrage klappen.


    /etc/apache2/sites-available/default