Could not determine the server's fully qualified domain name - bei Apache-Neustart

  • Hallo Netcup-Freunde,


    bin Neuling auf dem Gebiet vServer und habe mir den Server jetzt mal zugelegt, um mich ein bisschen in das Thema einzuarbeiten, werde euch also in Zukunft noch sicherlich mit reichlich Fragen nerven ;)


    Hier die erste:


    • Beim Versuch Apache neuzustarten, erhalte ich folgende Fehlermeldung "Could not determine the server's fully qualified domain name"


    Habe in der /etc/hostname statt vXXX mal vXXX.yourserver.net eingetragen, selbes Resultat. Habt ihr eine Idee?
    Hintergrund: ich habe in der php.ini ein höheres Memory_limit eingetragen, in der info.php steht aber immer noch der alte Wert.


    Meine nächste Frage:


    • Wo kann ich die Einstellungen für die htaccess vornehmen?
      Bekomme derzeit einen Internal Server Error mit der Drupal-Standard-htaccess.
  • Wenn Apache meckert dann wird es an einer fehlenden / falschen Apache Config liegen.


    http://forum.netcup.de/showthread.php?t=1379&highlight=fully+qualified+domain+name


    Bei PHP.ini mal eine PHP Info Datei anlegen und schauen welche php.ini verwendet wird und es dort anpassen. Apache Neustarte / Reload nicht vergessen.


    htaccess Einstellungen gehören zum Webserver und damit zu Apache, ergo, Apache Konfiguration.


    Was und warum der ISE verursacht wird? tail -f /var/log/apache2/error.log

  • Hachja die Meldung kenn ich zugut :D


    Bei mir lags an der /etc/ists Datei.


    Code
    127.0.0.1 localhost.localdomain localhost
    xxx.xxx.xxx.xxx server.deine-domain.tld server


    So nach diesem Shema sollte deine /etc/hosts aussehen.Die "x" durch deine IP ersetzen aber die erste Zeile genau so lassen.
    Danach den Server komplett neustarten und dann sollte die Meldung weg sein.
    Ist ein kleiner Imagefehler bei nem Image von Netcup, weiß aber nicht mehr welches es genau war. Hatte es nur noch in erinnerung :D


    MfG
    Andre

  • Danke schonmal für die Antworten.
    Erstmal noch kurz zur Info, habe einen vServer mit Debian.


    Nach dem Eintrag von


    Code
    ServerName localhost

    in die apache2.conf klappt der Neustart des Servers schonmal problemlos.


    Allerdings habe ich das htaccess Problem noch nicht lösen können.
    Laut Apache-Website müsste es mit None eigentlich ja egal sein, was ich in der htaccess zu stehen habe.


    Quote

    Wenn diese Anweisung auf None gesetzt wird, dann werden .htaccess-Dateien komplett ignoriert. In diesem Fall wird der Server nicht einmal versuchen, die .htaccess-Dateien im Dateisystem zu lesen.

    AllowOverride auf All zu ändern, hilft leider auch nicht.


    Sobald irgendwas in der htaccess steht, und sei es nur "Options +FollowSymLinks" gibt es einen Internal Server Error. Eine leere htaccess macht allerdings keine Probleme.


    edit: reicht nach dem Ändern ein "apache2 restart", oder muss man die Config-Datei irgendwie anders neu laden?

  • Hi,


    hast du Drupal aus den Paketquellen installiert? Denn dann musst du /etc/drupal/X/apache.conf (Lenny) bearbeiten.
    Ein "restart" liest die Konfiguration immer neu ein und startet den Demon neu.


    Grüße

  • Quote from joed;19976

    Hi,


    hast du Drupal aus den Paketquellen installiert? Denn dann musst du /etc/drupal/X/apache.conf (Lenny) bearbeiten.
    Ein "restart" liest die Konfiguration immer neu ein und startet den Demon neu.


    Grüße


    Hi, nein, habe die Inhalte per FTP auf den Server geladen. Das Problem besteht auch in jedem Nicht-Drupal-Ordner oder Benutzer.

  • Quote

    Allerdings habe ich das htaccess Problem noch nicht lösen können.
    Laut Apache-Website müsste es mit None eigentlich ja egal sein, was ich in der htaccess zu stehen habe.

    Nein. Wenn sich in einer .htaccess etwas findet was nicht erlaubt ist, löst Apache unter Umständen einen 500er Fehler aus.
    So beispielsweise wenn man mod_rewrite benutzen möchte.


    Das AllowOverride gibt es für jeden Ordner. Bist Du dir sicher, dass Du das All in dem richtigen <Directory>-Tag gesetzt hast?
    Und ein reload reicht. Ein restart musst Du nicht machen.

  • Quote from sim4000;19979

    Nein. Wenn sich in einer .htaccess etwas findet was nicht erlaubt ist, löst Apache unter Umständen einen 500er Fehler aus.
    So beispielsweise wenn man mod_rewrite benutzen möchte.


    Das AllowOverride gibt es für jeden Ordner. Bist Du dir sicher, dass Du das All in dem richtigen <Directory>-Tag gesetzt hast?
    Und ein reload reicht. Ein restart musst Du nicht machen.


    Yeah! Das war es!
    Hab als Directory jetzt das Verzeichnis des Kunden angegeben.


    Vielen Dank, so macht ein Forum Spaß!
    Werde mich jetzt noch weiter in den Server einarbeiten, um dann hoffentlich auch bald Newbies weiterhelfen zu können.