Problem Failover IPv6 Ubuntu Netplan

  • Moin,


    ich hab Probleme beim Einrichten einer Failover IPv6.

    Im SCP ist folgendes hinterlegt:

    pasted-from-clipboard.png

    Standartmäßig sieht die Datei /etc/netplan/50-cloud-init.yaml wie folgt aus (ipv4 hier entfernt, da das funktioniert):

    Füge ich bei adresses die Failover "2a03:4000:50:6b1::2/64" hinzu ist diese nicht pingbar...

    Erst wenn ich bei adresses noch "2a03:4000:33:21:6856:59ff:fef2:653b" hinzufüge klappt es.


    Kann man das irgendwie z.B. per Route umgehen , ohne das die Adresse "2a03:4000:33:21:6856:59ff:fef2:653b" hinzugefügt und erreichbar wird?
    Klar ich kann den eingehenden Traffic für diese Adresse per IP-Tables blocken, aber mich interessiert es, ob ich hier irgendwas falsch mache oder warum das eben so ist?

  • Erst wenn ich bei adresses noch "2a03:4000:33:21:6856:59ff:fef2:653b" hinzufüge klappt es.

    Steht ja auch so im SCP, dass das Subnetz auf diese IP geroutet wird. Daher muss die auf dem Server auch eingerichtet sein.

    Habe ich bei meinem zusätzlichen Subnetz genau so machen müssen. Eine andere Möglichkeit ist mir nicht bekannt.

    RS Brezn | VPS 500 G8 Plus | 2× VPS Karneval 2020 | VPS Pocket Admin | RS Cyber Quack | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

    Like 2 Thanks 1
  • Kann man das irgendwie z.B. per Route umgehen , ohne das die Adresse "2a03:4000:33:21:6856:59ff:fef2:653b" hinzugefügt und erreichbar wird?

    Nein. Über die preferred_lft kannst du verhindern, dass diese IP abgehend verwendet wird. Aber eingehenden Traffic darfst du nicht verhindern, da sie das Routing Ziel ist.

  • Nein. Über die preferred_lft kannst du verhindern, dass diese IP abgehend verwendet wird. Aber eingehenden Traffic darfst du nicht verhindern, da sie das Routing Ziel ist.

    Okay, das ist ein bisschen schade, das man das nicht verhindern kann.

    Bei Netplan geht das preferred_lft mit lifetime bei der IP.

    Das funktioniert so:

    könnte man glaub auch bei routes wie folgt abgehend von einer bestimmten IP erzwingen:

    Hat jedenfalls beides funktioniert. Gibts da nen richtiger ? xD


    Ausgehend wird die richtige IP verwendet.

    Nur bei Docker nicht, das verstehe ich noch nicht, aber da gibts dann vermutlich nen neuen Thread.