Server administrieren - wo fange ich an?

  • Es funktioniert so weit, vielen Dank euch, auch wenn ich ein wenig verwirrt bin:

    Und mein Wiki.js Server lässt sich leider auch nicht starten:

    Ich glaub, ich mach den platt und setze ihn einfach neu auf. Hab mir das mit den Snapshots irgendwie wesentlich einfacher vorgestellt ^^

    [RS] 2000 G9 | 500 G8 | Cyber Quack

    [VPS] 2000 ARM G11 | 1000 G9 | 200 G8 | Secret | A | mikro G11s | 4x nano G11s
    [WH] 8000 SE | 4000 SE | 2000 SE

  • Es funktioniert so weit, vielen Dank euch, auch wenn ich ein wenig verwirrt bin: [Wo kommt Ubuntu her?]

    Was sagt denn dpkg -S /usr/share/apache2/default-site/index.html?

    Ich glaub, ich mach den platt und setze ihn einfach neu auf. Hab mir das mit den Snapshots irgendwie wesentlich einfacher vorgestellt ^^

    Das ist natürlich auf den ersten Blick eine Option, so lernt man aber keine Server-Administration – (a) weil man es nicht versucht, bis es funktioniert (wenigstens mit einer Snapshot-Kopie in einer heimischen VM!) und (b) weil man sich damit soviel Arbeit macht, dass man gar keine Zeit mehr hat zum Lernen.

    Ohne (a) kann dieser Diskussionsfaden dann jetzt eigentlich geschlossen/von Dritten ignoriert werden.

    VServer IOPS Comparison Sheet: https://docs.google.com/spreadsheets/d/1w38zM0Bwbd4VdDCQoi1buo2I-zpwg8e0wVzFGSPh3iE/edit?usp=sharing

  • dpkg -S /usr/share/apache2/default-site/index.html

    apache2-data: /usr/share/apache2/default-site/index.html

    Mhm, mir geht da mehr darum eure Zeit nicht unnötig zu verschwenden ;)


    Ich fuchs mich morgen mal ein bisschen genauer in den Fehler rein, während der Arbeit bring das nichts...

    [RS] 2000 G9 | 500 G8 | Cyber Quack

    [VPS] 2000 ARM G11 | 1000 G9 | 200 G8 | Secret | A | mikro G11s | 4x nano G11s
    [WH] 8000 SE | 4000 SE | 2000 SE

    Edited once, last by Bud ().

  • apache2-data: /usr/share/apache2/default-site/index.html

    Und apt policy $(dpkg -S /usr/share/apache2/default-site/index.html | sed -e 's|:.*||') bzw. apt policy apache2-data (obiges Paket ist ja nun bekannt) benennt wirklich ein Debian-Paket als Ursprung?

    VServer IOPS Comparison Sheet: https://docs.google.com/spreadsheets/d/1w38zM0Bwbd4VdDCQoi1buo2I-zpwg8e0wVzFGSPh3iE/edit?usp=sharing

  • Kann ich mir leider erst morgen anschauen, aber schon einmal eine Frage vorweg:

    Wie lerne ich solche Befehle, ohne dass ich sie im Forum aufschnappe? ^^

    [RS] 2000 G9 | 500 G8 | Cyber Quack

    [VPS] 2000 ARM G11 | 1000 G9 | 200 G8 | Secret | A | mikro G11s | 4x nano G11s
    [WH] 8000 SE | 4000 SE | 2000 SE

  • Wie lerne ich solche Befehle, ohne dass ich sie im Forum aufschnappe? ^^

    Lesen, lesen, lesen: apt install -y manpages manpages-posix; find /usr/share/man -type f -exec man -l {} \;

    Alternativ gibt es in jeder gutsortierten Buchhandlung oder der lokalen/Online-Bibliothek Standardwerke, die weiterhelfen, etwa Linux: Das umfassende Handbuch oder Linux-Server: Das umfassende Handbuch oder die Linux Bible (RHEL-lastig) bzw. die Ubuntu Linux Bible.

    VServer IOPS Comparison Sheet: https://docs.google.com/spreadsheets/d/1w38zM0Bwbd4VdDCQoi1buo2I-zpwg8e0wVzFGSPh3iE/edit?usp=sharing

    Edited 2 times, last by m_ueberall ().

  • Ich stehe gerade auf dem Schlauch und sehe nicht wo...


    Hab ein Debian 10 (netcup Image) dem ich jetzt gerade eine zweite statische IP vermitteln möchte - vlan.

    Hab versucht die IP in der /etc/network/interfaces einzustellen - Kein Erfolg

    Hab versucht die IP in der /etc/network/interfaces.d/50-cloud-init.cfg einzzustellen - Kein Erfolg

    Nach den Changes hab systemctl restart networking das Networking neu gestartet.

    Ich gehe fest davon aus ich mache einen blöden Fehler, sehe ihn nur nicht.

    Wer fühlt sich bereit einmal auf den Fehler zu zeigen? :(


    Ist bei mir scheinbar zu lange her das ich unter Debian Netzwerk konfiguriert habe :D


    Unter Ubuntu läuft das ja alles mit netplan und dort gibt es noch eine 99_config.yaml neben der 50-cloud-init.yaml - Da läuft es auch alles. Aber bei dem Debian zickt es gerade

    RS Eggnog | VPS 1000 G10 SE | VPS piko G11s | VPS nano G11s | VPS mikro G11s | Webhosting 4000 NUE ADV23

  • Hab versucht die IP in der /etc/network/interfaces.d/50-cloud-init.cfg einzzustellen - Kein Erfolg

    So funktioniert es bei mir problemlos. Das eth1 Interface ist auch da?

    Code
    iface eth1 inet static
        address 192.168.150.2/24
    
    iface eth1 inet6 static
        address 2a03:ABCD:ABCD:ABCD:ABCD::2/64
  • Fehlt da nicht noch ein auto eth1


    Also so:


    Ansonsten mal mit ip a prüfen ob die Netzwerkschittstelle da auftaucht. Bei mir z.b. heißen die Immer ens3 4 usw.... Aber bei den Images von Netcup ist es meist eth0 1 usw...


    Edit: Man kann die Schnittstelle auch mit einem ifup eth1 starten. Dann muss man nicht ein systemctl restart networking machen.

  • Nur als kleiner Hinweis: Debian 10 ist seit mehr als einem Jahr EOL.

    Nevermind, gibt ja LTS.


    Jap, ist mir vorhin auch aufgefallen.

    Hatte eine ganze Zeit keine wirkliche Lust auf das Hobby und hatte kaum was gemacht :(

    Die Daten werden dieses Jahr auch noch auf den neuen Server migriert. Der steht schon. Der ist auch aktuell

    So funktioniert es bei mir problemlos. Das eth1 Interface ist auch da?

    Code
    iface eth1 inet static
        address 192.168.150.2/24
    
    iface eth1 inet6 static
        address 2a03:ABCD:ABCD:ABCD:ABCD::2/64

    Das eth1 Interface ist da. Das habe ich vorhin im SCP als vLan hinzugefügt.


    Ok... War wirklich ein blöder Fehler.
    Es fehlte noch ein ifup eth1 bzw. das auto eth1 in der Config -.-"


    Edit: Wurde ja auch geschrieben während ich hier noch am testen war. Aber so wurde ich wenigstens bestätigt :D


    Fehlt da nicht noch ein auto eth1


    Also so:


    Ansonsten mal mit ip a prüfen ob die Netzwerkschittstelle da auftaucht. Bei mir z.b. heißen die Immer ens3 4 usw.... Aber bei den Images von Netcup ist es meist eth0 1 usw...

    RS Eggnog | VPS 1000 G10 SE | VPS piko G11s | VPS nano G11s | VPS mikro G11s | Webhosting 4000 NUE ADV23

    Edited once, last by fvbor ().

    Like 1
  • Liebe Community,

    nach rund 15 Monaten unter euch möchte ich den Jahreswechsel nutzen, um ein kurzes Dankeschön loszuwerden.

    Danke, an [netcup] Claudia H., [netcup] Christina R. und [netcup] Lars S. für die Moderation dieses Forums. Die Community war für mich damals ein ausschlaggebender Punkt, wieso ich mich für netcup entschieden habe, und somit auch Dank eurer Arbeit. Übrigens sammele ich aktuell keine Tassen mehr, sondern Weihnachts- und Postkarten ;) Jemand hatte es vor Kurzem schon erwähnt: Handgeschriebenes macht es sehr persönlich, und man freut sich einfach mehr.

    Danke an alle aktiven User, welche Beiträge verfassen und Themen starten. Auch wenn ich natürlich nicht überall mitmische, nimmt man so nebenbei eine Menge mit.

    Danke für eure motivierenden Worte, über den Tellerrand der Webhostings zu schauen, und mir mal einen Server anzuschauen...

    Ein großer spezieller Dank gilt jedem Einzelnen, der mir in diesem Thema (oder auch in anderen) Linux / Server näher gebracht hat und mir helfend zur Seite stand – auch dann, wenn ich mal wieder auf dem Schlauch stand. Danke :*


    Mir ist auch bewusst, dass mich wegen meines „unfreundlichen Auftretens“, meines „unbedachten Quarks“ oder gar meiner Rechtschreibfehler ein paar wenige nicht leiden können, aber bei so vielen unterschiedlichen Charakteren ist das denke ich normal. Aber auch für euch gilt folgender Absatz:


    Ich hoffe, ihr rutscht heute alle gut ins neue Jahr, und habt einen schönen Abend/Nacht – passt gut auf euch auf. Auf dass ihr euren Wünschen und Vorstellungen für das Jahr 2024 näher kommt, sowohl beruflich als auch privat.

    Bud

    [RS] 2000 G9 | 500 G8 | Cyber Quack

    [VPS] 2000 ARM G11 | 1000 G9 | 200 G8 | Secret | A | mikro G11s | 4x nano G11s
    [WH] 8000 SE | 4000 SE | 2000 SE

    Thanks 9 Like 9 Happy Duck 6 Sad 1