RainLoop mit Verbindungsproblemen (SMTP)

  • Hallo zusammen,


    ich habe bei Netcup ein kleines Paket (Webhosting 1000 SE a1).

    Seit ca. 2 Wochen läuft dort Nextcloud. Davon verwende ich im Prinzip nur die Kalender und Kontaktsynchronisation und

    würde gerne, gelegentlich, auf meine Mails zugreifen.

    Die Mails werden per IMAP mit Rainloop abgerufen. Leider habe ich beim Versand das Problem, dass es die meiste Zeit nicht funktioniert

    und ich die folgende Fehlermeldung erhalte:

    stream_socket_client(): Unable to connect to ssl://mx2f8f.netcup.net:465 (Connection refused)


    Ab und zu geht es, ganz oft aber nicht.


    Hat jemand eine Idee dazu, warum das so ist?

    Es spielt im übrigen keine Rolle welchen Port oder Verschlüsselung ich verwende - die Meldung kommt (fast) immer.


    Freue mich, wenn ihr mir helfen könnt.


    pasted-from-clipboard.png

  • Go to Best Answer
  • Probier mal Port 587 mit StartTLS bei SMTP

    Ne, das ändert leider nichts, habe es gerade nochmal getestet.

    Wie ich ja schon oben erwähnte:

    Quote

    Es spielt im übrigen keine Rolle welchen Port oder Verschlüsselung ich verwende - die Meldung kommt (fast) immer

    Ich habe RainLoop auch mal ohne Nextcloud getestet, verhält sich aber genauso.

  • Dann wäre meine Vermutung, dass die IP-Adresse deines Webhostings auf der Blacklist des Mailservers gelandet ist.

    Ist natürlich gut möglich, dass andere auf deinem Webhosting auch Webmail-Anwendungen betreiben und wenn dort falsche Zugangsdaten eingegeben werden, sieht das für den Mailserver so aus, als würde jemand ständig falsche Zugangsdaten versuchen und sperrt irgendwann die IP.


    Wie sporadisch funktioniert es denn mal? Also liegen dazwischen Stunden/Tage oder funktioniert’s z.B. bei jedem 5. Klick?

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • Danke für Deine Antwort und sorry für meine späte - habs übersehen.


    Also es ist so, dass ich mich anmelde und mit etwas Glück 1, 2, 3 Mails raus bekomme - dann geht erstmal wieder nichts.

    Ob Abmelden/Anmelden Erfolg verspricht, konnte ich noch nicht verifizieren.

    Speichere dann in den Entwürfen und versuche es später wieder. Oder wenn es dringender ist, dann gehe ich den Weg über

    (Netcup)-Roundcube - da klappt soweit alles.


    Musste feststellen, dass ich das selbe Problem in Nextcloud habe - verhält sich dort auch so. Systemmails o.ä. gehen mal raus oder auch nicht.

    pasted-from-clipboard.png


    Zum testen habe ich auch mal die PHP-Version runtergeschraubt von 8.1 auf 7.4 - hat aber auch nichts gebracht...

  • Also für mich sieht das stark danach, als würde der Mailserver ständig die IP-Adresse vom Webserver timeouten.

    Vermutlich hat irgendein Kunde, mit dem du dir Web- und Mailserver teilst, falsche Zugangsdaten hinterlegt.


    Ich denke da kann nur der Support helfen.

    Wichtig ist, dass du erwähnst, dass es sich um ein generelles Problem handelt und nicht in Bezug auf eine von dir installierte Software. Sonst wirst du direkt mit "Wir können keine von Ihnen installierte Software supporten" abgehandelt.

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

  • Also für mich sieht das stark danach, als würde der Mailserver ständig die IP-Adresse vom Webserver timeouten.

    Vermutlich hat irgendein Kunde, mit dem du dir Web- und Mailserver teilst, falsche Zugangsdaten hinterlegt.

    Das wäre aber eine extrem kundenunfreundliche Konfiguration, wenn ein Kunde durch versehentlich falsche Eingabe von Zugangsdaten praktisch den kompletten Mailserver für alle Kunden lahmlegen könnte. Und das auch noch über einen längeren Zeitraum. Da würde ich mir doch erhoffen, dass man die IP des zugehörigen Webservers als Ausnahme konfiguriert hat. Oder dass man wenigstens die Logfiles oder die Jails regelmäßig auf diese IP überprüft, das ggf "schuldige" Skript zügig stoppt und den entsprechenden Kunden benachrichtigt.

  • Hier habe ich eine Antwort vom Support. Leider kann ich nicht allzuviel damit anfangen:


    Quote

    Wir haben festgestellt, dass extrem viele Verbindungen aufgebaut werden, dadurch kommt es immer wieder zu den Komplikationen.

    Ich würde Ihnen Empfehlen, die Verbindungen zu drosseln, damit es zukünftig nicht mehr vorkommt.

    Welche Verbindungen tatsächlich gemeint sind, kann ich nicht einschätzen. Mein Handy synchronisiert die Mails (IMAP) (4 andere Personen ebenfalls ihre eigenen Mails - auch IMAP) - sonst läuft doch nichts.

    Kann es RainLoop sein, dass eine Verbindung hält? Oder soviele Anfragen stellt, wenn ich angemeldet bin?


    Bin etwas ratlos.

  • Irgendwie passt meiner Meinung nach dann aber der Fehler nicht so ganz dazu. Der Webserver kann ja nicht mal einen Verbindung zum Mailserver aufbauen (bzw. lehnt der Mailserver die Verbindung ab). Zu dem Zeitpunkt weiß der Mailserver doch noch gar nicht, welcher Mail-Account sich da aktuelle versucht zu verbinden.

    Hat der Support verstanden, dass es sich bei dem Client um das Webhosting handelt? Oder übersehe ich da gerade was?

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

    Like 1
  • Man hat die Probleme wohl nicht bei allen Hostern. Kommt halt darauf an, wieviele gleichzeitige Verbindungen die zulassen, netcup und wohl auch einige andere Hoster sind da halt etwas restriktiver. Das Thema hatten wir vor längerer Zeit schon mehrfach. Bei Thunderbird z.B. kann ich die macximale Zahl der Verbindungen irgendwo einstellen, bei der Mail App weiss ich es nicht. Jedenfalls wird da wohl per Default pro vorhandenem IMAP Folder eine Verbindung aufgemacht. Und beim Schliessen nicht mehr gebrauchter Verbindungen ist die App wohl auch nicht so gut, eher beim Aufmachen von neuen Verbindungen. Kann natürlich auch sein, dass auch Rainloop sich ähnlich verhält.


    Problematisch ist eben auch, dass die Begrenzung der Verbindungen pro IP Adresse gilt. Wenn jetzt mehrere Geräte im selben WLAN eingebucht sind, dann haben alle die selbe IP-Adresse. Somit addieren sich ihre Verbindungen auf.


    Edit: Aber was Virinum da schreibt macht auch Sinn. Wobei, Fehlermeldungen sind oft nicht so detailliert. Rainloop bekommt halt eventuell schon eine Verbindung zum Server, die aber vom Server gleich wieder beendet wird. Probier mal, das/die iPhones mal kurzfristig auszuschalten oder auf mobile Daten umzustellen. Wenn es dann mit Rainloop besser klappt, dann hängt es wohl an dieser Geschichte. Aber, wie geschrieben, es mag auch an Rainloop selbst liegen.


    Edit2: Hmm, da die Begrenzung pro IP-Adresse gilt, die kennt der Mailserver definitiv.

  • Ok., verstehe.

    Für mich zum Verständniss noch.

    RainLoop baut nur eine Verbindung auf, wenn ich mich dort tatsächlich aktiv anmelde, oder? Cronjobs o.ä. laufen da keine.

    So könnte ich es prinzipiell dann (wahrscheinlich) auf die Endgeräte eingrenzen.(?)


    Edit: Was allerdings nicht erklärt, warum RoundCube von Netcup problemlos läuft... :-/

  • Irgendwie passt meiner Meinung nach dann aber der Fehler nicht so ganz dazu. Der Webserver kann ja nicht mal einen Verbindung zum Mailserver aufbauen (bzw. lehnt der Mailserver die Verbindung ab). Zu dem Zeitpunkt weiß der Mailserver doch noch gar nicht, welcher Mail-Account sich da aktuelle versucht zu verbinden.

    Hat der Support verstanden, dass es sich bei dem Client um das Webhosting handelt? Oder übersehe ich da gerade was?

    Hatte die Antwort gerade übersehen.

    Ich hoffe doch. Nach meiner Erklärung habe ich einfach mal den Link nach hier mitgeschickt...

  • Ich habe den Thread jetzt nochmal von Anfang an gelesen. Die Probleme sind ja beim Senden, also SMTP. Außerdem hat ja dein Webhostingserver und damit Nextcloud und/oder Rainloop eine andere IP als deine iPhones usw. Das sollte also entweder ein anderes Problem sein, oder der Mailserver blockt grundsätzlich alles, auch SMTP-Verbindungen, von IP-Adressen, die zuviele Verbindungen machen. Dann wäre - wenn überhaupt - höchstens Rainloop selbst der Verursacher.

    Das Roundcube von netcup läuft nicht auf deinem Webhostingserver oder Mailserver, deswegen hier eine andere IP als bei deinem Rainloop. Die mag auch von Verbindungsbeschränkungen ausgenommen sein oder jedenfalls hast du dahin dann nur eine Verbindung.


    Vorstellbar wäre eventuell noch eine Beschränkung der Gesamtzahl von Verbindungen zu E-Mail Accounts des selben Webhostings, also egal von welcher IP aus. Aber davon weiss ich jedenfalls nichts. Was es alles für Beschränkungen gibt, dazu müsste dann netcup was sagen können.

  • Edit: Was allerdings nicht erklärt, warum RoundCube von Netcup problemlos läuft... :-/

    Diese IP steht womöglich auf einer Whitelist.


    Dein Webhostingserver baut wahrscheinlich zu viele Verbindungen auf oder übermittelt zu oft falsche Zugangsdaten, danach wird die IP-Adresse des Webhostingservers automatisch (temporär) in der Firewall blockiert, wodurch der TCP-Verbindungsaufbau abgewiesen (refused) wird. Der Auslöser können aber auch andere Kunden am gleichen Server sein, wodurch es immer wieder von vorne los geht.


    Ich würde nochmals dem Support schreiben und darauf hinweisen, dass es um eine Verbindung vom Webhostingserver zum Mailserver geht und nicht um einen externen Abruf von woanders.

  • [...]

    Ich würde nochmals dem Support schreiben und darauf hinweisen, dass es um eine Verbindung vom Webhostingserver zum Mailserver geht und nicht um einen externen Abruf von woanders.

    Habe ich noch gemacht.


    Habe jetzt noch eine Rückmeldung erhalten:

    Quote

    Guten Tag Herr ...,

    vielen Dank für Ihre Geduld.

    Bitte probieren Sie es jetzt nochmals, ich denke, es ist jetzt behoben und sollte auch nicht mehr auftreten, andernfalls melden Sie sich bitte nochmals. Danke.

    Mit freundlichen Grüßen,


    Ich beobachte und gebe Rückmeldung! Wenn es klappt, dann frage ich noch nach der Lösung zum Problem - für's Allgemeinwissen...

    • New
    • Best Answer

    Hallo ihr lieben,

    erstmal herzlichen Dank für Eure "Anteilnahme" :)


    Hier kommt die Antwort mit der Lösung vom NC-Support:


    Edit: Ihr lagt also mit Euren "Timeouten" und "geblockt werden" absolut richtig!!