Mail account einrichten Debiam/Froxlor, Postfix/Dovecot

  • du könntest dir die dateien mit nano anschauen und raus kopieren bzw. markieren. dann hast auch gleich alle zeilenumbrüche drin.
    wie machst du das denn bitte, dass du keine zeilenumbrüche bekommst? also selbst bei cat kriegst ja welche.


    also nach den logs sieht es so aus als wäre der benutzername/email oder das passwort falsch. hast du das passwort mal geändert so dass da keine sonderzeichen, sondern nur zahlen und buchstaben drin sind?
    leider kann man daraus nicht mehr lesen, deswegen mach' mal bitte folgendes:


    geh mal bitte in die datei /etc/dovecot/dovecot.conf und füge folgendes am ende ein:

    Code
    auth_verbose = yes
    auth_verbose_passwords = yes
    auth_debug = yes
    auth_debug_passwords = yes
    verbose_ssl = yes


    !!!ÄNDERE oder schwärze nachdem du obiges gemacht hast dein passwort aus der mail.log bevor du sie hier nochmal postest!!!
    und dann versuch' dich erneut mit thunderbird einzuloggen (bitte direkt IP verwenden) und dann poste hier nochmal die neuen zeilen der datei /var/log/mail.log ab 16:02 uhr

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • In dieser Datei hatte ich noch:

    Code
    protocols = imap pop3mail_location = maildir:%h/maildirpop3_uidl_format = XuXvauth default {  mechanisms = plain
      userdb passwd {  }
      passdb pam {  }
      user = root}



    eingeügt gehabt. Habe es mit und ohne probiert jetzt. Kommt immer die Fehlermeldung bez. der Konfiguration.


    Das Passwort habe ich nur aus Zahlen und Buchstaben, keine Sonderzeichen.


    Ich bin in einer graphischen Oberfläche von SSH- Bitvise... wenn ich da eine beliebige Datei öffne gibt es da keine Zeilenumbrüche. Habe das hetzt etwas von der Hand formatiert.


  • die fehlermeldung wegen der conf kannst du ignorieren. es ist zwar nicht schön, aber es macht auch keinen unterschied. dovecot sagt nur dass die verwendeten einstellungen veraltet sind. stellt aber keine gefahr dar, ist halt nur nicht ganz so schick'.


    ...ich hätte vllt. erwähnen sollen, dass du dovecot neustarten musst nach dem einfügen von den log-befehlen.

    Code
    service dovecot restart


    alternativ:

    Code
    /etc/init.d/dovecot restart


    und versuch' dich dann nochmal mit thunderbird einzuloggen und poste dann nochmal die logs.

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • Ich habe jetzt mal andere Domain probiert. Da finden Thunderbird direkt mail.domain.tld jedoch kommt auch da eine Fehlermeldung. Auch wegen der Konfiguration.


    EDIT
    Unter Outlook werde ich jetzt bei der neuen Domain immer wieder um die Zugangsdaten gefragt anstelle von der Fehlermeldung. Die SMTP-Prüfung ist wohl erfolgreich, die IMAP nicht...
    OK, vllt. braucht der MX-Eintrag noch eine Weile...


    EDIT
    Outlook versendet keine Nachrichten, also SMTP funktioniert auch nicht.

  • Code
    Apr 13 16:48:30 v22014042143317921 dovecot: auth: plain(?,77.181.229.162,<Sa0Oqe32pABNteWi>): Username character disallowed by auth_username_chars: 0x3a (username: info@@8GAB0:5@.com)
    Apr 13 16:49:37 v22014042143317921 dovecot: auth: Debug: client out: FAIL#0111#011user=info@xn--80akhj1aedi7b.com
    Apr 13 16:49:37 v22014042143317921 dovecot: auth: Debug: client in: AUTH#0112#011PLAIN#011service=imap#011secured#011session=KlOxrO32sgBNteWi#011lip=5.45.109.226#011rip=77.181.229.162#011lport=143#011rport=52658#011resp=<hidden>


    da ist irgendwo ein doppelpunkt in deiner email mit der du dich anmeldest.
    und dovecot mag den namen des "benutzernamen" nicht, zumindestens nicht die des host. kannst du den mal umbennen? also info@IRGENDWAS anderes?

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • Also die Domain ist in Kyrillisch geschrieben, was als

    Code
    xn--80akhj1aedi7b.com

    entziffert wird. Da das Login dann auch kyrillische Zeichen enthält. hatte ich das mal mit kyrillischen Zeichen probiert, mal mit dem Umschreiben.


    Da das Problem daran liegen konnte, versuche ich einfach mal mit einer "normalen" Domain. Das klappt soweit aber auch nicht.

  • und das passwort? ist das auch kyrillisch oder lateinisch?

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • ich torfnase. du nutzt ja pam. (sofern du pam nicht vollständig umkonfiguriert hast) wird der fehler darin liegen, dass es den user info@xn--80akhj1aedi7b.com gar nicht geben kann. ersetzt bei thunderbird mal den benutzernamen durch den jeweiligen benutzer der auch im system hinterlegt ist. also einen nutzer der sich theoretisch auch auf dem system anmelden kann - je nach hinterlegter shell...
    solltest du das nicht wissen, schau hier nach welche user es gibt: /etc/passwd
    und ob den usern ein passwort vergeben ist siehst du in dieser datei /etc/shadow
    POSTE AUF KEINEN FALL DEN INHALT DER DATEIEN HIER!

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • Hi,
    also die Login-Daten wurden akzeptiert, ich habe auch eine Willkommens-Mail im Postfach. Nur klappt der Empfang und Versand trotzdem nicht.


    So langsam habe ich kein überblick mehr. Wie lösche ich denn jetzt postfix u.s.w. damit ich alles von neu einrichten kann?

  • Habe jetzt einfach mal die Konfigurationen aus dem Froxlor angewendet (davor ehrlich gesagt nicht gemacht).


    Beim Restart von Postfix bekomme ich mehrfach diese Meldung:

    Code
    postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=




    Was heißt das?

  • du kannst das hier mal einfügen in die main.cf bzw. das eben anpassen.

    Code
    smtpd_relay_restrictions = permit_mynetworks, permit_sasl_authenticated, defer_unauth_destination # standardwerte


    Postfix Configuration Parameters


    poste ansonsten nochmal deine main.cf


    und das mit dem "linux-"user hat nun geklappt?

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • arg! froxlor, natürlich....
    log dich mal im webinterface von froxlor ein und geh' dann mal auf server -> configuration und da wähl deine distri aus und geb' halt postfix und dovecot an. das musst du sowohl für postfix (smtp) machen als auch für dovecot (imap/pop3).
    froxlor spuckt dir dann das was du machen musst detailliert aus.
    und dann berichte nochmal ob das so geklappt hat...

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • Genau das habe ich auch gemacht und seit dem habe ich diese Fehlermeldung.

    Code
    postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_relay_restrictions=



    Die Konfigurationen habe ich alle 1 zu 1 übertragen und nur die Passwörter eingesetzt.

  • kommentier' die betreffende zeile einfach aus.


    also so:

    Code
    # Postfix 2.10 requires this option. Postfix < 2.10 ignores this.
    # The option is intentionally left empty.
    # smtpd_relay_restrictions =



    ich hab' gerade nochmal in meinem bücherlein nachgeschlagen, die warnung erscheint weil deine postfix den befehl noch gar nicht unterstützt.
    geraten müsstest du die version 2.9.6 haben und das ding gibt's erst ab 2.10


    edit:


    wir sind aber auch deppen... steht ja eigentlich schon in der fehlermeldung von postfix, ich ging aber davon aus, dass postfix hiermit die werte für den befehl meint und nicht den befehl selbst^^

    "Hmm, wo ist denn die Any-Key-Taste? Naja, ich bestell mir erst einmal ein Bier!" - Homer Simpson

  • OK,
    IMAP scheint zu funktionieren. Ich kann mich einloggen, aber der MX-Eintrag wurde noch nicht übernommen und ich kann nicht testen ob ich mails empfangen kann.
    Aber SMTP:

    Code
    Senden der Nachricht fehlgeschlagen.Die Nachricht konnte nicht gesendet werden, weil der Verbindungsaufbau mit dem SMTP-Server 5.45.109.226 fehlgeschlagen ist. Der Server ist entweder nicht verfügbar oder lehnt SMTP-Verbindungen ab. Bitte kontrollieren Sie die SMTP-Server-Einstellungen und versuchen Sie es nochmals oder kontaktieren Sie Ihren Netzwerkadministrator.