Keine Verbindung zu Microsoft und Mailjet E-Mail Server möglich

  • Hallo zusammen,


    wie ich hier beschrieben habe, kämpfe ich gerade mit dem Problem, dass ich von Microsoft ausgesperrt werde und überhaupt keine E-Mail an irgendeinen schicken kann, dessen E-Mail Server von Microsoft gehostet wird. Jetzt habe ich diesen Thread gefunden, in dem beschrieben wird, dass man für diesen Fall am besten einen Relayhost verwendet. Also habe ich Postfix so konfiguriert, dass alle Mails an Microschrott über Mailjet gesendet werden.

    Jetzt bin ich allerdings baff, weil ich nicht nur keine Verbindung zu irgendeinem MS E-Mail Server herstellen kann, sondern auch nicht zu Mailjet:

    Code
    root@myhost:~$ telnet in.mailjet.com 587
    Trying 104.199.96.85...
    telnet: Unable to connect to remote host: Connection timed out

    bzw.

    Code
    Dec 03 19:20:45 mail postfix/smtp[784]: E65642042963: to=<xxx@xxx.com>, relay=none, delay=1498, delays=1468/0.04/30/0, dsn=4.4.1, status=deferred (connect to in.mailjet.com[104.199.96.85]:587: Connection timed out)#015

    Irgendwas läuft doch total schief!? Mein Server ist auf keiner Blacklist (bis auf die altbekannte UCEPROTECTL3), alles ist korrekt eingerichtet und trotzdem kann ich keine Verbindung herstellen. Ich gehe davon aus, dass Mailjet nicht dieselbe Backlist verwendet wie Microsoft, trotzdem ist das Fehlerbild das gleiche.


    Übrigens ist das kein generelles Problem, zu anderen E-Mail Servern kann ich verbinden:

    Code
    Dec 02 10:38:30 mail postfix/smtp[3413]: AA72E20621FE: to=<xxx.xxx@xxx.de>, relay=rmail23.gadmail.de[195.200.34.244]:25, delay=3, delays=0.1/0.01/0.37/2.5, dsn=2.0.0, status=sent (250 ok:  Message 26190756 accepted)#015

    Woran soll das liegen?


    Gruß

    Jester

  • Die entsprechenden DNS records für die domain von der aus du da mailjet-relay nutzen willst, sind alle korrekt gesetzt und inzwischen durchpropagiert?

    Die domain ist bei mailjet inzwischen verifiziert?

  • Aber wieso muss ich da etwas eintragen? Da steht bei Mailjet nichts davon, dass das eine Verpflichtung ist:

    Quote

    Wir empfehlen Ihnen, die Domain oder Subdomain, die Sie verwenden werden, zu validieren, um die Qualität zu verbessern.

    Und das sollte doch unabhängig davon sein ob ich eine Telnet Verbindung aufbauen kann? Wenn ich das von meinem Rechner zu Hause mache geht das ja auch...

    Code
    jester@mypc:~$ telnet in.mailjet.com 587
    Trying 104.199.96.85...
    Connected to in.mailjet.com.
    Escape character is '^]'.
    220 in.mailjet.com ESMTP Mailjet
  • kannst du den mailjet anpingen?

    Ja

    Eventuell eine Firewall auf Deinem System, die die TCP-Verbindung auf diesem Port nicht zulässt?

    Kann nicht sein, dann würde ja auch kein anderer Server funktionieren. Abgesehen davon habe ich mal testweise einen Port bei mir zu Hause geöffnet, da geht es.


    Hast du es mal über Port 465 versucht?

    Ja, 25, 587, 465. Nix geht

  • Ich habe auch mal ein Ticket bei Mailjet geöffnet. Die verstehen auch schon das Problem gar nicht. Der Support Mitarbeiter fragt mich, ob ich sicher bin, dass ich von dieser IP Adresse komme, er sieht keine Verbindungsversuche im SMTP Server. :wacko:


    Die verstehen offensichtlich auch nicht, dass es einen Unterschied gibt zwischen der Port ist dicht, und die Verbindung wird vom Mailserver abgewiesen :pinch:

  • OK, die Aussage vom Mailjet ist, dass sie definitiv keine IP sperren, sondern lediglich durch eine Blocklist eine entsprechende Meldung zurückgeben. Und sie sehen logischerweise nicht, dass ich mich mit denen verbinde. Woran soll das denn jetzt liegen?

  • traceroute -T -p 587 in.mailjet.com funktioniert vom getesteten RS bei mir einwandfrei, Hops 2–5 sind identisch mit den im ersten Beispiel gezeigten Hosts. Vielleicht einen RDNS-Namen einsetzen, der mit einer eigenen Domäne übereinstimmt?

    VServer IOPS Comparison Sheet: https://docs.google.com/spreadsheets/d/1w38zM0Bwbd4VdDCQoi1buo2I-zpwg8e0wVzFGSPh3iE/edit?usp=sharing

    Edited 3 times, last by m_ueberall ().

  • traceroute -T -p 587 in.mailjet.com funktioniert vom getesteten RS bei mir einwandfrei...

    Bei mir auch.

    Code
    $ traceroute -T -p 587 in.mailjet.com
    traceroute to in.mailjet.com (104.199.96.85), 30 hops max, 60 byte packets
    1  194.36.144.3 (194.36.144.3)  0.307 ms  0.254 ms  0.236 ms
    2  94.16.25.76 (94.16.25.76)  0.511 ms  0.494 ms  0.470 ms
    3  ae2-0.bbr02.anx25.fra.de.anexia-it.net (144.208.208.141)  3.743 ms  3.836 ms  3.985 ms
    4  209.85.149.86 (209.85.149.86)  3.412 ms  3.452 ms  3.443 ms
    5  85.96.199.104.bc.googleusercontent.com (104.199.96.85)  10.468 ms  10.720 ms  10.237 ms
  • Ich habe die Änderung wieder rückgängig gemacht, weil der rDNS ja in erster Linie meinen Mailserver identifizieren soll und der ist ja wichtig. Für den Browser braucht es den Eintrag eh nicht.

  • Ich habe die Änderung wieder rückgängig gemacht, weil der rDNS ja in erster Linie meinen Mailserver identifizieren soll und der ist ja wichtig. Für den Browser braucht es den Eintrag eh nicht.

    Das meinte ich eigentlich; hatte mich unglücklich ausgedrückt. Wenn der zugehörige Name bereits drin stand, hätte ich hier keine Änderung erwartet.

    VServer IOPS Comparison Sheet: https://docs.google.com/spreadsheets/d/1w38zM0Bwbd4VdDCQoi1buo2I-zpwg8e0wVzFGSPh3iE/edit?usp=sharing

  • Hast du mal ins Rettungssystem gebootet und geprüft ob das Verhalten dort genau so ist?

    VPS 500 G8 Plus | VPS Karneval 2020 | Webhosting EiWoMiSau


    Dieses Gebäude hat mir die Vorfahrt genommen! *hup*

    Like 1