Domain für vServer und nginx

  • Hallo zusammen,


    ich betreibe einen vServer mit funktionierendem nginx als Webserver. Bisher laufen Owncloud und Wordpress und sind unter der Domain v22.nicesrv.de/owncloud und v22.nicesrv.de/wordpress erreichbar. Jetzt habe ich eine Zusatzdomain bei Netcup bestellt und im CCP den DNS-Eintrag * und @ per Typ A auf die Server-IP leiten lassen. Der Nameserver ist von Netcup.


    Die Weiterleitung klappt auch inzwischen, allerdings zeigt der Browser nicht die Domain, sondern man wird auf v22.nicesrv.de weitergeleitet. Ich hätte allerdings gerne, dass ich mit domain.de auf v22.nicesrv.de/wordpress zugreife. Owncloud kann erst mal unter v22.nicesrv.de/owncloud bleiben, aber gerne auch domain.de/owncloud.


    Die beiden Verzeichnisse liegen unter /var/www/owncloud bzw. /var/www/wordpress.


    In nginx habe ich 2 server eingerichtet. Einmal für Owncloud und v22.nicesrv.de generell:

    Code
    1. server {
    2. listen 443 ssl http2;
    3. listen [::]:433 ssl http2;
    4. server_name v22017104997653928.nicesrv.de;
    5. root /var/www/;
    6. location /owncloud {
    7. }
    8. }

    und dann für Wordpress, was unter domain.de abrufbar sein soll:

    Code
    1. server {
    2. listen 443 ssl http2 default_server;
    3. listen [::]:433 ssl http2;
    4. server_name www.domain.de domain.de;
    5. root /var/www/wordpress;
    6. ...
    7. }


    Habe ich ein Problem bei den DNS-Einstellungen, oder passen die vHosts von nginx nicht?


    Schon mal vielen Dank für Eure Unterstützung!

  • Wo genau sind denn die nginx configs gespeichert?


    Bzw. hast du daran gedacht, nginx zu restarten?


    /etc/init.d/nginx restart , oder service nginx restart


    Guck aber vorher, ob die configs fehlerfrei sind: nginx -t


    Sonst wäre es ineressant mal dein ganzes nginx Setting zu sehen.

  • WordPress leitet vermutlich noch auf die "alte" Adresse um, in dem Fall muss die neue Domain in den Einstellungen hinterlegt werden.

    Stimmt, wäre auch noch ne Option. In die Einstellungen wird er so nicht kommen.


    Kann man aber ohne Probleme in der wp-config.php ändern


    Code
    1. define('WP_HOME','http://domain.de');
    2. define('WP_SITEURL','http://domain.com');
  • Hallo Ihr beiden,

    das mit dem Umstellen der Domain in Wordpress war in guter Tipp. Ich habe es sowohl im Admin-Bereich, als auch in der wp-config geändert. Jetzt ist die Umleitung auf v22.nicesrv.de weg und die Domain bleibt stehen. Allerdings wird keine Datei von nginx geliefert, nur der header wird übertragen. Die error.log von nginx liefert Logs wie z.B.

    client xx.xx.xx.xx closed keepalive connection

    client closed connection while waiting for request, client: xx.xx.xx.xx, server: 0.0.0.0:443 ( <- Der Server ist komisch?!)


    Habt Ihr eine Idee, was das sein kann?

  • Manchmal mischt sich auch ein


    recv() failed (104: Connection reset by peer) while reading response header from upstream


    darunter. Das ergibt dann auch ein 502. Die anderen beiden logs sind 200, obwohl nichts gesendet wird.

  • Das ist aus der error.log von Nginx. Es gibt viele unterschiedliche Fehler, die aber alle in die gleiche Richtung gehen. Immer wenn der Client abbricht, ist der Status code 200 obwohl keine dateien angezeigt werden. Ist der Peer schuld, gibt es den status code 502.


    Kann es irgendetwas mit dem upstream zu tun haben? Der funktioniert allerdings für die v22.nicesrv.de domain ohne Probleme.

    Ich habe schon versucht, das keepalive_timeout von 70 auf 270 hochzusetzen. Allerdings hat das nichts geändert.


    Meine nginx.conf ist:

  • Hi Timon,


    ja, es gibt 2 configs. Die für Wordpress:

    Und die für Owncloud. Diese orientiert sich sehr stark an die Beispielconfig (aber hat mich sehr viel Schweiß gekostet):

    ssl.conf

    und die restrictions.conf

  • I made it work!


    There was a problem in the config for wordpress. The example config seems to not fit to my server. I exchanged

    Code
    1. # location ~ \.php$ {
    2. # #NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
    3. # include fastcgi_params;
    4. # fastcgi_intercept_errors on;
    5. # fastcgi_param HTTPS on;
    6. # fastcgi_pass php-handler;
    7. # fastcgi_buffers 16 16k;
    8. # fastcgi_buffer_size 32k;
    9. # }

    with