sieve Filer arbeitet nicht mehr

  • Hallo zusammen,


    ich habe mir vor ca. 6 Wochen einen Fehler ins System eingebaut und finde ihn nicht.

    Ankommende Spam-Mails werden durch Amavis korrekt "umbenannt", jedoch nicht mehr durch sieve verschoben.

    Das heist, das derzeit alle ankommenden Spams mit "***SPAM****" Markierung im Posteingang abgelegt werden.


    So weit ich das überblicken kann stimmen alle Einstellungen :-(

    Im mail.log sehe ich keine problembezogenen Fehler.


    Hat das jemand ein Idee ?


    Das Grundsystem wurde an diese Anleitung angelehnt: https://www.howtoforge.com/tut…nd-dovecot-ispconfig-3-1/

  • Ist der Sieve filter aktiviert? Man kann im System einen globalen Filter ablegen der als Default greift wenn für die EMail-Adresse kein gesonderter Filter-Regelweg hinterlegt ist. Pro eMail-Adresse kann immer nur ein Regelset aktiv sein.


    Sind ggf. mehrere Regelsets hinterlegt und der falsche davon aktiviert? Wird die Spamverschiebung im Default Regelset oder im Regelset speziell für das Mailpostfach definiert?


    Welche Mailclients werden verwendet? Wird ggf. ein Webmailer verwendet der filter regeln definieren kann? Unter Umständen wurde dadurch das Regelset überschrieben.

  • Ist der Sieve filter aktiviert? Man kann im System einen globalen Filter ablegen der als Default greift wenn für die EMail-Adresse kein gesonderter Filter-Regelweg hinterlegt ist. Pro eMail-Adresse kann immer nur ein Regelset aktiv sein.


    Sind ggf. mehrere Regelsets hinterlegt und der falsche davon aktiviert? Wird die Spamverschiebung im Default Regelset oder im Regelset speziell für das Mailpostfach definiert?


    Welche Mailclients werden verwendet? Wird ggf. ein Webmailer verwendet der filter regeln definieren kann? Unter Umständen wurde dadurch das Regelset überschrieben.

    re,

    ja, sieve läuft.

    Wir haben eine globale default.sieve config.

    diese ist im default Regelwerk gesetzt.


    Als (web)Mailclients nutzen wir wahlweise sogo oder roundcube.

  • Wie sieht das Default Regelset aus? Klappt der nur bei einem Postfach nicht, oder sind alle betroffen? Wurden durch SOGo und roundcube ggf für das betroffene Postfach neue regeln geschrieben? Am besten mal mit einem Sieve Client verbinden und schauen was da an Sieve Regeln für das Postfach geladen wird.

  • weder im Sogo noch im Roundcube dürfen mailuser sieve regeln anlegen.


    Das ist "die" Regel: (die Mailadresse wurde geändert)


    require ["body","fileinto","regex","envelope"];

    if header :contains "X-Spam-Flag" "YES" {

    fileinto "Junk";

    }


    if envelope "auth" "ping@pong.de" {

    fileinto "INBOX";

    stop;

    }


    if body :raw :regex ["filename=[ \"](.*?)\\.(exe|pif|scr|zip|hta|bat|cmd|reg|lnk|vbs|vbe|wcs|wbs|wsh|wsf|js|jse|ps1)[\";]"] {

    if not address :all :contains ["To", "Cc", "Bcc"] "ping@pong.de" {

    redirect "ping@pong.de";

    }

    }


    Dann schau ich mal nach einem Sieveclient - schon mal danke bis hier her.