serverseitiges Email-Problem - Gmail Mail-Handling mit eigener Domain in einer korrekt lauffähigen PHP mail() function

  • Hallo,

    es ist schon sehr spät, vllt. sehe ich deshalb vor lauter Bäumen den Wald nicht (und brauche bald eine neue Tastatur).
    Vielleicht bin ich aber auch einfach nicht kompetent genug :thumbsup:


    Das Problem:
    auf bla.net (Domainverwaltung im netcup CCP) nutze ich einen AJAX call um mit PHP's mail() function eine email zu senden.
    Die Funktion funktioniert auch 1A mit jeder anderen Mailadresse - ausser jenen mit Domain '(@)bla.net

    side-Info:

    Ich nutze die Domain mit Google Apps, bzw. GMail - habe demnach auch Google's MX Records setzen müssen - läuft! Über das GMail GUI kann ich eMails mit 'mail@bla.net' senden und empfangen.

    Sobald ich 'mail@bla.net' in die mail() Funktion baue, bekomme. 'unknown user: "mail@bla.net"' logfile-Einträge... An jede andere Adresse gehen die Mails durch.
    Ich gehe deshalb von einem serverseitigen Problem aus, für das ich aber keine Lösung finde. Oder können es immernoch DNS-Eintrag sein?

    Bitte nicht schimpfen!


    Ich danke euch!


    PS: Im Anhang ein Screenshot meiner DNS Setting für 'bla.net'


  • ich würde mal sagen du versuchst lokal eine email zuzustellen, wobei es diese email-adresse lokal gar nicht gibt, da sie am google-server liegt.
    du wirst wohl dem postfix mitteilen müssen, dass er für die domain loopband.de eigentlich nicht zuständig ist.

  • Die Domain wird auf dem Server wahrscheinlich u.a. als E-Mail Domain hinterlegt sein, deswegen ist der Server so "intelligent" und verschickt die Mails nicht per regulärem Verfahren sondern stellt sie lokal zu da er ja weiss das die Domain direkt auf dem gleichen Server liegt. Ggf. also, je nach verwendetem Panel, die Domaineinstellungen anpassen so das die Domain nicht als E-Mail Domain vorhanden ist. In Confixx und Froxlor geht das recht einfach.
  • Jup, danke. Domain war auch als eMail-Domain gesetzt...


    Kann man natürlich drauf kommen, aber in meinem Kopp waren die MX Records wahrscheinlich unbewusst prioritätshöher/wertiger als der kleine, mistige Haken im froxlor ;)


    Danke für's Kopfmachen...


    dv

  • Also ich habe den selben Ausgangspunkt wie der Threadersteller.


    Ich habe einfach Postfix auf dem Server am laufen.


    Dort habe ich dann einen Relayhost angegeben und nun werden alle Mails über dieses Relay an Google Mail geschickt und von dort geht es an den Zielort.


    Eine super Anleitung dazu gibt es hier:


    huschi.net - Mail-Relay


    (Dort aber den Kommentar beachten wenn es mit Google Mail arbeiten soll)

  • Schon selber gefunden:


    Von der Froxlor Übersicht: Sidepanel (unter Ressourcen) Domains -> Domain bearbeiten (unter Spalte Optionen - Logo:Papier mit Stift) -> E-Mail Domain (deaktivieren)