Fail2Ban Script für die VCP API

  • Also ich hatte es gestern auch mal wieder, das plötzlich ALLE Ports offen waren, und die FW irgendwie ignoriert wurde (den Bug hatte ich schon öfter, sollte mit der neuen FW eigentlich vorbei sein). Ich merke das immer schnell, da Port 80 bei mir eigentlich ZU ist. Kann ich die Index-Seite von ispCP erreichen, weiss ich, das die FW nicht korrekt funktioniert. Nach einem Neustart des Serves war alles wieder in Ordnung.

    9 von 10 Stimmen in meinem Kopf sagen ich bin nicht verrückt, die letzte summt ständig die Melodie von Tetris.

  • So Mail ist weg.
    Was ich nicht verstehe gestern hat das sehr gut funktioniert nur jetzt auf einmal nicht....


    EDIT:


    Das lustigste ist wen ich die einzenden Ports die ich in den Regeln freigebe deaktiviere sind dies gespert.. zumindest das funktioniert.

  • hej ho
    Das habe ich mir schon fast gedacht. Gibt es den eine möglichkeit jetzt die IP 46.38.232.136 zu speren?
    Den SSH port ist nicht freigegeben (zumindest komme ich nicht drauf) und trotzdem habe ich die ganze zeit:



    .... das geht kilometer so weiter in der LOG.....pro sec 2 versuche.....


    EDIT...
    Was mir grade mal so auffät... die ip ist meirner IP SEHR ähnlich @ Alex


    Die apocalypse der Deutschen Rechtschreibung ;)
    GIDF.DE Google ist dein Freund! :D

    The post was edited 2 times, last by DasUFO ().

  • Hallo,


    ich konnte das FirewallApi Skript wunderbar in Betrieb nehmen, scheitere jedoch bei der Integrierung durch Fail2ban. Mit der von mir angepassten jail.local und iptables-multiport.conf verweigert fail2ban das starten und logt auch auf Stufe 4 nichts in /var/log/fail2ban.log. Wenn ich /etc/fail2ban umbennene und fail2ban über apt-get neu installiere startet es wieder. Sieht jemand meinen Fehler in den config-Dateien oder kann villeicht seine bereit stellen ?


    Meine jail.local


    iptables-multiport.conf


    Der Übersicht halber ohne Kommentare, ich habe leider keine Spoilerfunktion gefunden.


    Grüße


    Slowly

  • Also ich habe es gerade mal versucht einzurichten und es hat auf Anhieb geklappt.
    Ich habe die Standard config benutzt und nur das abgeändert, was in der Anleitung stand. Mir ist aufgefallen, dass aber die anderen Aktionen in der iptables-multiport.conf ganz auskommentiert sind, sondern einen Leeren Wert zugeordnet sind:


    Code
    1. actionstart =
  • Vielen Danke thunderwave,


    das war tatsächlich der Fehler. Nach dem zuweisen der Aktionen auf ein Leerzeichen anstatt sie ganz auszukommentieren startet der Dienst und fail2ban funktioniert mit dem Skript wunderbar.


    Grüße


    Slowly

  • Ich hab gerade gemerkt, dass das Script bei mir nicht mehr funktioniert. Ich hab die Version 0.1.0. Wenn ich es manuel ausführe kommt folgende Fehlermeldung:



    Die hinterlegten Zugangsdaten sind richtig und es gibt auch keine fehlgeschlagene Loginversuche im VCP.


    Hat jemand dies Problem auch. Wird das Script noch weiterentwickelt? :S

  • Ich hab gerade gemerkt, dass das Script bei mir nicht mehr funktioniert. [...]
    Die hinterlegten Zugangsdaten sind richtig und es gibt auch keine fehlgeschlagene Loginversuche im VCP.


    Hab wohl verschlafen das zur Nutzung des Script neuerdings der "Webservice" im VCP aktiviert werden muss. Ein Blick in die Anleitung hat geholfen. :rolleyes:

  • Ich nutze das Script auch noch.
    Nur habe ich seit einiger Zeit das "Problem", dass ich beim löschen einer Firewallregel eine Fehlermeldung bekomme:
    Über Konsole:


    Über Fail2Ban_log:

    Code
    1. 2013-06-30 09:32:32,049 fail2ban.actions: WARNING [ssh] Unban 37.143.14.13
    2. 2013-06-30 09:32:32,341 fail2ban.actions.action: ERROR php -f /etc/fail2ban/firewallapi.php delete INPUT "37.143.14.13" DROP returned 100


    Das Script funktioniert aber trotzdem! Ich erhalte halt nur beim Löschen immer die Fehlermeldung.

  • hallo,
    bekomme nach der installation auch die fehlermeldung beim automatischen hinzufügen:


    2013-08-22 13:24:13,184 fail2ban.actions: WARNING [apache-404block] Ban 89.204.xxx.xxx
    2013-08-22 13:24:13,223 fail2ban.actions.action: ERROR php -f /etc/fail2ban/firewallapi.php add INPUT "89.204.xxx.xxx" DROP returned 100


    und es wird kein eintrag in der firewall erzeugt.


    tippe ich aber manuell in der console:


    php -f /etc/fail2ban/action.d/firewallapi.php add INPUT 42.42.42.42 DROP "a comment"


    ein, klappt alles wunderbar!?????????


    hat jemand einen tipp, wie man das beheben kann?


    danke!


    Quote

    fehler gefunden! pfad war falsch!!!!!