"fast CGI" statt "apache2handler" ? (pro vHost)

  • muss mich hier mal wieder als "absoluter Anfänger" outen:
    (irgendwann war jeder mal Anfänger)


    Für Joomla und andere CMS ist wohl doch besser "fast CGI" angesagt statt dem vorinstalliertem "apache2handler" zu verwenden...


    kann man das eigentlich nur global für den vServer umstellen oder irgendwie pro vHost / pro Kundenverzeichnis.


    muss ich dann phpmyAdmin auch neu installieren
    (dort wird ja während der Installation abgefragt welche PHP-API man hat),
    oder kann man das einfach in irgendwelchen .configs umstellen ... ?


    (sorry für "absoluter Anfänger") :love:

  • Moin


    Natürlich funktioniert auch eine gemischte Konfiguration.


    Du musst halt in jedem VHost genau sagen, welches php Du haben willst.
    Die globale Konfiguration sollte keine php-Konfiguration mehr enthalten. Sonst kommen sich die beiden in die Quere.


    An der phpMyAdmin-Konfiguration musst Du nichts ändern.
    Das sollte, abgesehen von den Zugriffsrechten im Dateisystem ohne Änderung laufen.


    Mordor

  • irgendwie verstehe ich das nicht so ganz,


    ich stelle mir das so vor wie hier beschrieben:
    --> How To Set Up Apache2 With mod_fcgid And PHP5 On Debian Lenny | HowtoForge - Linux Howtos and Tutorials
    [edit] bzw. hier: How To Set Up Apache2 With mod_fcgid And PHP5 On Debian Squeeze | HowtoForge - Linux Howtos and Tutorials
    ich muss demnach doch das Modul disable'n bevor ich die fcgi-Sachen enable'n kann, oder nicht ?


    nach deinen Worten kann apache2handler und fcgi quasi parallel laufen ?
    (oder habe ich dich missverstanden ?)


    [edit] hier mit Froxlor: Froxlor - FCGID - handbook - Froxlor

  • so ich habe das jetzt global umgestellt auf fCGI nach dieser Anleitung:
    --> Froxlor - FCGID - handbook - Froxlor


    es läuft auch alles bis auf 2 Kleinigkeiten/Merkwürdigkeiten:


    1) -------------------
    bei einem Server-Neustart (im VCP) startet der apache nicht mit:

    Code
    1. Starting web server: apache2apache2: bad user name EINER_DER_FROXLOR_KUNDENNAMEN
    2. Action 'start' failed.
    3. The Apache error log may have more information.
    4. failed!


    in "/var/log/apache2/*.log" steht aber nichts drin
    alle webs laufen naturgemäß nicht. (Wo muss ich noch schauen -in welche logs)


    wenn ich dann über die SSH (gleich danach) einen apache restart ausführe
    "/etc/init.d/apache2 restart"
    Startet der Apache normal und fehlerfrei.
    alle webs laufen dann.
    Wie kann das ein ? 8|



    2) -------------------
    phpmyadmin lässt sich nicht aufrufen,
    bzw. der browser möchte index.php downloaden statt darstellen.
    Es wurde installiert wie hier angegeben:
    --> PHPmyAdmin
    ( also mit includieren der "/etc/phpmyadmin/apache.conf" in die "/etc/apache2/apache2.config" )
    vor der Umstellung auf fCGI lief phpmyadmin auch schon einwandfrei.
    ( in der "/etc/phpmyadmin/apache.conf" steht ja auch als erste zeile "Alias /phpmyadmin /usr/share/phpmyadmin" )
    Das ist doch auch nur ne kleinigkeit, auf die ich jetzt nicht komme oder ? :whistling:

  • Moin


    zu 1)
    Vermutlich startet dein MySQL Server nicht schnell genug.
    Lass den mal früher starten, oder den Apache später.


    zu 2)
    Du musst phpmyadmnin im richtigen vhost einbinden und das Verzeichnis muss die richtigen Userrechte (wg. suexec) haben.


    Mordor

  • vielen Dank, Mordor.


    zu 1)
    Vermutlich startet dein MySQL Server nicht schnell genug.
    Lass den mal früher starten, oder den Apache später.

    Wie kann ich das machen ?
    ist das gemeint ? : Startup – netcup Wiki
    dort steht

    Quote

    ...Wenn in einem VServer Upstart eingesetzt wird...

    was ist "Upstart", wird es (schon) eingesetzt auf meinem vServer,
    oder muss/kann ich es nach installieren ?



    zu 2)
    Du musst phpmyadmnin im richtigen vhost einbinden und das Verzeichnis muss die richtigen Userrechte (wg. suexec) haben.

    ich habe es jetzt wie folgt gelöst:
    http://forum.froxlor.org/index…__view__findpost__p__5933
    Es funktioniert.
    (obwohl mir das komisch vorkommt)


    jetzt erscheint im phpmyadmin noch der Fehler:
    "Verbindung für den controluser, wie er in Ihrer Konfiguration angegeben ist, ist fehlgeschlagen."
    muss mal schauen, was das noch ist ...

  • so ich habe das jetzt global umgestellt auf fCGI nach dieser Anleitung:
    --> Froxlor - FCGID - handbook - Froxlor


    wollte für die nachwelt noch folgendes ergänzen:
    nachdem man auf fCGI umgestellt hat, muss man ggf die Datei "/etc/apache2/mods-available/fcgid.conf" überprüfen
    und den zusätzlichen Parameter "MaxRequestLen 33554432" eintragen (Zahl in byte)
    die Zahl z.B. so groß wählen, wie die "upload_max_filesize" in php (z.B. 32Mb = 33554432)
    --> mod_fcgid: HTTP request length 135714 (so far) exceeds MaxRequestLen (131072) | BlogTorrent
    (fehlt der Parameter (unter debian sqeeze) so kann man z.B. per php nur 128kByte hochladen...
    = default-Wert "MaxRequestLen 131072" )