Cronjobs werden nicht ausgeführt..

  • Hi,


    ich hoffe, hier kann mir jemand helfen - ich weiß nicht mehr, was ich noch tun soll... Ich habe per Webmin einen Cronjob erstellt - wenn ich es mit crontab -e prüfe, sieht dies auch korrekt aus:

    Quote

    0,2,4,6,8,10,12,14,16,18,20,22,24,26,28,30,32,34,36,38,40,42,44,46,48,50,52,54,56,58 * * * * /etc/webmin/status/monitor.pl

    Nur ein Beispiel, andere .sh, zB /root/OrdnerXY/script.sh werden auch nicht ausgeführt... Warum Webmin die Cronjobs so "hässlich" anlegt, weiß ich auch nicht, folgendes funktioniert aber genauso wenig:

    Quote


    */2 * * * * /etc/webmin/status/monitor.pl

    Wenn ich mit crontab -l nochmal prüfe, erhalte ich die Ausgabe mit Leerzeile am Ende, sollte also stimmen... Den cron-Daemon habe ich auch schon mit service cron restart neugestartet und laut service cron status läuft er auch (ich nutze Ubuntu 11.04 ;)).


    Wer weiß, woran's liegt? Ich habe leider keine Ahnung, woran es noch liegen könnte. :(


    Wenn ich das Script übrigens direkt ausführe oder den Cronjob über Webmin starte ("Run Now"), funktioniert es einwandfrei...



    Grüße. :S


    Und guten Rutsch!! ;)

  • Habe nun per crontab -e folgendes eingefügt (ganz oben):
    # shell und path
    SHELL=/bin/sh
    PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin


    Eine Mail habe ich nicht bekommen, nein.


    Jetzt zu den logs... Hm. Die /var/log/cron.log ist leider leer und */messages auch. Hier die letzten Zeilen aus dem syslog:


    :huh:

  • Ja, Leerzeile ist vorhanden. Wundert mich ja auch, dass da nichts funktioniert.. :wacko:


    Habe mal einen Ausschnitt der Shell angehängt. Da sieht man u. a. auch die Leerzeile sehr schön... ;)


    Idee? ?(

  • Leider kann ich hier nicht helfen. Aber im Großen und Ganzen finde ich dass die Ubuntu Image ziemlich buggy sind. Ich habe schon darauf verzichtet, Debian Image sind viel besser.

  • Habe ja einen aktuellen Snapshot und mich mal an den Support gewandt, vielleicht kann dieser helfen...


    Bin jetzt mal kurzfristig auf Debian Squeeze umgestiegen, mal abwarten, was der Support sagt. :wacko:


    Danke, für eure Hilfe, ich melde mich dann wieder!! :)


    @killerbees19:
    Hast du auch einen vServer bei netcup auf dem Ubuntu 11.04 läuft? Funktionieren bei dir die Crons? :)

  • So, Hi.. Habe jetzt mal Debian Squeeze (das Paket, wo Webmin gleich an Board ist ;)) über's VPC installiert.


    Folgendes habe ich schon installiert:
    * postfix (+ libsasl2-modules + dsb-mailx)
    * dnsmasq
    * openssl
    * ruby
    * weitere, kleinere pakete


    Die Cronjobs habe ich auch gleich wieder angelegt:

    Quote

    root@v2201112109917015:~# crontab -l
    0,2,4,6,8,10,12,14,16,18,20,22,24,26,28,30,32,34,36,38,40,42,44,46,48,50,52,54,56,58 * * * * /etc/webmin/status/monitor.pl
    @reboot /root/SiriProxy/SiriProxy_Upstart.sh > /root/SiriProxy/siriproxy.log 2>&1


    Wenn ich jetzt mit reboot über PuTTy neustarte, steht folgendes in der /var/log/syslog:


    Folgendes bekomme ich in der syslog, wenn ich über's VPC neustarte:

    8|