Server Monitoring-System aufsetzen

  • Dafür musst Du die graph_strategy auf CGI ändern. Das braucht aber auch einige Anpassungen beim Webserver. Falls kein Apache verwendet wird, brauchst Du dafür afaik auch noch spawn-fcgi. Dazu gibt es in der offiziellen Doku bzw. im Wiki einige Anleitungen.


    Edit: Siehe z.B. hier für Nginx. Wie aktuell das ist, weiß ich aber ehrlich gesagt nicht mehr… :D

  • Auf meinem Ubuntu 18 Server habe ich es nun hinbekommen:


    In /etc/munin/munin.conf auskommentiert bzw eingefügt:

    cgitmpdir /var/lib/munin/cgi-tmp

    graph_strategy cgi

    html_strategy cgi


    und in /etc/munin/apache24.conf im entsprechenden Abschnitt Require local ersetzt durch

    Require all granted

    Options FollowSymLinks SymLinksIfOwnerMatch


    Auf dem meinen Ubuntu 20.04 Server (weiterer munin-Master) klappt es nicht. Da bekomme ich noch einen 404.

    Auf diesem Server lief es aber von Anfang an mit munin nicht rund. Da habe ich überall rumpfriemeln müssen, damit ich die nodes überhaupt reinbekommen habe.

    Kann also sein, dass ich da Dinge unnötigerweise verstellt habe.