Port 25 ist nicht erreichbar

  • Guten Abend


    Ich stehe hier auf dem Schlauch und finde einfach nicht das Problem. Ich vermute mal das es was kleines ist. Ich bin einen neuen E-Mailserver am Aufbauen (Ähnlich wie der von Thomas Leister). Mein "alter" Mailserver ist eigentlich gleich aufgebaut und ich finde in der Konfiguration kein Unterschied. Es sind nur zwei dinge anders. Der Neue verwendet Postfix 3.4.1, der alte 3.3.2.

    Der zweite Unterschied: Auf dem neuen ist eine FailOver IP sowie eine vLAN IP eingerichtet.


    Code
    1. netstat -tulpn | grep :25

    findet leider nichts was auf den Port 25 lauscht. Auf meinem alten Server erhalte ich jeweils die beiden Public IPs (4/6) sowie die localhost IPs.


    Wenn ich meine main.cf anpasse, erhalte ich wenigstens Port 25. Ich verstehe jedoch nicht genau weshalb:

    Code
    1. # So ist der Port 25 dicht
    2. inet_interfaces = 127.0.0.1, ::1, 192.168.100.0/24, 91.XXX.XX.XX, 2a03:XXXX:XX:XXX::5
    3. # So ist der Port 25 offen.
    4. inet_interfaces = all

    Ich habe meine beiden Failover IP's eingetragen, da ich möchte das der E-Mailserver auf die FailoverIP hört. Hab ich dazu was vergessen?

  • Guten Abend


    Vielen Dank. Das war mein Fehler. Ich habe dies (192.168.100.0/24) Testweise mal eingefügt gehabt. Aber es ging auch vorher nicht ohne das.


    Ich habe die main.cf nun so:

    Code
    1. inet_interfaces = 127.0.0.1, ::1
    2. inet_interfaces = 91.XXX.XX.XX, 2a03:XXXX:XX:XXX::5

    Aber auch hier lauscht nichts auf Port 25. Sobald ich wieder all mache schon.


    gunnarh auf dem alten Server gabs weder vLAN noch FailOver

  • Was ich nun noch gemerkt habe:


    Wenn ich den Server aufstarte, lauscht der Server nicht auf Port 25


    Wenn ich nun jedoch den Service postfix neustarte, lauscht Postfix wieder auf den Port 25, aber nur bis zu einem reboot.

    Nach einem Neustart die Ausgabe:

    Nach dem Neustart vom Service

    Wie ihr seht ist der Status der selbe.


    In der mail.err/info:

    Code
    1. postmulti[1176]: fatal: parameter inet_interfaces: no local interface found for 2a03:XXXX:XX:XXX::5
    2. postmulti[1176]: fatal: parameter inet_interfaces: no local interface found for 2a03:XXXX:XX:XXX::5

    Ich denke dies ist der Fehler das mein IPv6 Interface nicht oben ist. Dachte so müsste aber wenigstens die IPv4 Adresse auf Port 25 hören.


    Meine Interface

    Code
    1. up ip -6 addr add 2a03:XXXX:XX:XXX::5/64 scope global dev ens3 preferred_lft 0

    Muss ich einfach ein Timer setzen damit Postfix erst nach 4 Sekunden order so hochfährt, oder ist der Eintrag in der interface falsch?

  • Zur Info: Ich habe ein 5 Sekunden Timer getestet aber ohne erfolg.


    Ich denke das hat mit meiner Sturheit zu tun das ich wollte das Postfix nur auf die Failover IPs hört :)

    Zumal die FailoverIPs einen anderen RDNS haben als die beiden normalen ServerIPs


    Installiert ist Debian 9.8.0

  • Wenn Postfix nur auf die Failover IP hören soll musst Du Dir aber auch noch einen Mechanismus ausdenken, wenn die Failover IP weg schwenkt. Das andere Vorgehen hätte den Vorteil, dass Du daran keinen Gedanken verschwenden musst.

  • Ergänzend:

    inet_interfaces = all

    http://www.postfix.org/postconf.5.html#inet_interfaces


    inet_protocols = all
    Alternativ

    inet_protocols = ipv4, ipv6

    http://www.postfix.org/postconf.5.html#inet_protocols


    smtp_bind_address = A.B.C.D

    smtp_bind_address6 = 2001:DB8:CCCC:DDDD::1

    Die Problematik bei Multihomed und IP-Aliased Servern ist, ihnen mitzuteilen mit welcher IP sie rausgehen dürfen.

    http://www.postfix.org/postconf.5.html#smtp_bind_address

  • Sind eingehende und ausgehende Mails mit dieser Konfiguration gleichzusetzen? Wenn ich eine IP festlege, muss auch der MX Hostname auf diese zeigen?

    Bezieht sich das auf mein Posting? Für eingehende Mails sollte der MX auf eine der IP-Adressen zeigen, auf die der SMTP-Server konfiguriert ist.


    Was ausgehende E-Mails anbelangt, beachte einerseits, dass Postfix das bind benützt und, dass die anderen (v6-)Adressen, die nicht zum Versand genützt werden sollen, „deprecated addresses“ sind. Für ausgehende Mails sollte, wenn SPF verwendet wird, diese IP mit entweder dem MX oder dem zusätzlichen „a:“ übereinstimmen.


    Ich hoffe, ich habe das einigermaßen verständlich erläutert. Falls nicht, bitte um eine konkretere Rückfrage.